请教高手怎样将MACD底背离选股公式的条件放宽一些,谢谢!

[飞 狐] 3744 1
设置
1196846 Lv.3

专栏

发表于 2011-10-18 19:05 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
请教高手怎样将MACD底背离选股公式的条件放宽,谢谢!

我用飞狐数据全推盘中用30分钟、15分、5分钟的级别选股预警,用MACD底背离作预警选股公式,但总有

一些符合条件的股票没选出。我是菜鸟不懂编程,请高手指点一下,将公式中的什么条件放宽一些,让更

的股票符合要求,就可以多选一些股票出来(粗选),以免符合条件的股票漏选,然后再用人工筛选符合

条件的股票,谢谢你的帮助!!
§83§ §83§ §83§   

MACD单底背离选股公式源码:
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
QM:=LLVBARS(MACD,QZQ+20);
MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);
XG1:=MACD<0 AND MACD>MQDZ
AND CLOSE=LLV(CLOSE,QZQ+20) AND MQDZ<0;
XG:REF(XG1,1)=1 AND MACD>REF(MACD,1);

MACD双底背离选股公式源码:
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
QZQ:=BARSLAST(REF(MACD,1)<0 AND MACD>0);
QM:=LLVBARS(MACD,QZQ+20);
MQDZ:=IF(QM>QZQ,REF(MACD,QM),0);
QF:=LLVBARS(DIFF,QZQ+20);
DQDZ:=IF(QF>QZQ,REF(DIFF,QF),0);

XG1:=MACD<0 AND MACD>MQDZ AND DIFF<0 AND DIFF>DQDZ
AND CLOSE=LLV(CLOSE,QZQ+20) AND MQDZ<0 AND DQDZ<0;
XG:REF(XG1,1)=1 AND MACD>REF(MACD,1);
来自 浙江省杭州市

举报

使用道具 扔鸡蛋 回复

1196846
Lv.3

专栏

发表于 2011-10-19 06:14 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省杭州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表