手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

彩色筹码主图(源码 贴图)

[通达信]
设置
33299 0 止损当果断 Lv.4 发表于 · 2011-11-16 10:51 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
彩色筹码主图,通达信。反正看看吧。量能平台和筹码分布,把东方的楚河汉界获利指标加上了。回复下,有些人的TDX版本太低了可能会报错哦。
筹码力量
002502.JPG
DA1:=IF(130>TOTALBARSCOUNT,TOTALBARSCOUNT,130);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);
LH10:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);
L1:=REFDATE(HHV(LH1,DA),DATE);
L2:=REFDATE(HHV(LH2,DA),DATE);
L3:=REFDATE(HHV(LH3,DA),DATE);
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);
STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT,HI*99/100,HI/GZ,9,0),
,COLOR002288,LINETHICK3;
STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,1)*99/100
,HI/POW(GZ,2),9,0),COLOR800600,LINETHICK3;
STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,2)*99/100
,HI/POW(GZ,3),9,0),COLOR808300,LINETHICK3;
STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,3)*99/100
,HI/POW(GZ,4),9,0),COLOR883D88,LINETHICK3;
STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,4)*99/100
,HI/POW(GZ,5),9,0),COLOR777700,LINETHICK3;
STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,5)*99/100
,HI/POW(GZ,6),9,0),COLOR804000,LINETHICK3;
STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,6)*99/100
,HI/POW(GZ,7),9,0),COLOR003377,LINETHICK3;
STICKLINE(CEILING(DA*L8/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,2),LO*POW(GZ,3)
*99/100,9,0),COLORLICYAN,LINETHICK3;
STICKLINE(CEILING(DA*L9/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,1),LO*POW(GZ,2)
*99/100,9,0),COLORLIMAGENTA,LINETHICK3;
STICKLINE(CEILING(DA*L10/SS)*3>=CURRBARSCOUNT,LO,LO*POW(GZ,1)*99/100,9,0)
,COLORBROWN,LINETHICK3;
DRAWKLINE(H,O,L,C);

DRAWKLINE(H,O,L,C);
DRAWTEXT(CURRBARSCOUNT=98,LOW*0.88,'☆压力越大暗条越长,做多越短越好★'),COLORYELLOW;
N:=10;
T1:=CONST(HHVBARS(V,10)),COLOR0000FF,LINETHICK1;
量能平台:IF(CURRBARSCOUNT<=N+15,CONST(IF(T1=0,C,REF(C,T1))),DRAWNULL)COLOR0000FF,LINETHICK2;
新量能点:IF(CURRBARSCOUNT=T1+1,量能平台,DRAWNULL),CIRCLEDOT,COLORLIGRAY,LINETHICK1;
DRAWTEXT(ISLASTBAR,量能平台,' 量能平台');

JJ:=(CLOSE+HIGH+LOW)/3;
A:=EMA(JJ,10);
B:=REF(A,1);            


持股区域:STICKLINE(A>B,A,B,2,0),COLORYELLOW;
持币区域:STICKLINE(A<B,A,B,2,0),COLORBLUE;

称帝:(COST(99)+COST(93)+COST(85))/3,COLORYELLOW,DOTLINE,LINETHICK1;
汉界:(COST(84)+COST(67)+COST(50))/3,COLORGREEN,DOTLINE,LINETHICK1;
楚河:(COST(16)+COST(34)+COST(49))/3,COLORRED,DOTLINE,LINETHICK1;
自刎:(COST(1)+COST(7)+COST(15))/3,COLORMAGENTA,DOTLINE,LINETHICK1;
汉界飘移:(汉界-REF(汉界,3))/REF(汉界,3)*100,COLORGREEN,NODRAW;
楚河飘移:(楚河-REF(楚河,3))/REF(楚河,3)*100,COLORRED,NODRAW;
DRAWTEXT_FIX(C>0,0.004,0.11,0,DYBLOCK),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(C>0,0.06,0.11,0,HYBLOCK),COLORRED,LINETHICK2;
DRAWTEXT_FIX(C>0,0.12,0.11,0,EXTERNSTR(0,1)),COLORWHITE,LINETHICK2;
主图显示
11.JPG

[ 本帖最后由 止损当果断 于 2011-11-16 12:51 编辑 ]

相关股票

开心的小锋
Lv.3
发表于 2012-3-19 21:59 复制 查看全部楼层
雾雨风
Lv.4
发表于 2012-3-19 20:39 复制 查看全部楼层
谢谢好指标。。。。。。。
天上火2009
Lv.3
发表于 2012-3-19 19:52 复制 查看全部楼层
感谢您.太美了.
来吧涨停
Lv.3
发表于 2012-3-19 09:10 复制 查看全部楼层
雪城L
Lv.3
发表于 2012-3-19 09:04 复制 查看全部楼层
这个不错,顶你。~~
李陈霖霏
Lv.3
发表于 2011-11-17 10:00 复制 查看全部楼层
这个不错,顶你!!!!!!!!!!!!!!!
彩红桥
Lv.5
发表于 2011-11-17 08:37 复制 查看全部楼层
谢 谢 分 享 !
麻牯鱼
Lv.7
发表于 2011-11-17 08:32 复制 查看全部楼层
非常不错,感谢你的分享!
纯律音乐
Lv.3
发表于 2011-11-17 00:41 复制 查看全部楼层
量能平台和筹码分布,把东方的楚河汉界获利指标加上了。
冠宇
Lv.5
发表于 2011-11-17 00:04 复制 查看全部楼层
第66行包含未来函数:cost
第67行包含未来函数:cost
第68行包含未来函数:cost
第69行包含未来函数:cost
短线游子
Lv.7
发表于 2011-11-16 22:42 复制 查看全部楼层
谢谢你的发帖!
龙门丹家
Lv.3
发表于 2011-11-16 22:25 复制 查看全部楼层
这个不错,顶你。~~
湖北老刘
Lv.4
发表于 2011-11-16 21:27 复制 查看全部楼层
不错的指标,顶上沙发不容易
老马重注册
Lv.4
发表于 2011-11-16 18:02 复制 查看全部楼层
这个不错,顶你。~~
老马重注册
Lv.4
发表于 2011-11-16 18:01 复制 查看全部楼层
这个不错,顶你。~~
一线生
Lv.4
发表于 2011-11-16 17:49 复制 查看全部楼层
指标不错,但是量能平台是什么意思?
邱sheng
Lv.5
发表于 2011-11-16 17:43 复制 查看全部楼层
这个不错,顶你。~~
卢子牛
Lv.2
发表于 2011-11-16 14:34 复制 查看全部楼层
相当不错的指标,不过副图能否一起奉献。
晓风027
Lv.3
发表于 2011-11-16 12:59 复制 查看全部楼层
帮顶!!!!!!!!!!!!!!
股海伐舟
Lv.5
发表于 2011-11-16 12:44 复制 查看全部楼层
换新版的软件吧,版本低的软件不行的。
富根
Lv.3
发表于 2011-11-16 12:07 复制 查看全部楼层
当前公式 : 彩色筹码 (指标画线公式)  
错误句 :
DRAWTEXT_FIX(C>0,0.004,0.11,0,DYBLOCK),COLORYELLOW,LINETHICK2
详细信息 : 您在括号前写的不是函数、公式等,
且缺少必要的运算符!
错误起始位置 : 3117 ; 长度: 3
冰心029
Lv.4
发表于 2011-11-16 12:05 复制 查看全部楼层
当前公式 : 筹~码~ (指标画线公式)  
错误句 :            


持股区域:STICKLINE(A>B,A,B,2,0),COLORYELLOW
详细信息 : 对不起,公式筹~码~输出不能超过16个!
错误起始位置 : 2633 ; 长度: 3
注定有横财
Lv.2
发表于 2011-11-16 11:14 复制 查看全部楼层
这个不错,顶你。~~
蓝狮异族
Lv.3
发表于 2011-11-16 11:09 复制 查看全部楼层
不错的指标,顶上沙发不容易
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表