KDJ周,月同时出现金叉选股公式

[通达信] 3623 2
设置
2598971 Lv.2

专栏

发表于 2012-5-24 15:10 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
月K:"KDJ.K"(89,3,3),COLOR00FF00; 月D:"KDJ.D"(89,3,3),COLOR00FF00,LINETHICK2; 周K:"KDJ.K"(27,3,3),COLORRED; 周D:"KDJ.D"(27,3,3),COLORRED,LINETHICK2; 日K:"KD.K"(5,3,3),COLORWHITE; 日D:"KD.D"(5,3,3),COLORWHITE,LINETHICK2; 日金叉:IF(CROSS(日K,日D),50,0),COLORFFFFFF; DRAWTEXT(日金叉,50,'日叉'),COLORFFFFFF; 周金叉:IF(CROSS(周K,周D),30,0),COLORRED; DRAWTEXT(周金叉,30,'周叉'),COLORRED; 月金叉:IF(CROSS(月K,月D),20,0),COLOR0080FF; DRAWTEXT(月金叉,20,'月叉'),COLORYELLOW; {KD在30以下多次金叉} JM:=CROSS("KDJ.K"(5,3,3),"KDJ.D"(5,3,3)); JMCOUNT:=COUNT(JM,BARSLAST("KDJ.D"(5,3,3)>=30)); JMTJ:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=1,21)=1); DRAWTEXT (JMTJ,70,'①'),COLORWHITE; JMTJ2:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=2,21)=1); DRAWTEXT (JMTJ2,70,'②'),COLORYELLOW; JMTJ3:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=3,21)=1); DRAWTEXT (JMTJ3,70,'③'),COLORYELLOW; JMTJ4:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=4,21)=1); DRAWTEXT (JMTJ4,70,'④'),COLORYELLOW; JMTJ5:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=5,21)=1); DRAWTEXT (JMTJ5,70,'⑤'),COLORYELLOW;  0,COLORYELLOW; DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26); DEA:=EMA(DIFF,9); MACD:=2*(DIFF-DEA); A1:=BARSLAST(REF(CROSS(DIFF,DEA),1)); B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA); MACD底背离:STICKLINE(FILTER(B1>0,5),0,0.75,3,0),COLORGREEN; DRAWTEXT(FILTER(B1>0,5),0.57,'MACD底背离'),COLORGREEN; RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100; K:=SMA(RSV,3,1); D:=SMA(K,3,1); A2:=BARSLAST(REF(CROSS(K,D),1)); B2:=REF(C,A2+1)>C AND REF(K,A2+1)<K AND CROSS(K,D); KDJ底背离:STICKLINE(FILTER(B2>0,5),0,1,3,0),COLORYELLOW; DRAWTEXT(FILTER(B2>0,5),0.80,'KDJ底背离'),COLORYELLOW; LC :=REF(CLOSE,1); RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100; RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100; A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1)); B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2); RSI底背离:STICKLINE(FILTER(B3>0,5),0,0.5,3,0),COLORWHITE; DRAWTEXT(FILTER(B3>0,5),0.25,'RSI底背离'),COLORWHITE; 2,COLORRED; C1:=BARSLAST(REF(CROSS(DEA,DIFF),1)); D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF); MACD顶背离:STICKLINE(FILTER(D1>0,5),2,1.25,3,0),COLOR0066FF; DRAWTEXT(FILTER(D1>0,5),1.47,'MACD顶背离'),COLOR0066FF; C2:=BARSLAST(REF(CROSS(D,K),1));D2:=REF(C,C2+1)<C AND REF(K,C2+1)>K AND CROSS(D,K); KDJ顶背离:STICKLINE(FILTER(D2>0,5),2,1,3,0),COLORRED; DRAWTEXT(FILTER(D2>0,5),1.2,'KDJ顶背离'),COLORRED; C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1)); D3:=REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1); RSI顶背离:STICKLINE(FILTER(D3>0,5),2,1.5,3,0),COLORFF00FF; DRAWTEXT(FILTER(D3>0,5),1.75,'RSI顶背离'),COLORFF00FF; 0,COLORFFA2AF; 20,COLORFFA2AF,POINTDOT; 50,COLORFFA2AF; 80,COLORFFA2AF,POINTDOT; 100,COLORFFA2AF;
来自 山东省济南市

举报

使用道具 扔鸡蛋 回复

1736814
Lv.7

专栏

发表于 2012-5-24 18:45 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 支持 扔鸡蛋 回复

2598971
Lv.2

专栏

发表于 2012-5-24 15:13 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河北省邢台市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
3楼
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表