请老师帮忙把MACD背离指标改成大智慧可用,谢谢!

[大智慧] 3234 1
设置
2420193 Lv.3

专栏

发表于 2012-5-24 16:28 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
MACD:(DIF-DEA)*2,COLORSTICK;
N:=5;
AA:=REF(DIF,N)=HHV(DIF,2*N+1);
BB:=BACKSET(AA,N+1);
CC:=FILTER(BB,N) AND DIF=HHV(DIF,N+1);
A1:=BARSLAST(REF(CC,1));
顶背离:REF(CLOSE,A1+1)<CLOSE AND REF(DIF,A1+1)>DIF AND CC,COLORRED,NODRAW;
DRAWLINE(CC,DIF,FILTER(顶背离>0,5),DIF,0),LINETHICK2,COLORRED;
DRAWTEXT(顶背离,DIF*1.1,'顶背离'),COLORRED;
AA2:=REF(DIF,N)=LLV(DIF,2*N+1);
BB2:=BACKSET(AA2,N+1);
CC2:=FILTER(BB2,N) AND DIF=LLV(DIF,N+1);
A2:=BARSLAST(REF(CC2,1));
底背离:REF(CLOSE,A2+1)>CLOSE AND REF(DIF,A2+1)<DIF AND CC2,COLORGREEN,NODRAW;
DRAWLINE(CC2,DIF,FILTER(底背离>0,5),DIF,0),LINETHICK2,COLORGREEN;
DRAWTEXT(底背离,DIF*0.99,'底背离'),COLORGREEN;
来自 云南省昆明市

举报

使用道具 扔鸡蛋 回复

1753330
Lv.5

专栏

发表于 2014-4-13 12:28 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省广元市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表