请老师帮我改写这个附图出现钱袋时选股公式

[通达信] 2488 1
设置
1306051 Lv.2

专栏

发表于 2012-5-25 11:06 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
请老师帮我改写这个附图出现钱袋时选股公式,谢谢!!


N:=EMA(C,20);
M:=EMA(C,60);

STICKLINE(CLOSE>=0,H,L,0,0),COLORFFFF00;
STICKLINE((CLOSE>=0 AND (C>=O)),O,C,3,1),COLORFFFF00;
STICKLINE((CLOSE>=0 AND (C<=O)),O,C,3,0),COLORFFFF00;


STICKLINE(CLOSE>N AND N>REF(N,1),H,L,0,0),COLOR0000A8;
STICKLINE((CLOSE>N AND N>REF(N,1) AND (C>=O)),O,C,3,1),COLOR0000A8;
STICKLINE((CLOSE>N AND N>REF(N,1) AND (C<=O)),O,C,3,0),COLOR0000A8;

STICKLINE(CLOSE<N AND CLOSE>M,H,L,0,0),COLOR00A800;
STICKLINE((CLOSE<N AND CLOSE>M AND (C>=O)),O,C,3,1),COLOR00A800;
STICKLINE((CLOSE<N AND CLOSE>M AND (C<=O)),O,C,3,0),COLOR00A800;


STICKLINE(CLOSE<M,H,L,0,0),COLORA80000;
STICKLINE((CLOSE<M AND (C>=O)),O,C,3,1),COLORA80000;
STICKLINE((CLOSE<M AND (C<=O)),O,C,3,0),COLORA80000;

STICKLINE(CLOSE>N AND N<M,H,L,0,0),COLOR54FCFC;
STICKLINE((CLOSE>N AND N<M AND (C>=O)),O,C,3,1),COLOR54FCFC;
STICKLINE((CLOSE>N AND N<M AND (C<=O)),O,C,3,0),COLOR54FCFC;



VAR1:=(C+H+O+L)/4;
卖出:=XMA(VAR1,20)*(1+80/1000);
买入:=XMA(VAR1,32)*(1-100/1000);
{买:CROSS(买入,LOW),NODRAW;
卖:CROSS(HIGH,卖出),NODRAW;}

高抛线:卖出,COLORGREEN,LINETHICK4;
低吸线:买入,COLORMAGENTA,LINETHICK4;
风险:100*(L-买入)/买入,NODRAW;
幅度:100*(卖出-买入)/买入,NODRAW;
MA1:=MA(VAR1,3);
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLOR007B00;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),2,0),COLOR009000;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),1,0),COLOR00A800;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLOR007B00;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),2,0),COLOR090000;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),1,0),COLOR00A800;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出<LOW,OPEN,CLOSE,3,0),COLOR007B00;
STICKLINE(卖出<LOW,OPEN,CLOSE,2,0),COLOR009000;
STICKLINE(卖出<LOW,OPEN,CLOSE,1,0),COLOR00A800;
STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),1.5,0),COLORCC66FF;
STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),1.5,0),COLORCC66FF;
STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORMAGENTA;
STICKLINE(买入>HIGH,OPEN,CLOSE,1.5,0),COLORMAGENTA;
STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
DRAWICON(CROSS(买入,LOW),LOW*0.95,11);
DRAWICON(CROSS(HIGH,卖出),HIGH*1.02,12);


MA5:EMA(CLOSE,5),COLORWHITE;
MA13:EMA(CLOSE,10),COLORFF00FF,LINETHICK2;
MA34:EMA(CLOSE,20),COLORBLUE,LINETHICK2;
MA55:EMA(CLOSE,60),COLORRED,LINETHICK3;
MA120:EMA(CLOSE,120),CIRCLEDOT,COLORGREEN;
MA250:EMA(CLOSE,250),CIRCLEDOT,COLOR0000FF;


月价托:=MA5>MA13 AND MA13>MA34 AND CROSS(MA5,MA13);
季价托:=MA13>MA55 AND MA5>MA13 AND MA34>MA120 AND CROSS(MA13,MA34);
短长价托:=MA5>MA250 AND MA13>MA34 AND MA34>MA55 AND CROSS(MA5,MA250);
DRAWICON(月价托,L-0.10,5);
DRAWICON(季价托,L-0.10,13);
DRAWICON(短长价托,L-0.10,18);


AAA:=BARSLAST(MA55>MA120 AND (MA34=MA55 OR MA34>MA55));
BB1:=REF(COUNT(C<MA120,AAA)=AAA,1);
CCC:=CROSS(C,MA120) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB1 AND CCC;
DRAWICON(芙蓉出水,L-0.10,9);




DRAWICON(CROSS(低吸线,MA55),低吸线,9);
DRAWICON(CROSS(高抛线,MA55),高抛线,9);
DRAWICON(CROSS(低吸线,MA34),低吸线,6);

附件

QQ截图20120525110059.png
来自 云南省楚雄州

举报

使用道具 扔鸡蛋 回复

1686251
Lv.6

专栏

发表于 2012-5-25 16:05 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省温州市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表