老师,能编个出现信号的的选股?谢谢

[通达信] 2590 2
设置
2343592 Lv.2

专栏

发表于 2012-5-25 12:47 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
源码:

n 1   30   6


MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA30:= MA(CLOSE,40);
MA60:=MA(CLOSE,60);
MA120:= MA(CLOSE,120);
VAR1:=ABS(MA5-MA20)/MA20*100<=N;
VAR2:=ABS(MA5-MA30)/MA30*100<=N;
VAR3:=MA5>REF(MA5,1);
VAR4:=MA20>REF(MA20,1);
VAR5:=MA30>REF(MA30,1);
DTPL:=MA20>MA30 AND MA30>MA120;
LYT:=DTPL AND VAR4 AND VAR5 AND COUNT(VAR3,4)<=1;
GJHS:=C>MA5 AND ((VAR3 AND NOT(REF(VAR3,1))) OR C>REF(C,3));
LYKK:=GJHS AND (VAR1 OR VAR2) AND LYT;
MAI:=(LYKK AND NOT(REF(LYKK,1)))*50 ;
VARC:=C=LLV(C,5)AND HHV(O,5)/C>=1.098 ;
VARD:=(C=HHV(C,4))AND REF(VARC,1);

YX:(MAI AND COUNT((MA10>MA20),5)=5) AND VARD;
来自 福建省福州市

举报

使用道具 扔鸡蛋 回复

1753330
Lv.5

专栏

发表于 2014-1-19 17:56 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省攀枝花市

举报

使用道具 支持 扔鸡蛋 回复

277912
Lv.6

专栏

发表于 2012-5-25 13:12 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省湖州市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
3楼
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表