求助老师把大知慧金山银山主图源码改成通达信主图源码。谢谢!

[大智慧] 4263 1
设置
2553264 Lv.2

专栏

发表于 2012-5-25 13:05 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
说明:大知慧金山银山主图源码改成通达信主图源码。谢谢!
源码:{大知慧金山银山主图源码}
diff:=ema(close,12)-ema(close,26);
dea:=ema(diff,9);
ma(c,8),colorwhite;
ma(c,21),coloryellow;
多头:stickline(diff>dea,c,o,8,0),colorred;
stickline(diff>dea,h,l,0,0),colorred;
空头:stickline(diff<=dea,c,o,8,0),COLORF0F000;
stickline(diff<=dea,h,l,0,0),COLORF0F000;
drawtext(cross(diff,dea),l-0.2,'买入'),colorwhite;
drawtext(cross(dea,diff),h+0.2,'卖出'),colorgreen;

W:=BARSLAST(DISPSTATUS=1);
P:=BACKSET(DISPSTATUS=2,W/2+1);
K:=BARSLAST(CROSS(P,0.5));
KJ:=HHVALL(HIGH)-LLVALL(LOW);
VERTLINE(CROSS(P,0.5),4),COLOR00FFFF;
平衡:LLVALL(LOW)+KJ/2,COLOR00FFFF,DOTLINE,linethick2,PRECIS2;
{FILLRGN(平衡,HHVALL(HIGH),W>K,RGB(0,0,200)),PRECIS2;{该行设置背景色}
压力:IF(K>=0,HHVALL(HIGH)-KJ*0.191,平衡),COLORFF00FF,DOTLINE,linethick3,PRECIS2;
支撑:IF(K>=0,LLVALL(LOW)+KJ*0.191,平衡),COLOR00FF00,DOTLINE,linethick3,PRECIS2;
低吸:K>=0 and CROSS(平衡,LOW),COLORFF8899,LINETHICK0,PRECIS2;
低涨:(C/LLV(LOW,W)-1)*100,COLOR0000FF,LINETHICK0,PRECIS2;
天:BARSLAST(L=LLV(LOW,W)),COLOR00FFFF,LINETHICK0,PRECIS0;
DRAWTEXT(HIGH=HHVALL(HIGH) and K>=0,HIGH*1.01,'←'+NUMTOSTRN(HIGH,2)),COLORFFFFFF;
DRAWICON(低吸,LOW,7);
{以下设置提示文字部分}
DRAWTEXT(K=67,HHVALL(HIGH)-KJ/8,'压力线为 0.809 !'),COLOR00FF00,ALIGN1;
DRAWTEXT(K=67,HHVALL(HIGH)-KJ/2.1,'平衡线为 0.500 !'),COLOR00FF00,ALIGN1;
DRAWTEXT(K=67,HHVALL(LOW)-KJ/1.2,'支撑线为 0.191 !'),COLOR00FF00,ALIGN1;
DRAWTEXT(DISPSTATUS=2,压力,'0.809'),COLOR0000FF,ALIGN0;
DRAWTEXT(DISPSTATUS=2,平衡,'0.500'),COLORFFFFFF,ALIGN0;
DRAWTEXT(DISPSTATUS=2,支撑,'0.191'),COLOR00FFFF,ALIGN0;
DRAWTEXT(K=0,HHVALL(HIGH)-KJ/12,'★强势区域--急拉减仓!'),COLOR00FF00,ALIGN1;
DRAWTEXT(K=0,HHVALL(HIGH)-KJ/3,'●震荡整理--寻机低吸!'),COLOR00FF00,ALIGN1;
DRAWTEXT(K=0,LLVALL(LOW)+KJ/3,'◆反弹中轨--逢高休息!'),COLOR00FF00,ALIGN1;
DRAWTEXT(K=0,LLVALL(LOW)+KJ/10,'■弱势区域--暂不参与!'),COLOR00FF00,ALIGN1;

附图:
2012-05-25_130353.png
来自 浙江省绍兴市

举报

使用道具 扔鸡蛋 回复

1686251
Lv.6

专栏

发表于 2012-5-25 15:56 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省温州市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表