求助老师把大知慧RYG副图源码改成通达信副图源码。谢谢!

[大智慧] 2766 2
设置
2553264 Lv.2

专栏

发表于 2012-5-25 19:19 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
说明:大知慧RYG副图指标源码改成通达信副图指标源码。谢谢!

RYG副图:
2012-05-25_130353.png

源码指标:{大知慧RYG副图源码}
INPUT:周期(15,1,100), 过滤(8,1,100),选股(-26, -30,-20),抄底(-40,-50,-25);
VAR2:=MA(CLOSE,5);
VAR3:=MA(CLOSE,10);
VAR4:=MA(CLOSE,20);
VAR5:=MA(CLOSE,30);
VAR6:=(VAR2+VAR3+VAR4+VAR5)/(4);
VAR7:=((VAR6-REF(VAR6,周期))/(REF(VAR6,周期)))*(100);
VAR8:=((VAR6-REF(VAR6,周期))/(REF(VAR6,周期)))*(100);
VAR9:=EMA(VAR7,过滤);

红包:IF((TROUGHBARS(3,15,1)=0) AND (HIGH>LOW+0.01),10,(-5)),Color00FF00;
反转:STICKLINE(Var9>1*REF(Var9, 1), Var7, 0, 5, 0), COLOREE00EE;
持股:STICKLINE(Var7>1*REF(Var7, 1), Var7, Var9, 5, 0), COLORRED;
持币:STICKLINE(Var7<1*REF(Var7, 1), Var7, Var9, 5, 1), COLORGREEN;
洗盘:STICKLINE(Var7<1*REF(Var7, 1) AND Var9>1*REF(Var9, 1), Var7, Var9, 10, 0), COLOR00EEFF;
VAR10:=((CLOSE-MA(CLOSE,58))/(MA(CLOSE,58)))*(100);
VAR11:=((VAR10>(1)*(REF(VAR10,1))) AND (VAR10<选股) AND (VAR10>抄底))*(1.5);
VAR12:=((VOL)/(CAPITAL))*(100);
VAR13:=LLVBARS(LOW,50);
VAR14:=SUM(VOL,VAR13);
VAR15:=HHVBARS(HIGH,50);
VAR16:=SUM(VOL,VAR15);
VAR17:=((CLOSE-REF(OPEN,VAR15))/(REF(OPEN,VAR15)))*(100);
VAR18:=((VAR16)/(CAPITAL))*(100);
VAR19:=((CLOSE-REF(OPEN,VAR13))/(REF(OPEN,VAR13)))*(100);
VAR20:=((VAR14)/(CAPITAL))*(100);
VAR21:=MA(CLOSE,3);
VAR22:=(REF(CLOSE,2))*(0.86500001);
VAR23:=(REF(CLOSE,13))*(0.77200001);
VAR24:=MIN(VAR22,VAR23);
VAR25:=MA(CLOSE,13);
抄底王:(IF(((CLOSE-VAR24)/(CLOSE)<0.02999999) AND (VAR17<(-35)) AND ((SUM(VAR12,5))/(5)<1.8),1,0))*(10),ColorFFFFFF;
DRAWTEXT(抄底王, 抄底王, ' 成功率90追 '), COLORFFAA00;
VAR26:=((CLOSE-REF(CLOSE,1))/(REF(CLOSE,1)))*(100);
VAR27:=(EMA(CLOSE,12)-EMA(CLOSE,26))*(100);
VAR28:=EMA(VAR27,9);
VAR29:=(2)*(VAR27-VAR28);
DRAWTEXT(Var27<(-50) AND Var26>7 AND Var27<Var28, (-10), '底'), COLORWHITE;
DRAWTEXT(Var27<(-50) AND Var26>7 AND Var27>=Var28, 5, '追'), COLORWHITE;
来自 浙江省绍兴市

举报

使用道具 扔鸡蛋 回复

2326951
Lv.3

专栏

发表于 2012-5-25 22:25 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 天津市

举报

使用道具 支持 扔鸡蛋 回复

7853
Lv.3

专栏

发表于 2012-5-25 20:33 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

附件

1.JPG
TEST.txt [预览]

1.72 KB, 下载次数: 1, 下载积分: 共享币 -10 个

来自 黑龙江省绥化市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
3楼
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表