求助老师把大知慧LCRS副图指标做个选股条件。谢谢!

[大智慧] 3432 0
设置
2553264 Lv.2

专栏

发表于 2012-5-26 08:15 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
选股公式名称:黑马选股
编写选股主要条件是绿柱[孕线]。
符合要求说明:为了清析解析下面LCRS指标我以划箭头线和方框文字方式一起来说明比较直观些:
一、首先符合图中的[“红方框1、文字]”。当日绿柱[孕线]必须在轴线50以下出现{注:轴线50请在编制后,在源码上注明一下可调“字样”}。
二、再符合图中“[红方框2、文字]”后,当日绿线柱[孕线]出现前必须连续三天向下但不包括当天。
三、然后要一、 二、符合的基础上,当日成立图中“[红方框3、文字]”要求绿柱当日最高点和最低点等于小于昨天的绿柱, “孕线”。
四、符合一、二、三、上述要求选股公式成立。谢谢!
附图说明:
2012-05-25_205920.png

附LCRS指标源码:a1:=1;
a2:=(5);
a3:=(((2 * CLOSE) + HIGH) + LOW) / 4;
a4:=LLV(LOW,34);  
a5:=HHV(HIGH,34);
a6:=EMA((((a3 - a4) / (a5 - a4)) * 100),13);
a7:=(EMA(((0.667 * (REF(a6,1))) + (0.333 * a6)),2)) * a1;
决策线:(EMA(a7,a2)) * a1,colorRed;
a8:=(HHV(HIGH,9)) - (LLV(LOW,9));
a9:=(HHV(HIGH,9)) - CLOSE;
a10:=CLOSE - (LLV(LOW,9));
a11:=((a9 / a8) * 100) - 70;
a12:=((CLOSE - (LLV(LOW,60))) / ((HHV(HIGH,60)) - (LLV(LOW,60)))) * 100;
a13:=SMA(((a10 / a8) * 100),3,1);
a14:=(SMA(a13,3,1)) - (SMA(a11,9,1));
a15:=IF((a14 > 100),(a14 - 100),0);
a16:=(EMA((((a3 - a4) / (a5 - a4)) * 100),8)) * a1;
a17:=(EMA(a16,5)) * a1;

STICKLINE(((a16 - a17) > 0),a16,a17,4,0),ColorFFAA18;
STICKLINE(((a16 - a17) < 0),a16,a17,4,0),ColorFFAA18;
a18:=(EMA(CLOSE,2)) * a1;  
a19:=(EMA((((SLOPE(CLOSE,21)) * 20) + CLOSE),42)) * a1;
a20:=(HHV((MA(HIGH,13)),13)) * a1;
a21:=(LLV((MA(HIGH,13)),1)) * a1;
a22:=(EMA(CLOSE,4)) * a1;
a23:=((((a18 >= a19) AND (a21 = a20)) AND (a18 > a22)) AND (CLOSE > a21)) AND ((REF(a21,1)) < (REF(a20,1)));
a24:=BARSLAST(a23) + 1;
a25:=(LLV(LOW,a24)) * 1.3;
a26:=(LLV(LOW,20)) * 1.418;
a27:=(((((a18 >= a19) AND (a21 = a20)) AND ((CLOSE / (REF(CLOSE,1))) >= 1.07)) AND (a24 <= 30)) AND (CLOSE <= a25)) AND (CLOSE <= a26);
a28:=a27 AND (FILTER(a27,a24));
a29:=(STRFIND(STKNAME,'ST',1)) > 0;
a30:=((((((a18 >= a19) AND (a21 = a20)) AND ((CLOSE / (REF(CLOSE,1))) >= 1.035)) AND (a24 <= 30)) AND (CLOSE <= a25)) AND (CLOSE <= a26)) AND a29;
a31:=a30 AND (FILTER(a30,20));
DRAWICON((a28 OR a31),决策线,7),ALIGN1;
DRAWTEXT((a28 OR a31),决策线,'←黑马'),colorRed;
{DRAWTEXTREL(3,30,'XXXX:XXXXXXXXX'),colorWhite;}
{DRAWTEXTREL(3,880,'说明:蓝柱在红线上逢低介入,蓝柱在红线下逢高离场。'),colorWhite;};
来自 浙江省绍兴市

举报

使用道具 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表