请教老师以下通达信指标为什么不能用?

[通达信] 3369 4
设置
181173 Lv.3

专栏

发表于 2012-5-26 09:08 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
生命线:=MA(C,60);
牛熊线:=MA(C,120);
DRAWBAND(生命线,RGB(200,50,55),牛熊线,RGB(0,100,50));
DRAWKLINE(H,O,L,C);
股价96:="Y395";
增幅96:=XMA(XMA(XMA(股价96,3),3),3)-REF(XMA(XMA(XMA(股价96,3),3),3),1);
X396:=XMA(股价96,3);
J396:=(XMA(股价96,3)*3+0.5*股价96-0.5*REF(股价96,1)+增幅96)/3;
Y396:IFF(CURRBARSCOUNT=1,J396,X396),LINETHICK2,COLORGREEN;
IF(Y396>REF(Y396,1),Y396,DRAWNULL),COLORRED,LINETHICK2;
高险区1:Y396*1.1,COLORLIRED,COLORFFFF00;
高风区2:Y396*1.125,COLORLIRED,COLORFF0000;
高风区3:Y396*1.15,COLORLIRED,COLOR00FF00;
良机区1:Y396*0.9,COLORLIBLUE,COLOR00FFFF;
良机区2:Y396*0.875,COLORLIBLUE,COLORFF00FF;
良机区3:Y396*0.85,COLOR0000FF;
WSR1:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
WSR2:=CROSS(WSR1,5);
WSR3:=CROSS(8,WSR1);
WSR4:=CROSS(WSR1,-5);
WSR5:=CROSS(WSR1,-8);
WSR6:=WSR3;
WSR7:=WSR4 OR WSR5;
WSR8:=WSR7 AND FILTER(WSR7,5);
WSR10:DRAWICON(WSR8,L-0.01,1);
WSR9:=WSR6 AND FILTER(WSR6,5);
WSR11:DRAWICON(WSR9,H+0.01,2);
WSR12:=O<良机区3;
DRAWICON(WSR12 AND FILTER(WSR12,12),L-0.03,9);
W1:=C>REF(C,1) AND MACD<REF(MACD,1) AND MACD>0 AND V<REF(V,1);
W2:=C>REF(C,1) AND MACD<0 AND MACD<REF(MACD,1) AND V<REF(V,1);
XG:=W1 OR W2;
VAR1:=AMOUNT/VOL/7;
VAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3:=SUM(AMOUNT,10)/VAR1/7;
VAR4:=DMA(VAR2,VOL/VAR3);
VAR5:=(CLOSE-VAR4)/VAR4*100,COLORLIMAGENTA;
XG1:=CROSS(VAR5,MA(VAR5,2)) AND VAR5<0 AND C<(HHV(H,5)*0.88) AND REF(O>C,1) AND REF(O>C,2);
XG3:=XG AND XG1 AND L<良机区1;
WSR13:=O>良机区3 AND L<良机区1 OR XG3;
DRAWICON(WSR13 AND FILTER(WSR13,10),L-0.03,23);
WSR14:=H>高风区3;DRAWICON(WSR14 AND FILTER(WSR14,15),H+0.03,19);
WSR15:=H<高风区3 AND H>高风区2;DRAWICON(WSR15 AND FILTER(WSR15,5),H+0.03,15);

WSR16:=(INDEXC-MA(INDEXC,3))/MA(INDEXC,3);
WSR17:=(INDEXC-MA(INDEXC,8))/MA(INDEXC,8);
WSR18:=(INDEXC-MA(INDEXC,18))/MA(INDEXC,18);
WSR19:=(WSR16 + WSR17 + WSR18)/3;

WSR20:=(C-MA(C,3))/MA(C,3);
WSR21:=(C-MA(C,8))/MA(C,8);
WSR22:=(C-MA(C,18))/MA(C,18);
WSR23:=(WSR20 + WSR21 + WSR22)/3;
WSR24:=(WSR19>REF(WSR19,1) AND CROSS(WSR23,WSR19))*50;

WSR25:=(INDEXC-MA(INDEXC,6))/MA(INDEXC,6);
WSR26:=(INDEXC-MA(INDEXC,12))/MA(INDEXC,12);
WSR27:=(INDEXC-MA(INDEXC,24))/MA(INDEXC,24);
WSR28:=(WSR25 + WSR26 + WSR27)/3;

WSR29:=(C-MA(C,6))/MA(C,6);
WSR30:=(C-MA(C,12))/MA(C,12);
WSR31:=(C-MA(C,24))/MA(C,24);
WSR32:=(WSR29 + WSR30 + WSR31)/3;
WSR33:=(WSR28>REF(WSR28,1) AND CROSS(WSR32,WSR28))*20;


WSR34:=(INDEXC-MA(INDEXC,13))/MA(INDEXC,13);
WSR35:=(INDEXC-MA(INDEXC,34))/MA(INDEXC,34);
WSR36:=(INDEXC-MA(INDEXC,55))/MA(INDEXC,55);
WSR37:=(WSR34 + WSR35 + WSR36)/3;

WSR38:=(C-MA(C,13))/MA(C,13);
WSR39:=(C-MA(C,34))/MA(C,34);
WSR40:=(C-MA(C,55))/MA(C,55);
WSR41:=(WSR38 + WSR39 + WSR40)/3;
WSR42:=(WSR37>REF(WSR37,1) AND CROSS(WSR41,WSR37));

WSR43:=(INDEXC-MA(INDEXC,13))/MA(INDEXC,13);
WSR44:=(INDEXC-MA(INDEXC,34))/MA(INDEXC,34);
WSR45:=(INDEXC-MA(INDEXC,55))/MA(INDEXC,55);
WSR46:=(WSR43 + WSR44 + WSR45)/3;

WSR47:=(C-MA(C,30))/MA(C,30);
WSR48:=(C-MA(C,60))/MA(C,60);
WSR49:=(C-MA(C,90))/MA(C,90);
WSR50:=(WSR47 + WSR48 + WSR49)/3;
WSR51:=(WSR46>REF(WSR46,1) AND CROSS(WSR50,WSR46));

WSR52:=(INDEXC-MA(INDEXC,34))/MA(INDEXC,34);
WSR53:=(INDEXC-MA(INDEXC,55))/MA(INDEXC,55);
WSR54:=(INDEXC-MA(INDEXC,89))/MA(INDEXC,89);
WSR55:=(WSR52 + WSR53 + WSR54)/3;

WSR56:=(C-MA(C,60))/MA(C,60);
WSR57:=(C-MA(C,120))/MA(C,120);
WSR58:=(C-MA(C,220))/MA(C,220);
WSR59:=(WSR56 + WSR57 + WSR58)/3;
WSR60:=(WSR59>REF(WSR59,1) AND CROSS(WSR59,WSR55));
WSR61:=WSR24 OR WSR33 OR WSR42 OR WSR51 OR WSR60;
DRAWTEXT(WSR61 AND H<Y396 AND FILTER(WSR61,5),良机区3,'★'),COLOR00FFFF;
DRAWTEXT(WSR61 AND H<Y396 AND FILTER(WSR61,5),良机区3*0.97,'机'),COLOR00FFFF;

时间之窗:=HHVBARS(ZIG(3,M)>REF(ZIG(3,M),1)
AND REF(ZIG(3,M), 1)<REF(ZIG(3,M), 2),N);
DRAWTEXT(时间之窗=2,L*0.94,'★3天'),COLORRED;
DRAWTEXT(时间之窗=4,H*1.06,'★5天'),COLORGREEN;
DRAWTEXT(时间之窗=7,L*0.94,'★8天'),COLORRED;
DRAWTEXT(时间之窗=12,H*1.06,'★13天'),COLORGREEN;
DRAWTEXT(时间之窗=20,L*0.94,'★21天'),COLORLIRED;
DRAWTEXT(时间之窗=33,H*1.06,'★34天'),COLORLIGREEN;
DRAWTEXT(时间之窗=54,L*0.94,'★55天'),COLORLIRED;
{DRAWTEXT(时间之窗=88,H*1.06,'★89天'),COLORLIGREEN;
DRAWTEXT(时间之窗=143,L*0.94,'★144天'),COLORLIRED;
DRAWTEXT(时间之窗=232,H*1.06,'★233天'),COLORLIGREEN;
DRAWTEXT(时间之窗=376,L*0.94,'★377天'),COLORLIRED;
DRAWTEXT(时间之窗=609,H*1.06,'★610天'),COLORLIGREEN; }

GET:=ZIG(3,3),COLORFFFFFF;
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'(A)'),COLORFFFF00;
DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'(B)'),COLORFF00FF;
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'(C)'),COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'⑴'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'⑵'),COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'⑶'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'⑷'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'⑸'),COLOR0000FF;
DRAWTEXT(EN2 AND DTJZ10=1,L*0.93,'Ⅰ'),COLORFF00FF;
DRAWTEXT(EX2 AND DTJD10=2,H*1.05,'Ⅱ'),COLORFFFF00;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.93,'Ⅲ'),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.03,'①'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.95,'②'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2)
AND EX2,H*1.03,'③'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.95,'④'),LINETHICK3,COLOR00FFFF;
V1:=(C+H+L)/3;
MA3:=MA(V1,2);
MA5:=MA(V1,5);
DRAWBAND(MA2,RGB(200,50,55),MA5,RGB(0,100,50));
IF(生命线>=牛熊线,生命线,DRAWNULL),COLORRED;  
IF(牛熊线>=生命线,牛熊线,DRAWNULL),COLORFF9900;
IF(生命线>=牛熊线,牛熊线,DRAWNULL),COLOR00FFFF;
IF(牛熊线>=生命线,生命线,DRAWNULL),COLOR00FF00;
DRAWTEXT_FIX(1,0.0,0.00,0,EXTERNSTR(0,1))COLOR0077FF;
来自 广东省深圳市

举报

使用道具 扔鸡蛋 回复

2095557
Lv.7

专栏

发表于 2012-5-26 10:45 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 支持 扔鸡蛋 回复

181173
Lv.3

专栏

发表于 2012-5-26 09:44 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省深圳市

举报

使用道具 点亮 支持 扔鸡蛋 回复

181173
Lv.3

专栏

发表于 2012-5-26 09:43 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省深圳市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2095557
Lv.7

专栏

发表于 2012-5-26 09:32 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
5楼
4楼
3楼
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表