当KDJ指标在共振出现时的红柱,做个选股公式

[通达信] 6530 6
设置
691969 Lv.3

专栏

发表于 2012-5-27 08:02 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
老师好!

在KDJ共振出现时的红柱,(指两柱合二为一时,出现的红柱)

未命名-KDJ.png


原码:

RSV1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
K1:=SMA(RSV1,5,1);
D1:=SMA(K1,5,1);
J1:=3*K1-2*D1;
AA1:=EMA(J1,5);
AA2:=REF(AA1,1);
STICKLINE(AA1>AA2,AA1,AA2,3,0),COLOR0055AA;
STICKLINE(AA1>AA2,AA1,AA2,2.3,0),COLOR0077CC;
STICKLINE(AA1>AA2,AA1,AA2,1.6,0),COLOR0099DD;
STICKLINE(AA1>AA2,AA1,AA2,1,0),COLOR01BEE7;
STICKLINE(AA1<=AA2,AA1,AA2,3,0),COLOR006600;
STICKLINE(AA1<=AA2,AA1,AA2,2.3,0),COLOR009900;
STICKLINE(AA1<=AA2,AA1,AA2,1.6,0),COLOR00BB00;
STICKLINE(AA1<=AA2,AA1,AA2,1,0),COLOR00CC00;
RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K2:=SMA(RSV2,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
STICKLINE(BB1>BB2,BB1,BB2,3,0),COLOR000045;
STICKLINE(BB1>BB2,BB1,BB2,2.3,0),COLOR000085;
STICKLINE(BB1>BB2,BB1,BB2,1.6,0),COLOR0000C5;
STICKLINE(BB1>BB2,BB1,BB2,1,0),COLOR0000E5;
STICKLINE(BB1<=BB2,BB1,BB2,3,0),COLOR353500;
STICKLINE(BB1<=BB2,BB1,BB2,2.3,0),COLOR555500;
STICKLINE(BB1<=BB2,BB1,BB2,1.6,0),COLOR757500;
STICKLINE(BB1<=BB2,BB1,BB2,1,0),COLOR858500;
DD:=AA1>AA2 AND BB1>BB2;
共振买入:DD AND NOT(REF(DD,1)) AND (AA1<50 OR BB1<50) ,LINETHICK0;
DRAWICON(共振买入,-5,1);
共振卖出:REF(DD,1)=1 AND NOT(DD),LINETHICK0;
DRWICON(共振卖出,105,2);

50,COLORRED;
100,COLORGRAY;
0,COLORWHITE;
80,COLORGREEN;
20,COLORYELLOW;

先谢过老师了!!!!!

[ 本帖最后由 杨尚尚 于 2012-5-27 22:10 编辑 ]
来自 浙江省台州市

举报

使用道具 扔鸡蛋 回复

1753330
Lv.5

专栏

发表于 2013-7-9 11:56 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市

举报

使用道具 支持 扔鸡蛋 回复

1753330
Lv.5

专栏

发表于 2012-6-23 20:08 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省成都市

举报

使用道具 支持 扔鸡蛋 回复

691969
Lv.3

专栏

发表于 2012-5-27 18:06 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省台州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1069971
Lv.2

专栏

发表于 2012-5-27 11:35 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖南省怀化市

举报

使用道具 支持 扔鸡蛋 回复

1500863
Lv.6

专栏

发表于 2012-5-27 09:30 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 陕西省咸阳市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2412790
Lv.3

专栏

发表于 2012-5-27 09:17 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省成都市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
7楼
6楼
5楼
4楼
3楼
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表