只买主升浪指标公式

[通达信] 6237 1
设置
2154350 Lv.1

专栏

发表于 2012-5-27 16:11 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
通达信只买主升浪指标公式股票软件源码如下:
VAR3:=LLV(HIGH,240);
VAR4:=((100 * (CLOSE - VAR3)) / VAR3);
VAR5:=REF(LLV(CLOSE,480),1);
VAR6:=REF(HHV(CLOSE,480),1);
VAR7:=((100 * (CLOSE - VAR5)) / (VAR6 - VAR5));
VAR8:=(((CLOSE - LLV(CLOSE,981)) / (HHV(CLOSE,981) - LLV(CLOSE,981))) * 100);
VAR9:=(((CLOSE - LLV(CLOSE,393)) / (HHV(CLOSE,393) - LLV(CLOSE,393))) * 100);
VARA:=(((CLOSE - LLV(LOW,981)) / (HHV(HIGH,981) - LLV(LOW,981))) * 100);
VARB:=(((CLOSE - LLV(LOW,393)) / (HHV(HIGH,393) - LLV(LOW,393))) * 100);
VARC:=(EMA(((100 * (CLOSE - LLV(LOW,100))) / (HHV(HIGH,100) - LLV(LOW,100))),5) / 4);
VARD:=IF((DATE < 1031231),IF((VARC > 23.16),VARC,0),0);
VARE:=(VARC < 1);
VARF:=VARD;
VAR10:=((VAR4 < 0) AND (VAR7 < 0));
VAR11:=1;
VAR12:=((((HIGH + LOW) + (CLOSE * 2)) / 4) * VAR11);
VAR13:=EMA(VAR12,21);
VAR14:=STD(VAR12,21);
VAR15:=((((((VAR12 - VAR13) / VAR14) * 100) + 200) / 4) * VAR11);
VAR16:=(((EMA(VAR15,89) - 25) * 1.56) * VAR11);
VAR17:=((EMA(VAR16,5) * 1.22) * VAR11);
VAR18:=(EMA(VAR17,3) * VAR11);
VAR19:=((3 * VAR17) - ((2 * VAR18) * VAR11));
VAR1A:=IF(((CROSS(VAR19,VAR17) AND CROSS(VAR19,VAR18)) AND CROSS(VAR17,VAR18)),1,0);
VAR1B:=IF(((CROSS(VAR17,VAR19) AND CROSS(VAR18,VAR19)) AND CROSS(VAR18,VAR17)),1,0);
买点:IF((FILTER(((((VAR8 = 0) AND VARE) AND VAR10) AND VAR1A),5) = 1),10,0),COLORRED;
卖点:IF((FILTER((((VAR8 = 100) AND VARF) AND VAR1B),5) = 1),10,0),COLORGREEN;
VAR1C:=(EMA(((100 * (CLOSE - LLV(LOW,100))) / (HHV(HIGH,100) - LLV(LOW,100))),13) / 4);
VAR1D:=(EMA(CLOSE,2) - EMA(CLOSE,89));
VAR1E:=EMA(VAR1D,30);
VAR1F:=((2 * (VAR1D - VAR1E)) * 10);
VAR20:=((POW(VAR1F,3) * 0.1) + POW(VAR1F,2));
VAR21:=SQRT(SQRT((((LOW * HIGH) * OPEN) * CLOSE)));
VAR22:=EMA((VAR21 * 0.97),3);
VAR23:=(((HIGH + LOW) + CLOSE) / 3);
VAR24:=((VAR23 - MA(VAR23,14)) / (0.015 * AVEDEV(VAR23,14)));
VAR25:=(IF(((YEAR < 2008) AND (VAR1F > 0.015)),VAR20,0) / 45);
庄拉线:VAR25,COLORYELLOW;
{股票公式网站 WWW.55188.COM}
VAR26:=(EMA(CLOSE,2) - EMA(CLOSE,150));
VAR27:=EMA(VAR26,100);
VAR28:=(2 * (VAR26 - VAR27));
VAR29:=((POW(VAR28,3) * 0.1) + POW(VAR28,1));
VAR2A:=SQRT(SQRT((((LOW * HIGH) * OPEN) * CLOSE)));
VAR2B:=EMA((VAR2A * 0.97),3);
VAR2C:=(((HIGH + LOW) + CLOSE) / 3);
VAR2D:=((VAR2C - MA(VAR2C,14)) / (0.015 * AVEDEV(VAR2C,14)));
黑马线:(IF((VAR28 > 0.1),VAR29,0) * 5),COLORRED;
比例:IF((BETWEEN((黑马线/庄拉线),0.9,1.05) AND 黑马线>25),50,0 );
量价线:(((CLOSE - MA(CLOSE,21)) / MA(CLOSE,21)) * 100),COLORFFFFFF;
VAR2E:=IF((FILTER(((量价线 > 0) AND (量价线 < 3)),5) = 1),12,0);
涨幅前兆:IF((FILTER(((((庄拉线 > 0) AND (庄拉线 < 0.5)) AND VAR2E) AND (VAR1C < 3)),10) = 1),10,0),COLORFFFFFF;
选股利器:IF((FILTER((((((((VAR2E > 0) AND (VAR1C < 2)) AND (庄拉线 > 0)) AND (庄拉线 < 1)) AND (黑马线 > 0)) AND (黑马线 < 1.5)) AND (VAR2E > 0)),5) = 1),10,0),COLORFF00FF;
DRAWICON((买点 > 0),10,1);
DRAWICON((卖点 > 0),10,2);
DRAWICON((涨幅前兆 > 0),10,1);
DRAWICON((选股利器 > 0),10,1);
量价先行:(10 * CROSS(量价线,0)),COLORFFFF00;
DRAWICON((量价先行 > 0),10,11);
庄拉主升浪:(30 * ((CROSS(庄拉线,黑马线) AND (黑马线 > 0)) AND (量价线 > 0))),LINETHICK3,COLORFF00FF;
DRAWICON((庄拉主升浪 > 0),30,8);

[ 本帖最后由 福阿德 于 2012-5-27 16:18 编辑 ]
来自 山东省烟台市

举报

使用道具 扔鸡蛋 回复

1753330
Lv.5

专栏

发表于 2014-2-6 20:09 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省攀枝花市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表