请老师把“第四根绿柱”副图指标改写成大智慧选股公式(感谢!)

[大智慧] 4322 2
设置
1511845 Lv.3

专栏

发表于 2012-5-28 15:40 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
下面附件图中红圈划出的为有效信号。
选股公式为——
当看到DIF线上穿DEA,同时出现黄色指示时,短线可以根据压力位和支撑位的提示买入。
感谢老师~~~


【副图指标源码】
{动态底部  顸誓N=1  120 13,M=1 120 3,P=30  30<=P<50};

DIF:EMA(CLOSE,6)-EMA(CLOSE,13);
DEA:EMA(DIF,5);
MACD:(DIF-DEA)*2,COLORSTICK;

DRAWTEXT(REF(MACD,1)>0 AND MACD<0,MACD-0.01,'1');
DRAWTEXT(REF(MACD,2)>0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'2');
DRAWTEXT(REF(MACD,3)>0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'3');
DRAWTEXT(REF(MACD,4)>0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'4');
DRAWTEXT(REF(MACD,5)>0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'5');
DRAWTEXT(REF(MACD,6)>0 AND REF(MACD,5)<0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'6');
绿线天:=BARSLAST(CROSS(DEA,DIF));
红线天:=BARSLAST(CROSS(DIF,DEA));
压力:REF(H,绿线天),LINETHICK0;
支撑:REF(O,红线天),LINETHICK0;

A2:=IF(CROSS(0,DEA),1,0);
A12:=IF(DIF>0 AND CROSS(DIF,DEA),1,0);
SS2:=IF(A2,SUM(A12,0),0);
SSB2:=HHV(SS2,0);
SSS2:=SUM(A12,0);
轴上第1次金叉:IF(SSS2-SSB2=1 AND SSS2>REF(SSS2,1),1,0),LINETHICK0;
DRAWICON(轴上第1次金叉,0.2,1);
破0轴: REF(DIF,1)>0 AND DIF<0,COLORGREEN,LINETHICK0;
DRAWICON(破0轴,0.1,2);
第四根绿柱:REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3) <=0 AND  MACD<=0 AND REF(MACD,4) >=0,COLORRED,LINETHICK0;
DRAWICON(第四根绿柱,0,11);

好趋势2:=MA((3*SMA((C-LLV(L,M))/(HHV(H,M)-LLV(L,M))*100,3,1)),2)
-MA((2*SMA(SMA((C-LLV(L,M))/(HHV(H,M)-LLV(L,M))*100,3,1),3,1)),2);
动态底部2:=IF(EMA(IF(L<=LLV(L,13),SMA(ABS(L-REF(L,1)),5,1)
/SMA(MAX(L-REF(L,1),0),5,1),0),3)*10 AND 好趋势2<REF(好趋势2,1)
AND 好趋势2<50,-5,-2.5);

好趋势:=MA((3*SMA((C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100,3,1)),2)
-MA((2*SMA(SMA((C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100,3,1),3,1)),2);
动态底部:=IF(EMA(IF(L<=LLV(L,13),SMA(ABS(L-REF(L,1)),5,1)
/SMA(MAX(L-REF(L,1),0),5,1),0),3)*10 AND 好趋势<REF(好趋势,1)
AND 好趋势<50,-5,-3);
买警:=IF(好趋势<=-3 AND 好趋势<REF(好趋势,1),-5,
IF(好趋势<=0 AND 好趋势<REF(好趋势,1),-4.9,
IF(好趋势<=3 AND 好趋势<REF(好趋势,1),-4.8,
IF(好趋势<=6 AND 好趋势<REF(好趋势,1),-4.6,
IF(好趋势<=9 AND 好趋势<REF(好趋势,1),-4.4,
IF(好趋势<=12 AND 好趋势<REF(好趋势,1),-4.2,
IF(好趋势<=15 AND 好趋势<REF(好趋势,1),-4.0,
IF(好趋势<=18 AND 好趋势<REF(好趋势,1),-3.8,
IF(好趋势<=21 AND 好趋势<REF(好趋势,1),-3.6,
IF(好趋势<=24 AND 好趋势<REF(好趋势,1),-3.4,
IF(好趋势<=27 AND 好趋势<REF(好趋势,1),-3.2,
IF(好趋势<=30 AND 好趋势<REF(好趋势,1),-3.1,0))))))))))));
CROSS(动态底部,-4) AND CROSS(动态底部2,-4) AND REF(买警,1)<-P/10
AND DYNAINFO(39)>0 AND DYNAINFO(17)>0 AND C<20;

[ 本帖最后由 郭猫猫 于 2012-5-28 16:20 编辑 ]

附件

2_120320204411_1.jpg
来自 河南省郑州市

举报

使用道具 扔鸡蛋 回复

1511845
Lv.3

专栏

发表于 2012-5-28 16:15 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省郑州市

举报

使用道具 支持 扔鸡蛋 回复

1511845
Lv.3

专栏

发表于 2012-5-28 16:12 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河南省郑州市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
3楼
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表