麻烦将这个大智慧分时买卖指标换成通达信可用

[通达信] 3635 3
设置
1712644 Lv.1

专栏

发表于 2012-5-28 16:11 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
公式如下:

VAR0:=VOL/CLOSE/2;
VAR1:=SUM(IF(VAR0 > 100 AND CLOSE > REF(CLOSE,1),VAR0,0),0);
VAR2:=SUM(IF(VAR0 > 100 AND CLOSE < REF(CLOSE,1),VAR0,0),0);
VAR3:=SUM(IF(VAR0 < 100 AND CLOSE > REF(CLOSE,1),VAR0,0),0);
VAR4:=SUM(IF(VAR0 < 100 AND CLOSE < REF(CLOSE,1),VAR0,0),0);
VAR5:=VAR1 + VAR2 + VAR3 + VAR4;
VAR6:=IF(BARSTATUS=2,100 * VAR1/VAR5,0);
VAR7:=IF(BARSTATUS=2,100 * VAR2/VAR5,0);
VAR8:=IF(BARSTATUS=2,100 * VAR3/VAR5,0);
VAR9:=IF(BARSTATUS=2,100 * VAR4/VAR5,0);
机构买盘:VAR1,LINETHICK3,COLORFF55FF;
机构卖盘:VAR2,LINETHICK3,COLORFFFF55;
散户买盘:VAR3,COLOR5555FF;
散户卖盘:VAR4,COLOR55FF55;
DRAWTEXTREL(950,870,'机构买盘'),COLORFF00ff;
DRAWTEXTREL(950,570,'机构卖盘'),COLORFFFF00;
DRAWTEXTREL(950,320,'散户买盘'),COLOR0000FF;
DRAWTEXTREL(950,50,'散户卖盘'),COLOR00FF00;
IF BARSTATUS=2 THEN BEGIN
DRAWTEXTREL(1030,870,'' + FLOOR(VAR6) + '%'),COLORFF00FF;
END
IF BARSTATUS=2 THEN BEGIN
LOOP0:=FLOOR(VAR7);
VAR10:='' + LOOP0;
VAR11:=VAR10 + '%';
DRAWTEXTREL(1030,570,VAR11),COLORFFFF00;
END
IF BARSTATUS=2 THEN BEGIN
LOOP1:=FLOOR(VAR8);
VAR12:='' + LOOP1;
VAR13:=VAR12 + '%';
DRAWTEXTREL(1030,320,VAR13),COLOR0000FF;
END
IF BARSTATUS=2 THEN BEGIN
LOOP2:=FLOOR(VAR9);
VAR14:='' + LOOP2;
VAR15:=VAR14 + '%';
DRAWTEXTREL(1030,50,VAR15),COLOR00FF00;
END;

[ 本帖最后由 南宫多情 于 2012-5-28 17:05 编辑 ]
来自 湖北省随州市

举报

使用道具 扔鸡蛋 回复

1712644
Lv.1

专栏

发表于 2012-5-28 19:39 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省随州市

举报

使用道具 支持 扔鸡蛋 回复

1402417
Lv.2

专栏

发表于 2012-5-28 17:55 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省苏州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1712644
Lv.1

专栏

发表于 2012-5-28 17:06 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖北省随州市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
4楼
3楼
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表