麻烦大师把这个主图指标做一个选股公式 谢谢 问题已经解决!

[通达信] 3486 3
设置
2455495 Lv.2

专栏

发表于 2012-5-28 19:06 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
麻烦大师把这个主图指标做一个选股公式  条件就是今日洋红色线价格和上个交易日洋红线价格相同做一个选股指标   原码:N:=10;
M:=1.5;
TR1:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=MA(TR1,10);
MEDIAN:= (HIGH + LOW) / 2;
X:=20;
MID :=MA(C,X);
UPPER: MID + 2*STD(CLOSE,X),COLORGRAY;
LOWER: MID - 2*STD(CLOSE,X),COLORGRAY;
HH:=MEDIAN + ATR * M;
LL:=MEDIAN - ATR * M;
W:=BARSLAST((HH>=HHV(HH,N)))-BARSLAST((LLV(LL,N)>=LL));
BBX:=LLV(HH,BARSLAST(W<0));
SSX:=HHV(LL,BARSLAST(W>0));
WW:=IF(W>0,BBX,IF(W<0,SSX,C));
STICKLINE(0>W,H,L,0,0),COLORRED;
STICKLINE(0>W AND C>O,O,C,3,1),COLORRED;
STICKLINE(0>W AND C<O,O,C,3,0),COLORRED;
STICKLINE(0<W,H,L,0,0),COLOR00AA00;
STICKLINE(0<W AND C>O,O,C,3,1),COLOR00AA00;
STICKLINE(0<W AND C<O,O,C,3,0),COLOR00AA00;
IF(W>0,WW,DRAWNULL),LINETHICK2,COLORBLUE;
IF(W<0,WW,DRAWNULL),LINETHICK2,COLORMAGENTA;

[ 本帖最后由 忧郁人格者 于 2012-5-28 21:02 编辑 ]

附件

未命名横盘.jpg
来自 上海市金山区

举报

使用道具 扔鸡蛋 回复

1753330
Lv.5

专栏

发表于 2014-4-9 16:32 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 上海市

举报

使用道具 支持 扔鸡蛋 回复

7853
Lv.3

专栏

发表于 2012-5-28 20:06 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

附件

TEST.txt [预览]

345 Bytes, 下载次数: 1, 下载积分: 共享币 -10 个

来自 黑龙江省绥化市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1758480
Lv.4

专栏

发表于 2012-5-28 20:02 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省广州市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
3楼
2楼
楼主
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表