请老师把“美人眼”指标修改下,通达信通不过! 已经解答,谢谢神风!

[通达信] 2871 2
设置
2592659 Lv.2

专栏

发表于 2012-5-28 20:55 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
DIFF1:=EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);

DEA1:=EMA(DIFF1,M);

MACD:=2*(DIFF1-DEA1);

DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG),colorff00ff,linethick2;

DEA : EMA(DIFF1,M),colorwhite,linethick2;



AH:HHV(DIFF1,55),COLOR6600ff,linethick2,layer0;

PARTLINE(ah,ah),COLORWHITE,POINTDOT,linethick2,layer0;

DRAWICON( ref(aH=diff1,1) and DIFF<REF(DIFF1,1),AH,8),ALIGN1;

AL:LLV(DIFF1,55),COLOR248a24,linethick2,layer0;

PARTLINE(al,Al),COLORWHITE,POINTDOT,linethick2,layer0;

DRAWICON( ref(al=diff1,1) and DIFF>REF(DIFF1,1),al,7),ALIGN1;



{●60零上金叉:IF(CROSS(DIFF,DEA) AND DIFF>0,0.3,0),COLOR6600ff,POINTDOT;

STICKLINE(●60零上金叉,DIFF,ah,4,0),COLOR6600ff;}

■零下金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.001,0.3,0),COLORWHITE,POINTDOT;

STICKLINE(■零下金叉,0.1,0.15,6,0),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

■二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,0.2,0),COLOR3C86CC,POINTDOT;

STICKLINE(■二次金叉,0.15,0.2,6,0),COLOR3C86CC;



A3:=CROSS(DIFF,DEA) AND DEA<0;

■零下二次金叉:IF(FILTER(COUNT(A3,21)=2,10) AND DEA<0,0.05,0),COLORF58F98,POINTDOT;

STICKLINE(■零下二次金叉,0.25,0.3,6,0),COLORF58F98;



A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

■底背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),0.1,0),COLORFFFF00;

底背离1:STICKLINE(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),0,AL,4,0),COLOR00FF00;

STICKLINE(■底背离,0.2,0.25,6,0),COLORFFFF00;

{DRAWLINE(A1=0,DEA,■底背离,DEA,0),COLORYELLOW};

{A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:STICKLINE(REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),0,DIFF,4,0),COLORBLACK;

DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN;}

[ 本帖最后由 凭栏品茗 于 2012-5-28 22:28 编辑 ]
来自 江苏省泰州市

举报

使用道具 扔鸡蛋 回复

1753330
Lv.5

专栏

发表于 2014-1-19 18:17 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省攀枝花市

举报

使用道具 支持 扔鸡蛋 回复

1758480
Lv.4

专栏

发表于 2012-5-28 21:05 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省广州市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
3楼
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表