诚求高手把飞狐副图寻庄MACD改成通达信公式

[通达信] 2890 2
设置
2037747 Lv.4

专栏

发表于 2012-5-28 22:26 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
拜托公式高手朋友帮我写:
飞狐源码:INPUT:N(14,1,60);
均价:=(2*C+(H-L)/2+L)/3;
价差:=SUM(均价-REF(均价,1),2)/2;
高低:=(均价+价差);
实价:=(高低+均价)/2;
ED1:=(2*C-2*REF(C,2)+REF(C,1));
ED2:=(2*C-0.4*REF(C,4)-0.4*REF(C,3)-1.1*REF(C,2)+0.9*REF(C,1));
操盘线:=SMA(SMA(ED1,3,1),3,1);
aa:=eMA(((SLOPE(实价,N)*20)+实价),N*3),COLORYELLOW;
bb:=eMA(((SLOPE(均价,N)*20)+均价),N*3),COLORYELLOW;
多空线:=(AA+bb)/2,COLORRED,PRECISION2;
行情1:=EMA(EMA(EMA((AA+BB)/2,7),21),63),COLORYELLOW,LINETHICK2;
AaA:=eMA(((SLOPE(实价,N*2)*20)+实价),n*6),COLORYELLOW,LINETHICK1;
BbB:=eMA(((SLOPE(均价,N*2)*20)+均价),n*6),COLORYELLOW,LINETHICK1;
行情2:=(AAA+BBB)/2,COLORWHITE,LINETHICK2;
行情线:=ema((行情1+行情2)/2,28),COLOR7F00FF,COLORYELLOW,LINETHICK2;
DDIF:多空线-行情线,COLORRED;
Ddea:MA(Ddif,3),COLORAAAA00;
DMACD:5*(DDIF-DDEA),LINETHICK;
STICKLINE(DMACD>=0,0,DMACD,5,1),COLOR00AA99,COLOR7F00FF;
STICKLINE(DMACD<0,0,DMACD,5,1),COLORGRAY;
FILLRGN(Ddif>DDEa,DDIf,DDEa),COLORBROWN;
FILLRGN(Ddif<DDEa,DDIf,DDEa),COLORAAAA00;
DIF:操盘线-行情线,COLORWHITE,PRECISION2;
DEA:MA(DIF,3),COLORGREEN,PRECISION2;
MACD:3*(DIF-DEA),COLORSTICK,LINETHICK2;
天:HHV(MA(DIF,1),56/2),COLOR7F00FF,LINEDOT;
地:llV(MA(DIF,1),56/2),COLOR00AA99,LINEDOT;
0;
谢谢
来自 辽宁省大连市

举报

使用道具 扔鸡蛋 回复

2591478
Lv.5

专栏

发表于 2012-8-4 20:54 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 安徽省滁州市

举报

使用道具 支持 扔鸡蛋 回复

2037747
Lv.4

专栏

发表于 2012-5-29 17:01 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 辽宁省大连市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
3楼
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表