请老师把【融胜基础主图】改为通达信可用。

[通达信] 2943 2
设置
1566674 Lv.2

专栏

发表于 2012-5-29 11:53 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
请老师把下面指标改为通达信可用。谢谢!
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上:(1+7/100)*DD,COLORgray;
疯:(1+14/100)*DD,COLORred;
下:(1-7/100)*DD,COLORgray;
中:(上+下)/2,colorf0f000;
A := DISPSTATUS=2;
DRAWTEXT(A AND 上,上,NUMTOSTRN(上,2)),ColorEA91B5;
PARTLINE(上 ,(上>REF(上,1))-1,rgb(0,255,200),1,rgb(255,0,255) ),LINETHICK1,LAYER0;
DRAWTEXT(A AND 疯,疯,NUMTOSTRN(疯,2)),ColorEA91B5;
DRAWTEXT(A AND 中,中,NUMTOSTRN(中,2)),ColorEA91B5;
PARTLINE(中 ,(中>REF(中,1))-1,rgb(0,255,200),1,rgb(255,0,255) ),LINETHICK1,LAYER0;
DRAWTEXT(A AND 下,下,NUMTOSTRN(下,2)),ColorEA91B5;STICKLINE(C>=O,C,O,  7,0),COLORred;
PARTLINE(下 ,(下>REF(下,1))-1,rgb(0,255,200),1,rgb(255,0,255) ),LINETHICK1,LAYER0;


【上市年】:=REF(YEAR,BARSCOUNT(C)-1);
【月】:=REF(MONTH,BARSCOUNT(C)-1);
【日】:=REF(DAY,BARSCOUNT(C)-1);
DRAWTEXTREL(1,16,'■上市日期:'+NUMTOSTRN(【上市年】,0)+'年'+NUMTOSTRN(【月】,0)+'月'+NUMTOSTRN(【日】,0)+'日'+' 上市后总交易天数:'+NUMTOSTRN(BARSCOUNT(C),0)+'天  '),ColorAAEEEE,LINETHICK1;
DRAWTEXTABS(1,29,'■主营业务:'+SELFSTRING('主营业务')),color00D7FF;
DRAWTEXTABS(1,50,'■主题库:'+SELFSTRING('主题投资')),COLOR00A5FF;
DRAWTEXTABS(1,72,'■所属板块:'+' '+BKNAME),COLORYELLOW,LINETHICK1;
DRAWTEXTABS(1,96,'■流通盘:'+capital/1000000+'亿'),COLORred,linethick1;
DRAWTEXTABS(1,116,'■行业:'+SELFSTRING('行业')),colorAAEEEE;

Inline:=EMA(C,250);
chips:Inline-(EMA(C,3)-Inline),COLORgray;


YF_DDI:=(AMOUNT / VOL);
YF_JJ:=((OPEN + CLOSE) / 2);
YF_PJJ:=0;
YF_DDING:=EMA(CLOSE,6);
YF_MMD:=MA(YF_DDING,1);
YF_XXD:=EMA(CLOSE,18);
YF_YYZ:=REF(YF_MMD,1);
YF_XXD1:=REF(YF_XXD,1);
YF_YYZ1:=BARSCOUNT(CLOSE);
YF_TDCG:=IF((YF_YYZ1 = 1),0,(((YF_MMD - YF_YYZ) / YF_YYZ) * 100));
YF_ZFD:=IF((YF_YYZ1 = 1),0,(((YF_XXD - YF_XXD1) / YF_XXD1) * 100));
YF_JSD2:=REF(CLOSE,1);
CLOSE1:=IF((YF_YYZ1 = 1),0,(((CLOSE - YF_JSD2) / YF_JSD2) * 100));
YF_JZDF:=IF((YF_YYZ1 = 1),((CLOSE + OPEN) / 2),YF_YYZ);
YF_DCGJ:=YF_MMD;
JJ0:=YF_YYZ;
JJ1:=REF(YF_MMD,2);
JJ2:=(((YF_DCGJ + JJ0) + JJ1) / 3);
JJ02:=(((ABS((YF_DCGJ - JJ2)) + ABS((JJ0 - JJ2))) + ABS((JJ1 - JJ2))) / 3);
SS:=REF(YF_TDCG,1);
YF_ZFD1:=REF(YF_TDCG,2);
YF_ZFD2:=IF((YF_YYZ1 < 3),0,((JJ02 / YF_DCGJ) * 100));
YF_DHPXS:=IF((YF_YYZ1 < 3),0,IF((((YF_TDCG < 0) AND (SS < 0)) AND (YF_ZFD1 < 0)),(0 - 1),1));
SS:=REF(YF_TDCG,1);
YF_YZFZ:=IF((((YF_YYZ1 > 11) AND (SS < 0)) AND (YF_TDCG > 0)),1,0);
YF_JSD21:=BARSLAST((YF_YZFZ = 1));
YF_JSD:=REF(YF_JSD21,1);
A:=IF((((YF_YYZ1 > 11) AND (SS < 0)) AND (YF_TDCG > 0)),(YF_JSD + 1),YF_JSD);
YF_PJJ:=IF((((YF_YYZ1 > 11) AND (SS > 0)) AND (YF_TDCG < 0)),1,0);
YF_JSD11:=YF_JZDF;
DMRJ:=YF_JZDF;
DMCJ:=IF(((YF_YYZ1 > 11) AND (YF_JSD11 < OPEN)),OPEN,YF_JZDF);
YF_DMRJ:=IF(((YF_YYZ1 > 11) AND (DMRJ > OPEN)),OPEN,YF_JZDF);
YF_DMCJ:=0;
YF_DCG1:=REF(YF_JZDF,1);
YF_BDF5:=IF(((((YF_TDCG > 0.5) AND ((YF_ZFD2 > 0.215) OR (LOW > YF_JZDF))) AND (CLOSE >= OPEN)) AND ((CLOSE >= 200) OR ((CLOSE < 200) AND (CLOSE1 < 11)))),1,0);
YF_DMR:=IF((((YF_TDCG < (0 - 0.3)) AND ((YF_ZFD2 > 0.2) OR (HIGH < YF_JZDF))) AND ((OPEN >= CLOSE) OR (CLOSE1 < (0 - 1)))),1,0);
YF_DKS1:=BARSSINCE(YF_BDF5);
YF_TDMR:=BARSSINCE(YF_DMR);
YF_DMR:=(YF_DMR OR (BARPOS = 1));
YF_DCGJ1:=((COUNT(YF_BDF5,BARSLAST(YF_DMR)) = 1) AND YF_BDF5);
YF_DMRBUY:=((COUNT(YF_DMR,BARSLAST(YF_BDF5)) = 1) AND YF_DMR);
YF_DMCSELL:=BARSLAST(YF_DMRBUY);
YF_DCG10:=BARSLAST(YF_DCGJ1);
YF_DCG11:=((SUM(YF_DMRBUY,YF_DCG10) = 0) * YF_DCG10);
YF_DCGREAL:=REF(DMCJ,YF_DCG11);
YF_DMRJ11:=REF(YF_DCGREAL,1);
YF_DMRJ1:=IF((YF_DCGJ1 = 1),(((CLOSE - DMCJ) / DMCJ) * 100),(((YF_DMRJ - YF_DMRJ11) / YF_DMRJ11) * 100));
YF_DCG:=IF((((YF_DCG11 = 0) AND (YF_DCGJ1 = 0)) AND (YF_DMRBUY = 0)),0,YF_DMRJ1);
短买入:YF_DCGJ1,LINETHICK0;
短卖出:YF_DMRBUY,LINETHICK0;
短持股:YF_DCG11,LINETHICK0;
短持股1:=YF_DCG;
短本次收益:=IF((短买入 = 1),YF_DCGREAL,IF(((短持股 <> 0) OR (短卖出 = 1)),YF_DMRJ11,0));
短买价:=IF((短卖出 = 1),YF_DMRJ,0);
STICKLINE((短买入 = 1),OPEN,CLOSE,8,0),colorFF99FF;
STICKLINE((短买入 = 1),OPEN,CLOSE,6,0),colorFF00FF;
STICKLINE((短买入 = 1),OPEN,CLOSE,4,0),color9900FF;
STICKLINE((短买入 = 1),OPEN,CLOSE,2,0),colorFF0000;
STICKLINE((短持股 > 0),OPEN,CLOSE,0,0),colorFFBBFF;
STICKLINE((短持股 > 0),OPEN,CLOSE,8,0),colorFF00FF;
STICKLINE((短持股 > 0),OPEN,CLOSE,7,0),colorFF22FF;
STICKLINE((短持股 > 0),OPEN,CLOSE,6,0),colorFF44FF;
STICKLINE((短持股 > 0),OPEN,CLOSE,5,0),colorFF66FF;
STICKLINE((短持股 > 0),OPEN,CLOSE,4,0),colorFF88FF;
STICKLINE((短持股 > 0),OPEN,CLOSE,3,0),colorFF99FF;
STICKLINE((短持股 > 0),OPEN,CLOSE,2,0),colorFFAAFF;
STICKLINE((短持股 > 0),OPEN,CLOSE,1,0),colorFFBBFF;
STICKLINE((短卖出 = 1),OPEN,CLOSE,0,0),colorFF0000;
STICKLINE((短卖出 = 1),OPEN,CLOSE,8,0),color880000;
STICKLINE((短卖出 = 1),OPEN,CLOSE,7,0),color990000;
STICKLINE((短卖出 = 1),OPEN,CLOSE,6,0),colorAA0000;
STICKLINE((短卖出 = 1),OPEN,CLOSE,5,0),colorBB0000;
STICKLINE((短卖出 = 1),OPEN,CLOSE,4,0),colorCC0000;
STICKLINE((短卖出 = 1),OPEN,CLOSE,3,0),colorDD0000;
STICKLINE((短卖出 = 1),OPEN,CLOSE,2,0),colorEE0000;
STICKLINE((短卖出 = 1),OPEN,CLOSE,1,0),colorFF0000;
DRAWICON((短买入 = 1),LOW,1),ALIGN1;
DRAWICON((短卖出 = 1),HIGH,2),ALIGN2;
短操盘状态:IF((短买入 = 1),1,IF((短持股 > 0),2,IF((短卖出 = 1),9,0))),LINETHICK0;
明日空间买卖点:EMA(CLOSE,6),LINETHICK0;


最低:LLV(C,20),POINTDOT,COLOR00FFFF;
A1:=C/REF(C,1)>1.05;
A2:=O=L;
A3:=VOL<ref(VOL,1);
MTM:=A1 and A2 and A3;

DRAWTEXT(MTM,h,'今买'),COLORYELLOW;

庄家送礼:=C-O>=0 AND O/L>1.05 AND L<=LLV(L,25);
DRAWTEXT(庄家送礼,H,'送礼'),COLORYELLOW;

YX:=count(c<o,5)>=4 and
c/ref(c,5)<0.85 and
c<ma(c,5) and
(MA(CLOSE,5)-C)/MA(CLOSE,5)<0.2 and
ma(c,20)>ref(ma(c,20),1);
DRAWTEXT(YX,H,'第二天抢反弹'),COLORRED;
来自 四川省成都市

举报

使用道具 扔鸡蛋 回复

1869097
Lv.2

专栏

发表于 2013-5-16 11:59 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省广州市南沙区

举报

使用道具 支持 扔鸡蛋 回复

1390008
Lv.3

专栏

发表于 2012-6-4 09:53 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 吉林省通化市集安市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
3楼
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表