请老师帮忙看下公式里面的BT参数为何没显示

[通达信] 4041 2
设置
2605524 Lv.3

专栏

发表于 2012-5-29 14:51 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
老师,你好,朋友给了个选股公式,里面有个参数BT,在有些股票里可以随时显示,而有些股票在当天或往前几天都无显示,请问是什么原因,谢谢
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*10;
K:SMA(RSV,3,1);
D:SMA(K,3,1);
J:3*K-2*D;
IF(J<0,J,DRAWNULL),COLORGREEN,LINETHICK2;
IF(K>90,K,DRAWNULL),COLOR0000FF,LINETHICK2;
IF(D>85,D,DRAWNULL),COLORFFFF11,LINETHICK2;
2, COLORCC6633,LINETHICK2;
5, POINTDOT;
10,COLORRED,LINETHICK2;
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0),COLOR00FF00;
BT:(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
STICKLINE(UP,0,0.2,3,0),COLOR0000FF;
STICKLINE(DOWN,0,0.2,3,0),COLOR00FF00;
STICKLINE(BT,0,3,2,0),COLOR000088;
STICKLINE(BT,0,3,1,0),COLOR0000CC;
STICKLINE(BT,0,3,0.22,0),COLOR0000FF;
DRAWTEXT(BT,3,'短牛'),COLOR0000FF;
TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
STICKLINE(TJ1,0,2,3,0),COLOR880088;
STICKLINE(TJ1,0,2,1.5,0),COLORAA00AA;
STICKLINE(TJ1,0,2,0.8,0),COLORCC00CC;
STICKLINE(TJ1,0,2,0.2,0),COLORFF00FF;
DRAWTEXT(TJ1,2,'中牛'),COLORFF00FF;
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
STICKLINE(TJ2,0,1,5,0),COLOR008888;
STICKLINE(TJ2,0,1,2,0),COLOR00AAAA;
STICKLINE(TJ2,0,1,1,0),COLOR00CCCC;
STICKLINE(TJ2,0,1,0.2,0),COLOR00FFFF;
DRAWTEXT(TJ2,1,'大牛'),COLOR00FFFF;
ST:=REF(UP,1)>REF(UP,2) AND DOWN<REF(UP,1);
STICKLINE(ST,10,11.05,5,0),COLOR008800;
STICKLINE(ST,10,11.05,2,0),COLOR00AA00;
STICKLINE(ST,10,11.05,1,0),COLOR00CC00;
STICKLINE(ST,10,11.05,0.2,0),COLOR00FF00;
DRAWTEXT(ST,10,'卖'),COLORFFFFFF;
DRAWICON(BT AND TJ1 AND TJ2,5,25);

附件

Doc1.doc

109.5 KB, 下载次数: 1, 下载积分: 共享币 -10 个

来自 山东省济南市

举报

使用道具 扔鸡蛋 回复

1686251
Lv.6

专栏

发表于 2012-5-29 15:20 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省温州市

举报

使用道具 支持 扔鸡蛋 回复

2605524
Lv.3

专栏

发表于 2012-5-29 14:52 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省济南市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
3楼
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表