请老师把“短线狙击手”写成预警公式(已解决,谢谢may158 老师)

[通达信] 3624 1
设置
2215197 Lv.3

专栏

发表于 2012-5-30 06:45 复制 显示全部楼层 倒序浏览 |
跳转到指定楼层
在红包黄蜡烛的柱体形成时出现信号。
A:=(3*C+H+L+O)/6;
XJ:=(A+0.618*REF(A,1)+0.382*REF(A,2)+0.236*REF(A,3)+0.146*REF(A,4))/2.382;
YCZXH:=(MA(HHV(A,2),5)+MA(HHV(A,2),13)+MA(HHV(A,2),21)+MA(HHV(A,2),32))/4;
YCZXL:=(MA(LLV(A,2),5)+MA(LLV(A,2),13)+MA(LLV(A,2),21)+MA(LLV(A,2),32))/4;
SMH:EMA(YCZXH,21),COLOR004000,LINETHICK2;
SML:EMA(YCZXL,21),COLOR004000,LINETHICK2;
SMJ:(SML+SMH)/2,COLOR004000,LINETHICK2;
PJ:=(10*A+9*REF(A,1)+8*REF(A,2)+7*REF(A,3)+6*REF(A,4)+5*REF(A,5)+4*REF(A,6)+3*REF(A,7)+2*REF(A,8)+REF(A,9))/55;
A1:=EMA(PJ,3),COLOR004000;A2:=EMA(PJ,5),COLOR004000;
A3:=EMA(PJ,7),COLOR004000;A4:=EMA(PJ,9),COLOR004000;
A5:=EMA(PJ,11),COLOR004000;
LX:=REF(XJ,1);
ZD:=(SMA(MAX(XJ-LX,0),5,1)/SMA(ABS(XJ-LX),5,1))*100;
KX1:=(CLOSE>=OPEN) AND ZD>=50;
KX2:=(CLOSE<OPEN) AND ZD>=50;
KX3:=(CLOSE>=OPEN) AND ZD<50;
KX4:=(CLOSE<OPEN) AND ZD<50;
IF(A5<REF(A5,1),A5,DRAWNULL),COLOR820000,LINETHICK2;
IF(A5>REF(A5,1),A5,DRAWNULL),COLOR00005B,LINETHICK2;
IF(A4<REF(A4,1),A4,DRAWNULL),COLOR8C0000,LINETHICK1;
IF(A4>REF(A4,1),A4,DRAWNULL),COLOR000055,LINETHICK1;
IF(A3<REF(A3,1),A3,DRAWNULL),COLOR9B0000,LINETHICK1;
IF(A3>REF(A3,1),A3,DRAWNULL),COLOR00006C,LINETHICK1;
IF(A2<REF(A2,1),A2,DRAWNULL),COLORBB0000,LINETHICK1;
IF(A2>REF(A2,1),A2,DRAWNULL),COLOR00007D,LINETHICK1;
IF(A1<REF(A1,1),A1,DRAWNULL),COLORCC0000,LINETHICK1;
IF(A1>REF(A1,1),A1,DRAWNULL),COLOR00009B,LINETHICK1;
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
BB1:=0;
B1万元:=DVOL*DCLOSE/100;
B1差:=B1万元-REF(B1万元,1);
B2万元:=DVOL*DCLOSE/100;
B2比:=B2万元/REF(B2万元,1);
净流入万元:=(AAA2-AAA3-0.5*AAA4);
PM:=MA(净流入万元,1);
PMA:=PM/REF(PM,1)>1;
PMB:=REF(PMA,1)<1 AND PMA;
密码:=(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW;
二日比:=密码/REF(密码,1);
选股:=PMB AND 密码>REF(密码,1) AND 二日比>1 ,COLORRED,NODRAW;
均价线:=AMOUNT/V/100;
均价线2:=MA(均价线,3);
均价线5:=MA(均价线,5);
均价线10:=MA(均价线,10);
均价线30:=MA(均价线,30);
突破:=C>均价线2 AND 均价线2<REF(均价线2,1) AND REF(均价线2,1)<REF(均价线2,2)
AND  REF(均价线2,2)<REF(均价线2,3) AND 选股;
STICKLINE(突破,H,L,5,0),LINETHICK1,COLORRED;
STICKLINE(突破,H,L,0.2,0),COLORYELLOW;
STICKLINE(突破,O,C,2,0),LINETHICK1,COLORYELLOW;

[ 本帖最后由 赋闲居士 于 2012-5-30 07:44 编辑 ]
来自 山西省太原市

举报

使用道具 扔鸡蛋 回复

7853
Lv.3

专栏

发表于 2012-5-30 07:35 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

附件

TEST.txt [预览]

553 Bytes, 下载次数: 17, 下载积分: 共享币 -10 个

来自 黑龙江省绥化市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表