返回列表

将大盘K线做副图指标出现异常,为何,请教高手

1930738 Lv.4

专栏

查看:6778 评论:8 复制 设置 显示全部楼层 倒序浏览 |
跳转到指定楼层
设置
将大盘K线做成副图指标后,我发现在大多数情况下,K线是正确的,但有时会出现异常。请教高手。 以下是源码及状态图。
上证:"999999$C",NODRAW,COLORWHITE;
涨幅%:("999999$C"-REF("999999$C",1))/"999999$C"*100,NODRAW;
涨跌±:"999999$C"-REF("999999$C",1),COLORLIGRAY,NODRAW;
涨家数:INDEXADV,NODRAW,COLORLIMAGENTA;
跌家数:INDEXDEC,NODRAW,COLORGREEN;
DRAWKLINE("999999$H","999999$O","999999$L","999999$C");
大盘:"999999$C",COLORWHITE,NODRAW;
_±:"999999$C"-REF("999999$C",1),COLORLIGRAY,NODRAW;
MA05:MA("999999$C",5),COLORGRAY;
MA10:MA("999999$C",10),COLORYELLOW;
MA20:MA("999999$C",20),COLORMAGENTA;
MA60:MA("999999$C",60),COLORGREEN;
MA200:MA("999999$C",60),COLORWHITE;
DRAWTEXT(ISLASTBAR,MA10, '10'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,MA20, '20'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,MA60, '60'),COLORGREEN;
角度05:ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416,COLORMAGENTA,NODRAW;
IF(角度05>=-10,MA05,DRAWNULL),COLORRED{红线操作,主用60分\日\周};

附件

作002220副数.JPG
做上证副图.JPG
738.middle
1930738 Lv.4

专栏

发表于:2012-7-9 23:03 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
793.middle
2312793 Lv.3

专栏

发表于:2012-7-9 23:21 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
580.middle
314580 Lv.4

专栏

发表于:2012-7-10 00:52 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
390.middle
2267390 Lv.2

专栏

发表于:2012-7-10 07:50 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
787.middle
1880787 Lv.0

专栏

发表于:2012-7-10 08:30 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
921.middle
2377921 Lv.5

专栏

发表于:2012-7-10 08:54 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
809.middle
1537809 Lv.3

专栏

发表于:2012-7-10 13:01 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
534.middle
1908534 Lv.3

专栏

发表于:2012-7-10 13:53 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
3楼
4楼
5楼
6楼
7楼
8楼
9楼
广告
广告
站长推荐 /2

最新主题