返回列表

放下屠刀立地成佛《一》

2131066 Lv.3

专栏

查看:4万 评论:62 复制 设置 显示全部楼层 倒序浏览 |
跳转到指定楼层
设置
最简单的填数工具源码:

.版本 2
.支持库 EThread

.子程序 子程序
.局部变量 文本IP, 文本型, , "3"
.局部变量 n, 整数型
.局部变量 服务器内容, 文本型
.局部变量 临时文本, 文本型, , "0"
.局部变量 临时, 整数型

计次 = 0
服务器内容 = 到文本 (读入文件 (“通达信服务器.ini”))
临时文本 = 分割文本 (服务器内容, #换行符, )
重定义数组 (行情服务器, 假, 取数组成员数 (临时文本))
.计次循环首 (取数组成员数 (临时文本), n)
    文本IP = 分割文本 (临时文本 [n], “:”, 3)
    行情服务器 [n].名称 = 文本IP [1]
    行情服务器 [n].地址 = 文本IP [2]
    行情服务器 [n].端口 = 到数值 (文本IP [3])
.计次循环尾 ()
编辑框5.内容 = “用户名:” + 用户名称
临时 = 0
.计次循环首 (取数组成员数 (临时文本), )
    临时 = 临时 + 1
    重定义数组 (行情客户, 真, 临时)
    复制窗口组件 (客户4, 行情客户 [临时])
    启动线程 (&客户号3, 临时, )
    行情客户 [临时].标记 = 到文本 (临时)
    超级延时 (350)
.计次循环尾 ()
超级延时 (10000)
播放音乐 (#声音1, )

.子程序 客户号3
.参数 参数

.如果真 (行情客户 [参数].连接 (行情服务器 [参数].地址, 行情服务器 [参数].端口))
    行情客户 [参数].发送数据 (还原字节集2 (“0C 01 18 7B 00 01 20 00 20 00 1E 00 ” + 用户名字节 + “ 00 35 32 74 64 78 00 00 00 00 00 00 00 00 00 00 00 00”))
.如果真结束


.子程序 _客户4_数据到达
.局部变量 实际组件, 客户
.局部变量 变量1, 字节集
.局部变量 变量4, 整数型

实际组件 = 取事件组件 ()
变量1 = 实际组件.取回数据 ()
变量4 = 取字节集长度 (变量1)
.如果真 (变量4 = 70)
    实际组件.发送数据 (还原为字节集 (“0C0218930001030003000D00” + 编辑框3.内容))
.如果真结束

.如果真 (变量4 = 205)
    实际组件.发送数据 (还原为字节集 (“12,3,24,153,0,1,32,0,32,0,219,15,116,100,120,108,101,118,101,108,50,0,0,10,215,195,64,4,84,” + 到文本 (十六到十 (编辑框4.内容)) + “,0,0,0,0,0,0,0,0,0,0,0,2”, 假))
.如果真结束

.如果真 (变量4 = 195)
    实际组件.发送数据 (还原字节集2 (“0C 01 00 2A 00 01 3B 00 3B 00 44 05 05 00 01 39 39 39 39 39 39 00 00 00 00 00 33 39 39 30 30 31 00 00 00 00 00 33 39 39 30 30 35 00 00 00 00 00 33 39 39 33 30 30 00 00 00 00 00 33 39 39 30 30 36 00 00 00 00”))
.如果真结束

.判断开始 (变量4 > 300 )
    .如果真 (变量4 < 400)
        .如果真 (寻找文本 (编辑框5.内容, 行情服务器 [到数值 (实际组件.标记)].名称, , 假) = -1)
            编辑框5.加入文本 (#换行符, 行情服务器 [到数值 (实际组件.标记)].名称 + “连接成功”)
            计次= 计次 + 1
            编辑框6.内容 = “BaoLi成功:” + 到文本 (计次2) + “个” + “ ” + “用时:” + 到文本 (取整 ((取启动时间 () - 时间A) ÷ 1000)) + “秒”
        .如果真结束

    .如果真结束

.判断 (变量4 = 18)
    .如果真 (寻找文本 (编辑框5.内容, 行情服务器 [到数值 (实际组件.标记)].名称, , 假) = -1)
        编辑框5.加入文本 (#换行符, 行情服务器 [到数值 (实际组件.标记)].名称 + “连接失败”)
    .如果真结束

服务器配置文件格式:
高级行情_上海电信2  *:61.152.168.232:7715
高级行情_北京电信1   :124.127.97.197:7709
高级行情_北京网通1   :61.135.142.90:7709
高级行情_北京主站    :211.151.185.133:443
高级行情_上海电信1   :61.152.168.227:7709
高级行情_上海电信3   :61.152.168.229:7709
高级行情_上海新站   *:61.152.107.173:7707
高级行情_深圳电信1   :119.147.86.166:7709
高级行情_深圳电信2   :113.105.73.82:7709
597.middle
2035597 Lv.3

专栏

发表于:2012-7-10 11:12 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
520.middle
682520 Lv.4

专栏

发表于:2012-7-10 11:21 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
549.middle
1286549 Lv.4

专栏

发表于:2012-7-10 11:33 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
547.middle
1972547 Lv.2

专栏

发表于:2012-7-10 11:34 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
306.middle
2373306 Lv.2

专栏

发表于:2012-7-10 11:39 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
165.middle
1192165 Lv.3

专栏

发表于:2012-7-10 11:51 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
732.middle
2023732 Lv.2

专栏

发表于:2012-7-10 11:54 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
297.middle
1560297 Lv.3

专栏

发表于:2012-7-10 12:00 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
053.middle
2318053 Lv.3

专栏

发表于:2012-7-10 12:17 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
146.middle
1684146 Lv.3

专栏

发表于:2012-7-10 12:38 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
249.middle
2146249 Lv.0

专栏

发表于:2012-7-10 12:43 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
178.middle
1185178 Lv.3

专栏

发表于:2012-7-10 12:46 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
921.middle
2377921 Lv.5

专栏

发表于:2012-7-10 12:47 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
707.middle
2471707 Lv.2

专栏

发表于:2012-7-10 12:49 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
599.middle
1185599 Lv.4

专栏

发表于:2012-7-10 13:10 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
871.middle
1580871 Lv.2

专栏

发表于:2012-7-10 13:19 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
100.middle
38100 Lv.5

专栏

发表于:2012-7-10 13:25 复制 查看全部楼层
提示: 该帖被管理员或版主屏蔽
078.middle
1901078 Lv.2

专栏

发表于:2012-7-10 13:45 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
314.middle
1142314 Lv.0

专栏

发表于:2012-7-10 13:58 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
308.middle
1819308 Lv.3

专栏

发表于:2012-7-10 14:14 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
593.middle
2437593 Lv.7

专栏

发表于:2012-7-10 14:27 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
avatar
1773575 Lv.0

专栏

发表于:2012-7-10 15:07 复制 查看全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
546.middle
2364546 Lv.3

专栏

发表于:2012-7-10 15:33 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
638.middle
1704638 Lv.7

专栏

发表于:2012-7-10 15:38 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
971.middle
2255971 Lv.3

专栏

发表于:2012-7-10 16:03 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
426.middle
1404426 Lv.0

专栏

发表于:2012-7-10 17:52 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
703.middle
1141703 Lv.2

专栏

发表于:2012-7-10 18:07 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
758.middle
169758 Lv.7

专栏

发表于:2012-7-10 18:40 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
454.middle
81454 Lv.4

专栏

发表于:2012-7-10 19:10 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
123下一页
您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主 19楼
2楼 20楼
3楼 21楼
4楼 22楼
5楼 23楼
6楼 24楼
7楼 25楼
8楼 26楼
9楼 27楼
10楼 28楼
11楼 29楼
12楼 30楼
13楼  
14楼  
15楼  
16楼  
17楼  
18楼  
广告
广告
站长推荐 /2

最新主题