返回列表

请老师将下面大智慧“形”指标修改为通达信指标 先谢谢

[通达信]
1973437 Lv.4

专栏

查看:3828 评论:0 复制 设置 显示全部楼层 倒序浏览 |
跳转到指定楼层
设置
参数名   最小   最大    缺省    步长
YN         1     12     1        1
CP         0     4      0        1
分钟1      0    1000    2        1
分钟5      0    1000    6        1
分钟15      0    1000    12        1
延迟1      0    1000     48      1


FON:=49;FDA:HHV(FORCAST(MA(MA(C,FON)*2-REF(MA(C,FON),FON/2),FON),FON*2),30),COLORFF0000,DOTLINE,LINETHICK0,LAYER0;CN1:=MA(C,60);CN2:=MA(C,240);CN3:=MA(C,36);CN4:=MA(C,15);CRD:=CN1>CN2;CRE:=CRD=0;CNT:=BARSLAST(CROSS(CN1,CN2))+1;A1:=DRAWGBK(CRD,STRIP(RGB(120,060,000),RGB(060,060,060),0));A2:=DRAWGBK(CRE,STRIP(RGB(060,060,060),RGB(000,000,000),0));FOC:="HEDY.FOC";FC01:MA(FORCAST(FOC,02),02),COLOR22AA22,LINETHICK1,LAYER0;FC02:MA(FORCAST(FOC,04),02),COLOR003000;FC03:MA(FORCAST(FOC,06),03),COLOR003000;FC04:MA(FORCAST(FOC,08),04),COLOR003000;FC05:MA(FORCAST(FOC,10),05),COLOR003000;FC06:MA(FORCAST(FOC,12),06),COLOR003000;FC07:MA(FORCAST(FOC,14),07),COLOR003000;FC08:MA(FORCAST(FOC,16),08),COLOR003000;FC09:MA(FORCAST(FOC,18),09),COLOR003000;FC10:MA(FORCAST(FOC,20),10),COLOR003000;FC11:MA(FORCAST(FOC,22),11),COLOR003000;FC12:MA(FORCAST(FOC,24),12),COLOR003000;FC13:MA(FORCAST(FOC,26),13),COLOR003000;FC14:MA(FORCAST(FOC,28),14),COLOR003000;FC15:MA(FORCAST(FOC,30),15),COLOR003000;FC16:MA(FORCAST(FOC,32),16),COLOR003000;FC17:MA(FORCAST(FOC,34),17),COLOR003000;FC18:MA(FORCAST(FOC,36),18),COLOR003000;FC19:MA(FORCAST(FOC,38),19),COLOR003000;FC20:MA(FORCAST(FOC,40),20),COLOR003000;FC21:MA(FORCAST(FOC,42),21),COLOR003000;FC22:MA(FORCAST(FOC,44),22),COLOR003000;FC23:MA(FORCAST(FOC,46),23),COLOR003000;FC24:MA(FORCAST(FOC,48),24),COLOR003000;FC25:MA(FORCAST(FOC,50),25),COLOR003000;FC26:MA(FORCAST(FOC,52),26),COLOR003000;FC27:MA(FORCAST(FOC,54),27),COLOR003000;FC28:MA(FORCAST(FOC,56),28),COLOR003000;FC29:MA(FORCAST(FOC,58),29),COLOR003000;FC30:MA(FORCAST(FOC,60),30),COLOR003000;FC31:MA(FORCAST(FOC,62),31),COLOR003000;FC32:MA(FORCAST(FOC,64),32),COLOR003000;FC33:MA(FORCAST(FOC,66),33),COLOR003000;FC34:MA(FORCAST(FOC,68),34),COLOR003000;FC35:MA(FORCAST(FOC,70),35),COLOR003000;FC36:MA(FORCAST(FOC,72),36),COLORRED,LINETHICK1,LAYER0;FILLRGN(FC36,REF(FC36,1),1,RGB(180,000,000)),LAYER0;GD1:=CROSS(REF(FC36,2),FC36)&nbsp;OR&nbsp;CROSS(FC36,REF(FC36,2));GD2:=CROSS(FC36,FC01)&nbsp;OR&nbsp;CROSS(FC01,FC36)&nbsp;OR&nbsp;CROSS(REF(FC01,2),FC01)&nbsp;OR&nbsp;CROSS(FC01,REF(FC01,2));GDT1:=BARSLAST(GD1)+1;GDT2:=BARSLAST(GD2)+1;GDT:=MIN(GDT1,GDT2);HFC36:REF(FC36,GDT1),COLORRED,POINTDOT,LINETHICK1,LAYER0;LFC36:REF(FC01,GDT2),COLORGREEN,POINTDOT,LINETHICK1,LAYER0;DD:=(HOUR=9&nbsp;AND&nbsp;DAY<>REF(DAY,1));WD:=WEEKDAY<REF(WEEKDAY,1)&nbsp;OR&nbsp;(DATE-REF(DATE,1)>3&nbsp;AND&nbsp;MONTH=REF(MONTH,1));JD:=DAY>=15&nbsp;AND&nbsp;REF(DAY,1)<15;FD:=MONTH<>REF(MONTH,1);AD:=MOD(MONTH,3)=MOD(YN,3)&nbsp;AND&nbsp;FD;AD2:=MOD(MONTH,3)=MOD(YN+1,3)&nbsp;AND&nbsp;JD;ED:=MOD(MONTH,13)=YN&nbsp;AND&nbsp;FD;ZD:=MOD(MONTH,6)=MOD(YN,6)&nbsp;AND&nbsp;FD;DDT:=BARSLAST(DD)+1;JDT:=IF(DATATYPE>7,BARSLAST(JD),BARSLAST(DD))+1;FDT:=IF(DATATYPE>7,BARSLAST(FD),BARSLAST(DD))+1;EDT:=IF(DATATYPE>7,BARSLAST(ED),BARSLAST(FD&nbsp;OR&nbsp;JD))+1;ZDT:=BARSLAST(ZD)+1;ADT:=IF(DATATYPE>7,BARSLAST(AD),BARSLAST(WD))+1;ADT2:=MOD(ADT-1+30,60)+1;WDT:=IF(DATATYPE>7,BARSLAST(WD),MOD(CNT-1,5))+1;PLDT:=EDT;WH:=HHV(H,WDT);WL:=LLV(L,WDT);RWH:=REF(WH,WDT);RWL:=REF(WL,WDT);JH:=HHV(H,JDT);JL:=LLV(L,JDT);RJH:=REF(JH,JDT);RJL:=REF(JL,JDT);FH:=HHV(H,FDT);FL:=LLV(L,FDT);RFH:=REF(FH,FDT);RFL:=REF(FL,FDT);AH:=HHV(H,ADT);AL:=LLV(L,ADT);RAH:=REF(AH,ADT);RAL:=REF(AL,ADT);EH:=HHV(H,EDT);EL:=LLV(L,EDT);REH:=REF(EH,EDT);REL:=REF(EL,EDT);SGNW:=IF(SGN(LLVBARS(L,WDT)-HHVBARS(H,WDT))>=0,1,-1);RSGNW:=REF(SGNW,WDT);SGNF:=IF(SGN(LLVBARS(L,FDT)-HHVBARS(H,FDT))>=0,1,-1);RSGNF:=REF(SGNF,FDT);SGNA:=IF(SGN(LLVBARS(L,ADT)-HHVBARS(H,ADT))>=0,1,-1);RSGNA:=REF(SGNA,ADT);SGNZ:=IF(SGN(LLVBARS(L,ZDT)-HHVBARS(H,ZDT))>=0,1,-1);RSGNZ:=REF(SGNZ,ZDT);SGNE:=IF(SGN(LLVBARS(L,EDT)-HHVBARS(H,EDT))>=0,1,-1);RSGNE:=REF(SGNE,EDT);RWMC:REF(SUM(C,WDT)/WDT,WDT),COLORWHITE,POINTDOT,LINETHICK0,LAYER0;RJMC:REF(SUM(C,JDT)/JDT,JDT),COLORYELLOW,POINTDOT,LINETHICK0,LAYER0;RFMC:REF(SUM(C,FDT)/FDT,FDT),COLORYELLOW,POINTDOT,LINETHICK0,LAYER0;RAMC2:REF(SUM(C,ADT2)/ADT2,ADT2),COLORGREEN,POINTDOT,LINETHICK0,LAYER0;RAMC:REF(SUM(C,ADT)/ADT,ADT),COLORMAGENTA,POINTDOT,LINETHICK1,LAYER0;REMC:REF(SUM(C,EDT)/EDT,EDT),COLORGREEN,POINTDOT,LINETHICK0,LAYER0;PHL:=(REH-REL)*0.015;R1:=C;R2:=REF(C,1);RSHA:=REF(SUM(IF(R1>R2,R1-R2,0),ADT),ADT);RSLA:=REF(SUM(IF(R1<R2,R1-R2,0),ADT),ADT);GDP:=REF(MA(H-L,120),EDT);DRAWTEXT(ADT=1,RAMC+PHL*2,NUMTOSTRN(RSGNA*(RAH-RAL),CP)),COLORCCCCCC,LINETHICK4,LAYER0;DRAWTEXT(WDT=1,RFL-PHL*1,NUMTOSTRN(RSGNW*(RWH-RWL),CP)),COLOR999999,LINETHICK1,LAYER0;DRAWTEXT(FDT=1,RFL-PHL*3,NUMTOSTRN(RSGNF*(RFH-RFL),CP)),COLORYELLOW,LINETHICK1,LAYER0;DRAWTEXT(ADT=1,RAMC,NUMTOSTRN(RAMC,CP)),COLORMAGENTA,LINETHICK6,LAYER0;DRAWTEXT(MOD(ADT+1,15)=1,EH+GDP,NUMTOSTRN(SGNE*(EH-EL),CP)),COLORAAAAAA,LINETHICK2,LAYER0;
您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

广告
广告
站长推荐 /2

最新主题