手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

那个老师把冷头战士法公式整号成一个通达信主图公式和选股公式!

[通达信]
设置
4939 7 刘滨33 Lv.4 发表于 · 2013-3-9 22:20 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
那个老师把冷头战士法公式整号成一个通达信主图公式和选股公式!
{1.百日低量群}
百日地量:= V=LLV(V,100) AND V>0;
倍量:= VOL>=REF(V,1)*1.9 AND C>REF(C,1);
地量又倍量:COUNT(百日地量,5)>=1 AND COUNT(倍量,1)>=1;{2.倍量过左峰}
N:=20;
左峰高:=REF(HHV(C,N),1);
倍量过左:REF(COUNT(C<左峰高,2)=2,1) AND C>左峰高 AND C>O
  AND VOL/REF(VOL,1)>=1.9;{3.回踩黄金线}
{1.黄金柱}
JJ:=(3*C+H+L+O)/6;
VAR1:=DMA(JJ,0.2);
{VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)
+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;}
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);
LJL:=FILTER(TJ1,3);
黄金线:=REF(LOW,BARSLAST(LJL));
黄金柱:=FILTER(TJ1,3);
{2.倍量过左峰}
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=BACKSET(SR2,10+1);
HD:=FILTER(SR3,10);
前高:=REF(H,BARSLAST(HD));
{倍量:=VOL/REF(VOL,1)>=2 AND COUNT(CLOSE>OPEN,1) OR LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>=2;}
突破前高:=CROSS(C,前高);
倍量过左峰:= 突破前高 AND 倍量;
{3.凹口起柱}
T7:=REF(VOL,6)/REF(VOL,7)>=2;
T6:=REF(VOL,5)/REF(VOL,6)>=2;
T5:=REF(VOL,5)/REF(VOL,4)>=1.5;
T4:=REF(VOL,4)/REF(VOL,3)>=1.5;
T3:=REF(VOL,2)/REF(VOL,3)>=1.5;
T1:=V/REF(VOL,1)>2;
T0:=C>O AND C>REF(C,1);
凹口起柱:= T7 AND T1 AND T0
OR T6 AND T1 AND T0
OR T5 AND T1 AND T0
OR T4 AND T1 AND T0
OR T3 AND T1 AND T0 ;
{凹口起柱}
AKQZ:= 黄金柱 AND 凹口起柱;
{4.前高低位}
X:=21;
TTY:=H;
AAT:=REF(TTY,X)=HHV(TTY,2*X+1);
BBT:=FILTER(AAT,X);
CCT:=BACKSET(BBT,X+1);
HD10T:=FILTER(CCT,X);
前期高位:=REF(H,BARSLAST(HD10T));
{突破前高}
TPQG:= 黄金柱 AND 倍量过左峰 AND C>前期高位;
{选股}
回踩黄金线: (COUNT(TPQG,10) OR COUNT(AKQZ,10))
AND COUNT(CROSS(黄金线*1.01,L),3)>0 AND L>=黄金线
AND C>REF(C,1) AND REF(C,2)>REF(C,1) AND COUNT(LJL,3)=0;{5.长阴短柱}
长阴短柱: C/REF(C,1)<0.95 AND V<HHV(V,30)/1.9;
{6.1 底同向精准}
NN:=3;
LL0:=0;
L0:=LL0/100;
L1:=ABS(L-REF(L,1))<=L0;
L2:=ABS(L-REF(L,2))<=L0;
L3:=ABS(L-REF(L,3))<=L0;
L4:=ABS(L-REF(L,4))<=L0;
L5:=ABS(L-REF(L,5))<=L0;
精准线:=L1 OR L2 OR L3 OR L4 OR L5;
底精准: FILTER(精准线,NN),COLORCYAN;
{6.2 异向并肩精准线}
异向并肩精准:  MIN(O,C)=REF(MAX(O,C),1) ;
{4.咬住峰顶线}
FDX:=PEAK(1,10,1);{REF(HHV(H,60),5)};{上一波峰值}
TJ:=BETWEEN(MA(H,3),FDX*0.997,FDX*1.02);
咬住峰顶线: COUNT(TJ,3)>=2,COLORRED;  


HHH:=CONST(HHV(H,100));
LLL:=CONST(LLV(L,100));
HH:=HHH-LLL;
TJ2:= CURRBARSCOUNT=58;
DRAWTEXT(TJ2,LLL+HH*0.90,'百日低量处,倍量要涨停;凹口平量柱,确实猛如虎;');
DRAWTEXT(TJ2,LLL+HH*0.85,'倍量过左峰,涨停急先锋;凹口去淘金,报四三涨停;');
DRAWTEXT(TJ2,LLL+HH*0.80,'确定黄金柱,实盘擒牛股;回踩黄金线,腾飞不眨眼;');
DRAWTEXT(TJ2,LLL+HH*0.75,'接力黄金线,一步一重天;银谷黄金仓,涨停没商量;');
DRAWTEXT(TJ2,LLL+HH*0.70,'二次红波起,必有好戏看;长阴压短柱,攻势猛如虎;');
DRAWTEXT(TJ2,LLL+HH*0.65,'咬住峰顶线,伏击赚大钱;顶底若互换,牛股要逛奔。');
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;

战法, 龙头, 通达信, 股票指标公式, 通达信指标公式

  VAR1:=((((((2*CLOSE)+HIGH)+LOW)+OPEN)/5));A1:(((((EMA(VAR1,3)+EMA

  (VAR1,6))+EMA(VAR1,12))+EMA(VAR1,24))/4));A2:(EMA(A1,2));

  A3:(EMA(A2,2));A4:(EMA(A3,2));A5:(EMA(A4,2));A6:(EMA(A5,2));

  A7:(EMA(A6,2));A8:((EMA(VAR1,2.78)*1.028));A9:((MA(OPEN,3.2)*1.028));

  AA:=((CLOSE/REF(CLOSE,1))>=1.099);AB:=(VOL/REF(VOL,1));

  龙头第一买点:=IF((AA AND (AB<1)),1,0);龙头第二买点:=IF((((CLOSE/REF

  (CLOSE,1))>=1.07) AND (AB<1)),1,0);买线:=(EMA(CLOSE,2));

  卖线:=(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42));

  STICKLINE((买线>=卖线),CLOSE,OPEN,3,0),COLOR0000AA;

  STICKLINE((买线>=卖线),CLOSE,OPEN,3,0),COLOR0000BB;

  STICKLINE((买线>=卖线),CLOSE,OPEN,3,0),COLOR0000CC;

  STICKLINE((买线<卖线),CLOSE,OPEN,3,0),COLORAAAA00;

  STICKLINE((买线<卖线),CLOSE,OPEN,3,0),COLORBBBB00;

  STICKLINE((买线<卖线),CLOSE,OPEN,3,0),COLORCCCC00;

  DRAWTEXT((龙头第二买点=1),(REF(LOW,1)*1.1),'龙头战法D2买点'),COLOR00FFFF;
澄碧河
Lv.3
发表于 2015-12-27 19:58 复制 查看全部楼层
将就用吧!好像用处不大。
HHH:=CONST(HHV(H,90));
LLL:=CONST(LLV(L,90));
HH:=HHH-LLL;
TJ2:= CURRBARSCOUNT=180;
DRAWTEXT(TJ2,LLL+HH*1.60,'百日低量处,倍量要涨停;凹口平量柱,确实猛如虎;');
DRAWTEXT(TJ2,LLL+HH*1.45,'倍量过左峰,涨停急先锋;凹口去淘金,报四三涨停;');
DRAWTEXT(TJ2,LLL+HH*1.30,'确定黄金柱,实盘擒牛股;回踩黄金线,腾飞不眨眼;');
DRAWTEXT(TJ2,LLL+HH*1.15,'接力黄金线,一步一重天;银谷黄金仓,涨停没商量;');
DRAWTEXT(TJ2,LLL+HH*1.00,'二次红波起,必有好戏看;长阴压短柱,攻势猛如虎;');
DRAWTEXT(TJ2,LLL+HH*0.85,'咬住峰顶线,伏击赚大钱;顶底若互换,牛股要逛奔。');
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;

百日地量:=LLV(V,100) AND V>0;
倍量:= VOL>=REF(V,1)*1.9 AND C>REF(C,1);
地量又倍量:=COUNT(百日地量,5)>=1 AND COUNT(倍量,1)>=1;{2.倍量过左峰}
STICKLINE(地量又倍量,C,O,2.1,0),COLORRED;
N:=20;
左峰高:=REF(HHV(C,N),1);
倍量过左:REF(COUNT(C<左峰高,2)=2,1) AND C>左峰高 AND C>O AND VOL/REF(VOL,1)>=1.9;{3.回踩黄金线}
STICKLINE(倍量过左,C,O,3.1,1),COLORBLUE;
{1.黄金柱}
JJ:=(3*C+H+L+O)/6;
VAR1:=DMA(JJ,0.2);
{VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)
+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;}
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);
LJL:=FILTER(TJ1,3);
黄金线:=REF(LOW,BARSLAST(LJL));
黄金柱:=FILTER(TJ1,3);
STICKLINE(黄金柱,C,O,0.5,0),COLORYELLOW;
{3.凹口起柱}
T7:=REF(VOL,6)/REF(VOL,7)>=2;
T6:=REF(VOL,5)/REF(VOL,6)>=2;
T5:=REF(VOL,5)/REF(VOL,4)>=1.5;
T4:=REF(VOL,4)/REF(VOL,3)>=1.5;
T3:=REF(VOL,2)/REF(VOL,3)>=1.5;
T1:=V/REF(VOL,1)>2;
T0:=C>O AND C>REF(C,1);
凹口起柱:= T7 AND T1 AND T0
OR T6 AND T1 AND T0
OR T5 AND T1 AND T0
OR T4 AND T1 AND T0
OR T3 AND T1 AND T0 ;
{凹口起柱}
AKQZ:= 黄金柱 AND 凹口起柱;
STICKLINE(AKQZ,C,O,1.1,0),COLORFFFFFF;
{选股}
TPQG:= 黄金柱 AND 倍量过左;
回踩黄金线:(COUNT(TPQG,10) OR COUNT(AKQZ,10))
AND COUNT(CROSS(黄金线*1.01,L),3)>0 AND L>=黄金线
AND C>REF(C,1) AND REF(C,2)>REF(C,1) AND COUNT(LJL,3)=0;
DRAWTEXT(回踩黄金线,L*0.98,'踩');
{6.1 底同向精准}
NN:=3;
LL0:=0;
L0:=LL0/100;
L1:=ABS(L-REF(L,1))<=L0;
L2:=ABS(L-REF(L,2))<=L0;
L3:=ABS(L-REF(L,3))<=L0;
L4:=ABS(L-REF(L,4))<=L0;
L5:=ABS(L-REF(L,5))<=L0;
精准线:=L1 OR L2 OR L3 OR L4 OR L5;
底精准:FILTER(精准线,NN),COLORCYAN;
DRAWICON(底精准,L*0.95,41);
{6.2 异向并肩精准线}
异向并肩精准:MIN(O,C)=REF(MAX(O,C),1) ;
DRAWICON(异向并肩精准,L*0.95,38);

AA:=((CLOSE/REF(CLOSE,1))>=1.099);AB:=(VOL/REF(VOL,1));
龙头第一买点:=IF((AA AND (AB<1)),1,0);龙头第二买点:=IF((((CLOSE/REF
(CLOSE,1))>=1.07) AND (AB<1)),1,0);买线:=(EMA(CLOSE,2));
卖线:=(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),120));
STICKLINE((买线>=卖线),CLOSE,OPEN,2,0),COLOR0000AA;
STICKLINE((买线>=卖线),CLOSE,OPEN,2,0),COLOR0000BB;
STICKLINE((买线>=卖线),CLOSE,OPEN,2,0),COLOR0000CC;
STICKLINE((买线<卖线),CLOSE,OPEN,2,0),COLORAAAA00;
STICKLINE((买线<卖线),CLOSE,OPEN,2,0),COLORBBBB00;
STICKLINE((买线<卖线),CLOSE,OPEN,2,0),COLORCCCC00;
刘滨33
Lv.4
发表于 2013-3-10 10:39 复制 查看全部楼层
看来不能用???????????
黄桷幽幽
Lv.3
发表于 2013-3-10 01:47 复制 查看全部楼层
发现未来函数BACKSET
刘滨33
Lv.4
发表于 2013-3-9 22:49 复制 查看全部楼层
老师这个图就更加看不懂了

附件

3.jpg
刘滨33
Lv.4
发表于 2013-3-9 22:43 复制 查看全部楼层
老师主图成这个样子???能改变一下吗?请取消未来!

附件

2.jpg
张焱昧
Lv.6
发表于 2013-3-9 22:37 复制 查看全部楼层
HHH:=CONST(HHV(H,100));
LLL:=CONST(LLV(L,100));
HH:=HHH-LLL;
TJ2:= CURRBARSCOUNT=58;
DRAWTEXT(TJ2,LLL+HH*0.90,'百日低量处,倍量要涨停;凹口平量柱,确实猛如虎;');
DRAWTEXT(TJ2,LLL+HH*0.85,'倍量过左峰,涨停急先锋;凹口去淘金,报四三涨停;');
DRAWTEXT(TJ2,LLL+HH*0.80,'确定黄金柱,实盘擒牛股;回踩黄金线,腾飞不眨眼;');
DRAWTEXT(TJ2,LLL+HH*0.75,'接力黄金线,一步一重天;银谷黄金仓,涨停没商量;');
DRAWTEXT(TJ2,LLL+HH*0.70,'二次红波起,必有好戏看;长阴压短柱,攻势猛如虎;');
DRAWTEXT(TJ2,LLL+HH*0.65,'咬住峰顶线,伏击赚大钱;顶底若互换,牛股要逛奔。');
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;
{战法, 龙头, 通达信, 股票指标公式, 通达信指标公式}
VAR1:=((((((2*CLOSE)+HIGH)+LOW)+OPEN)/5));A1:(((((EMA(VAR1,3)+EMA
(VAR1,6))+EMA(VAR1,12))+EMA(VAR1,24))/4));A2:(EMA(A1,2));
A3:(EMA(A2,2));A4:(EMA(A3,2));A5:(EMA(A4,2));A6:(EMA(A5,2));
A7:(EMA(A6,2));A8:((EMA(VAR1,2.78)*1.028));A9:((MA(OPEN,3.2)*1.028));
AA:=((CLOSE/REF(CLOSE,1))>=1.099);AB:=(VOL/REF(VOL,1));
龙头第一买点:=IF((AA AND (AB<1)),1,0);龙头第二买点:=IF((((CLOSE/REF
(CLOSE,1))>=1.07) AND (AB<1)),1,0);买线:=(EMA(CLOSE,2));
卖线:=(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42));
STICKLINE((买线>=卖线),CLOSE,OPEN,3,0),COLOR0000AA;
STICKLINE((买线>=卖线),CLOSE,OPEN,3,0),COLOR0000BB;
STICKLINE((买线>=卖线),CLOSE,OPEN,3,0),COLOR0000CC;
STICKLINE((买线<卖线),CLOSE,OPEN,3,0),COLORAAAA00;
STICKLINE((买线<卖线),CLOSE,OPEN,3,0),COLORBBBB00;
STICKLINE((买线<卖线),CLOSE,OPEN,3,0),COLORCCCC00;
DRAWTEXT((龙头第二买点=1),(REF(LOW,1)*1.1),'龙头战法D2买点'),COLOR00FFFF;
张焱昧
Lv.6
发表于 2013-3-9 22:36 复制 查看全部楼层
{另1个}{1.百日低量群}
百日地量:= V=LLV(V,100) AND V>0;
倍量:= VOL>=REF(V,1)*1.9 AND C>REF(C,1);
地量又倍量:COUNT(百日地量,5)>=1 AND COUNT(倍量,1)>=1;{2.倍量过左峰}
N:=20;
左峰高:=REF(HHV(C,N),1);
倍量过左:REF(COUNT(C<左峰高,2)=2,1) AND C>左峰高 AND C>O AND VOL/REF(VOL,1)>=1.9;{3.回踩黄金线}
{1.黄金柱}
JJ:=(3*C+H+L+O)/6;
VAR1:=DMA(JJ,0.2);
{VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)
+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;}
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);
LJL:=FILTER(TJ1,3);
黄金线:=REF(LOW,BARSLAST(LJL));
黄金柱:=FILTER(TJ1,3);
{2.倍量过左峰}
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
SR2:=FILTER(SR1,10);
SR3:=BACKSET(SR2,10+1);
HD:=FILTER(SR3,10);
前高:=REF(H,BARSLAST(HD));
{倍量:=VOL/REF(VOL,1)>=2 AND COUNT(CLOSE>OPEN,1) OR LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>=2;}
突破前高:=CROSS(C,前高);
倍量过左峰:= 突破前高 AND 倍量;
{3.凹口起柱}
T7:=REF(VOL,6)/REF(VOL,7)>=2;
T6:=REF(VOL,5)/REF(VOL,6)>=2;
T5:=REF(VOL,5)/REF(VOL,4)>=1.5;
T4:=REF(VOL,4)/REF(VOL,3)>=1.5;
T3:=REF(VOL,2)/REF(VOL,3)>=1.5;
T1:=V/REF(VOL,1)>2;
T0:=C>O AND C>REF(C,1);
凹口起柱:= T7 AND T1 AND T0
OR T6 AND T1 AND T0
OR T5 AND T1 AND T0
OR T4 AND T1 AND T0
OR T3 AND T1 AND T0 ;
{凹口起柱}
AKQZ:= 黄金柱 AND 凹口起柱;
{4.前高低位}
X:=21;
TTY:=H;
AAT:=REF(TTY,X)=HHV(TTY,2*X+1);
BBT:=FILTER(AAT,X);
CCT:=BACKSET(BBT,X+1);
HD10T:=FILTER(CCT,X);
前期高位:=REF(H,BARSLAST(HD10T));
{突破前高}
TPQG:= 黄金柱 AND 倍量过左峰 AND C>前期高位;
{选股}
回踩黄金线: (COUNT(TPQG,10) OR COUNT(AKQZ,10))
AND COUNT(CROSS(黄金线*1.01,L),3)>0 AND L>=黄金线
AND C>REF(C,1) AND REF(C,2)>REF(C,1) AND COUNT(LJL,3)=0;{5.长阴短柱}
长阴短柱: C/REF(C,1)<0.95 AND V<HHV(V,30)/1.9;
{6.1 底同向精准}
NN:=3;
LL0:=0;
L0:=LL0/100;
L1:=ABS(L-REF(L,1))<=L0;
L2:=ABS(L-REF(L,2))<=L0;
L3:=ABS(L-REF(L,3))<=L0;
L4:=ABS(L-REF(L,4))<=L0;
L5:=ABS(L-REF(L,5))<=L0;
精准线:=L1 OR L2 OR L3 OR L4 OR L5;
底精准: FILTER(精准线,NN),COLORCYAN;
{6.2 异向并肩精准线}
异向并肩精准:  MIN(O,C)=REF(MAX(O,C),1) ;
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表