手机版 理想小程序
理想小程序
RSS 论坛APP
返回列表

请老师帮助把飞狐海龟交易公式改为通达信的

[通达信] 8941 2
设置
1678447 Lv.5

专栏

复制 显示全部楼层 倒序浏览 |
跳转到指定楼层

海龟交易法则就是均线,唐奇安通道 通达信,通达信指标公式大全,海龟源码 通达信指标编写_技术互助答疑论坛股票软件指标公式技术理想股票技术论坛

请老师帮助把飞狐海龟交易公式改为通达信的。谢谢!input:N1(55,6,99),N2(20,2,99);LC:=REF(CLOSE,1);TR:=MAX((HIGH - LOW),MAX((HIGH - LC),(LC - LOW)));ATR:=SM ...指标编写_技术互助答疑论坛股票软件指标公式技术

请老师帮助把飞狐海龟交易公式改为通达信的。谢谢!
input:N1(55,6,99),N2(20,2,99);
LC:=REF(CLOSE,1);
TR:=MAX((HIGH - LOW),MAX((HIGH - LC),(LC - LOW)));
ATR:=SMA(TR,20,1);
AA:=(HHV(HIGH,N1) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));
B3B:=BARSLAST(B3);
SS:=CROSS(MAX(AA,MA(CLOSE,13)),CLOSE);
SS1:=(((SS AND ((B3B < B2B) OR (B2B < B1B))) AND (SSSB > B1B)) AND (COUNT(SS,B2B) < 2));
SS1B:=BARSLAST(SS1);
SS2:=((((SS AND (SS1B < SSSB)) AND (B3B < B2B)) AND (SS1B > 0)) AND (COUNT(SS,B2B) < 3));
SSSS:=(SSS AND (REF(SSSB,1) > REF(B1B,1)));
DRAWICON((B1 = 1),(LOW - 0.1),1);
DRAWTEXT((B1 = 1),(LOW - 0.25),'买1'),colorFF;
DRAWICON((B2 = 1),(LOW - 0.1),1);
DRAWTEXT((B2 = 1),(LOW - 0.25),'买2'),colorFF;
DRAWICON((B3 = 1),(LOW - 0.1),1);
DRAWTEXT((B3 = 1),(LOW - 0.25),'买3'),colorFF;
DRAWICON((SS1 = 1),(HIGH + 0.1),2);
DRAWTEXT((SS1 = 1),(HIGH + 0.25),'止损1'),colorFF00;
DRAWICON((SS2 = 1),(HIGH + 0.1),2);
DRAWTEXT((SS2 = 1),(HIGH + 0.25),'止损2'),colorFF00;
DRAWICON((SSSS = 1),(HIGH + 0.1),2);
DRAWTEXT((SSSS = 1),(HIGH + 0.25),'快卖'),colorFF00;
183.middle
2020183
Lv.6

专栏

发表于 2013-7-3 16:42 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
191.middle
626191
Lv.4

专栏

发表于 2013-7-3 17:47 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请到新手区学习升级之后才能查看,或直接购买升级后查看。
您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
3楼
131943xjzjpcd6s1hvja2p
160828rrwbe8b2ijeeae8w
站长推荐 /1

最新主题

回顶部 到页底