手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

【求助】新高对应指标值的问题

[飞 狐]
设置
3489 7 奥运快乐 Lv.4 发表于 · 2013-8-8 19:19 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
求收盘价创新高那根k线所对应的ma(c,20)均线
求上次收盘价创新高那根k线所对应的ma(c,20)均线值
这个公式怎么编写?

举报

扔鸡蛋(0) 回复

沉默cge
Lv.6
发表于 2013-8-11 14:33 复制 查看全部楼层
谢谢...............

举报

扔鸡蛋(0) 回复

芳华木
Lv.3
发表于 2013-8-10 13:11 复制 查看全部楼层
原帖由 奥运快乐 于 2013-8-9 08:31 发表


我这个是日内条件(分钟图例如股指期货)
创当日新高和上一次创当日新高



sorry,我审错题了,还真是第一次回答是对的

NTA:=DATE<>REF(DATE,1);
NT:=BARSLAST(DATE<>REF(DATE,1));
A:=BARSLAST(H=HHV(H,NT));
m1:ref(ma(c,20),a);
m2:ref(ma(c,20),sumbars(a=1,2)-1)

举报

点亮(0) 扔鸡蛋(0) 回复

芳华木
Lv.3
发表于 2013-8-10 13:07 复制 查看全部楼层
@奥运快乐

我第一次回复你的那个是错的,5楼绿虚线是当天最高的ma,红虚线是昨天最高的ma,简化后只要数值的:


NTA:=DATE<>REF(DATE,1);
NT:=BARSLAST(DATE<>REF(DATE,1));
A:=BARSLAST(H=HHV(H,NT));
Y0:=BACKSET(ISLASTBAR,A+1);
Y1:=BACKSET(ISLASTBAR,NT+REF(A,SUMBARS(NTA,1))+2);            
Y2:=BACKSET(ISLASTBAR,SUMBARS(NTA,2)+REF(A,SUMBARS(NTA,2))+1);
当天MA:REF(MA(C,10),A),nodraw;
昨天ma:REF(MA(C,10),BARSLAST(Y1>REF(Y1,1))+1),nodraw;
DRAWLINE(Y1>REF(Y1,1),MA(C,20),REF(Y1>REF(Y1,1),1),REF(MA(C,20),1),1),DOTLINE,COLORRED;
STICKLINE(Y0,REF(MA(C,10),A),REF(MA(C,10),A),2,0);
DRAWTEXT(ISLASTBAR,REF(MA(C,10),A),VAR2STR(REF(MA(C,10),A),2));
DRAWTEXT(ISLASTBAR,REF(MA(C,10),BARSLAST(Y1>REF(Y1,1))+1),VAR2STR(REF(MA(C,10),BARSLAST(Y1>REF(Y1,1))+1),2));
截图1376111221.png

举报

点亮(0) 扔鸡蛋(0) 回复

芳华木
Lv.3
发表于 2013-8-10 11:37 复制 查看全部楼层
NTA:=DATE<>REF(DATE,1);
NT:=BARSLAST(DATE<>REF(DATE,1));
A:=BARSLAST(H=HHV(H,NT));
Y0:=BACKSET(ISLASTBAR,A+1);
Y1:=BACKSET(ISLASTBAR,NT+REF(A,SUMBARS(NTA,1))+2);            
Y2:=BACKSET(ISLASTBAR,SUMBARS(NTA,2)+REF(A,SUMBARS(NTA,2))+1);

DRAWLINE(Y2>REF(Y2,1),MA(C,20),Y1>REF(Y1,1),MA(C,20),0),LINETHICK2,COLORRED;

DRAWLINE(Y2>REF(Y2,1),MA(C,20),REF(Y2>REF(Y2,1),1),REF(MA(C,20),1),1),DOTLINE,COLORRED;
DRAWLINE(Y1>REF(Y1,1),MA(C,20),REF(Y1>REF(Y1,1),1),REF(MA(C,20),1),1),DOTLINE,COLORRED;
STICKLINE(Y0,REF(MA(C,10),A),REF(MA(C,10),A),2,0);
DRAWLINE(Y1>REF(Y1,1),MA(C,20),Y0,MA(C,20),0),LINETHICK2,COLORGREEN;

DRAWTEXT(ISLASTBAR,REF(MA(C,10),A),VAR2STR(REF(MA(C,10),A),2));

DRAWTEXT(ISLASTBAR,REF(MA(C,10),BARSLAST(Y1>REF(Y1,1))+1),VAR2STR(REF(MA(C,10),BARSLAST(Y1>REF(Y1,1))+1),2));

截图1376105827.png

举报

点亮(0) 扔鸡蛋(0) 回复

奥运快乐
Lv.4
发表于 2013-8-9 19:01 复制 查看全部楼层
没人知道吗?

举报

扔鸡蛋(0) 回复

奥运快乐
Lv.4
发表于 2013-8-9 08:31 复制 查看全部楼层
原帖由 @芳华木 于 2013-8-8 19:23 发表
奥运快乐

创新高也得有时间范围的条件啊,创多少时间内的新高


我这个是日内条件(分钟图例如股指期货)
创当日新高和上一次创当日新高

举报

点亮(0) 扔鸡蛋(0) 回复

芳华木
Lv.3
发表于 2013-8-8 19:23 复制 查看全部楼层
@奥运快乐

创新高也得有时间范围的条件啊,创多少时间内的新高

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表