手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

请老师根据抄底逃顶指标编写一个选股公式。非常感谢,并祝老师节日快乐!

[通达信]
设置
3150 5 胡云曲2009 Lv.4 发表于 · 2014-10-5 09:19 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
要求是:机构做多能量线上穿或大于40的选股公式和90上出现绿柱的选股公式。
VAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
机构做多能量线: SMA(VAR1,5,1)-8,LINETHICK2,COLORGREEN;
VAR2:=(HHV(HIGH,30)-CLOSE)/(HHV(HIGH,30)-LLV(LOW,30))*100;
机构做空能量线:= SMA(VAR2,3,1),LINETHICK2,COLORGREEN;
弱势区:21,,COLORFFBBFF;
分水岭:60,,COLORYELLOW;
强势区:81,,COLORMAGENTA;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
XG1:=VOL<HHV(VOL,120)/10 AND CROSS(DIF,DEA) AND VOL<MA(VOL,60)/1.9;
XG2:=HHV(C,120)/LLV(C,120)<1.5;
趋势线:=3*SMA((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100,5,1),3,1), COLORYELLOW;
底:10, COLOR983433;
爆:20;
顶:90,COLORGREEN;
STICKLINE(底>趋势线,底,趋势线,2,0),COLORRED;
STICKLINE(趋势线>顶,趋势线,顶,2,0),COLORGREEN;
STICKLINE(REF(趋势线,1)<顶 AND 趋势线>顶,90,100,2,0),COLORCYAN;
STICKLINE(REF(趋势线,1)>顶 AND 趋势线<顶,90,80,2,0),COLORBLUE;
STICKLINE(CROSS(趋势线,底),0,60,2,0),COLORMAGENTA;
STICKLINE(CROSS(趋势线,爆),20,30,2,0),COLORRED;
趋势线1:=3*SMA((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100,5,1),3,1), COLORYELLOW;
DRAWTEXT(CROSS(趋势线,底),底,'杀庄'),COLORLIMAGENTA;
趋势:=(趋势线-REF(趋势线,1))*100/REF(趋势线,1),NODRAW;
BB:=IF(趋势>=1,趋势线,DRAWNULL),COLORRED,LINETHICK3;

[ 本帖最后由 胡云曲2009 于 2014-10-5 09:31 编辑 ]
沉默cge
Lv.6
发表于 2014-10-8 01:53 复制 查看全部楼层
谢谢........................
天生我才89
Lv.5
发表于 2014-10-6 09:38 复制 查看全部楼层
谢谢休闲人生11老师的热心解答。祝老师节日愉快,投资顺利!!!!!!!!!!
胡云曲2009
Lv.4
发表于 2014-10-5 10:29 复制 查看全部楼层
谢谢休闲人生11老师的热心解答。祝老师节日愉快,投资顺利!
休闲人生11
Lv.5
发表于 2014-10-5 09:46 复制 查看全部楼层
趋势线:=3*SMA((C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*100,5,1)-2*SMA(SMA((C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*100,5,1),3,1);
xg:趋势线>=90;
休闲人生11
Lv.5
发表于 2014-10-5 09:43 复制 查看全部楼层
VAR1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
机构做多能量线:=SMA(VAR1,5,1)-8;
XG:CROSS(机构做多能量线,40) or 机构做多能量线>=40;
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表