手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

求教公式过滤条件

[通达信]
设置
3203 2 雄鹰MACD Lv.2 发表于 · 2015-10-1 09:42 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
2015-10-01_9-39-21.jpg

N:=5;
A11:DRAWLINE(HIGH>=HHV(HIGH,N),HIGH,LOW<=LLV(LOW,N),LOW,0),COLORWHITE,DOTLINE;
E11:DRAWLINE(LOW<=LLV(LOW,N),LOW,HIGH>=HHV(HIGH,N),HIGH,0),COLORWHITE,DOTLINE;

如何把上面的公式添加一个过滤条件,将高低点之间不够5根K线的线段合并,直到出现高低点大于或者等于5根K线的再画线段。如图像紫色段那样的效果。

举报

扔鸡蛋(0) 回复

听雪寻股
Lv.5
发表于 2015-10-3 09:43 复制 查看全部楼层
原帖由 @雄鹰MACD 于 2015-10-1 09:42 发表
6632922

N:=5;
A11:DRAWLINE(HIGH>=HHV(HIGH,N),HIGH,LOW

A11:=HIGH>=HHV(HIGH,N);
E11:=LOW<=LLV(LOW,N);
A22:=BARSLAST(E11)>=N-1 AND A11;
E22:=BARSLAST(A11)>=N-1 AND E11;
A:DRAWLINE(A22,HIGH,E22,LOW,0),COLORWHITE,DOTLINE;
E:DRAWLINE(E22,LOW,A22,HIGH,0),COLORWHITE,DOTLINE;


1.jpg

举报

点亮(0) 扔鸡蛋(0) 回复

您需要登录后才可以回帖 免费注册登录

本版积分规则

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表