发新话题
这个指标有老师一二年前就发表过的
发消息 加好友
积分
22803 
理想币
3559 个 
彩币
5 个 
共享币
8471 个 
注册时间
2013-5-29 

复制

这个确实与其他提供的有点不同,信息很全面。
发消息 加好友
积分
6104 
理想币
25 个 
彩币
5 个 
共享币
773 个 
注册时间
2015-7-5 

复制

发消息 加好友
积分
307 
理想币
0 个 
彩币
5 个 
共享币
7 个 
注册时间
2015-8-4 

复制

谢谢分享!!!!!!!!!
发消息 加好友
积分
8457 
理想币
2842 个 
彩币
10 个 
共享币
2069 个 
注册时间
2015-4-23 

复制

谢谢分享!!!!!!!!!
发消息 加好友
积分
489 
理想币
0 个 
彩币
9 个 
共享币
115 个 
注册时间
2015-4-3 

复制

看起来很不错,可惜分不够,待下载后再说。
发消息 加好友
积分
319 
理想币
0 个 
彩币
5 个 
共享币
2 个 
注册时间
2015-6-21 

复制

支持,楼主分享的都是好指标.
发消息 加好友
积分
13972 
理想币
3567 个 
彩币
98 个 
共享币
880 个 
注册时间
2009-11-29 

复制

谢谢楼主分享!!!
发消息 加好友
积分
3200 
理想币
147 个 
彩币
50 个 
共享币
1939 个 
注册时间
2014-7-9 

复制

回复 6楼 @怡情永恒 的帖子

@怡情永恒 老师你好,这样的图标我找了好长时间,谢谢你提供这么好的公式。
老师,我按着提示安装后,出现仪表图压住主图的现象,而且图片较大,怎么做才能把图片缩小,做成你的那样的主图,请老师指导一下。



[ 本帖最后由 大道至简62 于 2015-11-9 21:41 编辑 ]
发消息 加好友
积分
3200 
理想币
147 个 
彩币
50 个 
共享币
1939 个 
注册时间
2014-7-9 

复制

引用:
原帖由 @大道至简62 于 2015-11-9 21:39 发表
怡情永恒 老师你好,这样的图标我找了好长时间,谢谢你提供这么好的公式。
老师,我按着提示安装后,出现仪表图压住主图的现象,而且图片较大,怎么做才能把图片缩小,做成你的那样的主图,请老师指导一下。
6699 ...    
这图片不是俺的,修改图片的话俺用CorelDRAW X6,新建一个文件-导入图片-修改图片大小与俺提供的图片一样--导出为bmp文件就可以的。CorelDRAW X6 自己百度吧,我也忘了哪里下载的
发消息 加好友
积分
126128 
理想币
94659 个 
彩币
96244 个 
共享币
6329 个 
注册时间
2010-11-20 

复制

回复 51楼 @怡情永恒 的帖子

@怡情永恒 谢谢老师,我去找一下。
发消息 加好友
积分
3200 
理想币
147 个 
彩币
50 个 
共享币
1939 个 
注册时间
2014-7-9 

复制

东西很好,谢谢提供!
发消息 加好友
积分
167 
理想币
0 个 
彩币
0 个 
共享币
105 个 
注册时间
2015-11-9 

复制

永恒老师,我下截了您说的版本,但发现T0002中没有子目录。
发消息 加好友
积分
4577 
理想币
523 个 
彩币
5 个 
共享币
997 个 
注册时间
2014-3-29 

复制

谢谢老师的无私奉献,
发消息 加好友
积分
7903 
理想币
17 个 
彩币
0 个 
共享币
3112 个 
注册时间
2009-9-30 

复制

回复 51楼 @怡情永恒 的帖子

@怡情永恒 老师你好,图片已经解决,谢谢你指点。
现在我把“仪表图”和现在用的“神枪手主图”数据放在一起,两者能容和,但有一个问题,就是出现两条日线数据,我截图你看一下。
所以我想把“仪表图”中的日线的数据去掉,和“神枪手主图”共用日线数据,其他不变,麻烦老师改一下好吗?



(一)神枪手主图
MA3:MA(C,3);
MA5:MA(C,5);
MA8:MA(C,8);
MA13:MA(C,13);
MA21:MA(C,21);
A2:=REF(MA21,1);
J1:=(MA21-A2)/A2*100;
MJ1:=MA(J1,3);
MA34:MA(C,34);
MA55:MA(C,55);
MA89:MA(C,89);
MA144:MA(C,144);
MA233:MA(C,233);
MA377:MA(C,377);
乖离2:=(MA21-MA34)/MA34*100;
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
MAX1:=MAX(MA21,MA34);
MAX2:=MAX(MAX1,MA55);
MIN3:=MIN(MA21,MA34);
MIN2:=MIN(MIN3,MA55);
K1:=(MAX2/MIN2-1)*100;
VAR2:=IF(K1<=8,1,0);
上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,55),1) AND MA(V,5)>MA(V,13) AND J1>REF(J1,1) AND
( L<=MA21 AND C>MA21 OR (CROSS(MA5,MA21)) ),5),L*0.98,'←神枪手');
神枪手选股:=FILTER(上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",1) AND MA(V,60)>REF(MA(V,55),1) AND MA(V,5)>MA(V,13) AND J1>REF(J1,1) AND
( L<=MA21 AND C>MA21 OR (CROSS(MA5,MA21)) ),5);{44.40%15240}
短线暴涨:DRAWTEXT(FILTER( (VAR1 OR VAR2) AND MA13>REF(MA13,1) AND COUNT(MA34>REF(MA34,1),3)=3 AND MA34>MA55 AND COUNT(CROSS(MA5,MA34),3) AND J1>MJ1 AND MA(V,5)>MA(V,55)
AND MA(V,55)>REF(MA(V,55),1),5),MA55*0.99,'短线暴涨'),COLORRED;
DRAWTEXT(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)<30 AND J1>MJ1 AND MA55>REF(MA55,1) AND COUNT(J1<1,3)>=1 ,L*0.995,'←买入'),COLORYELLOW;
DRAWTEXT(CROSS("KDJ.D"(5,2,3),"KDJ.K"(5,2,3)) AND "KDJ.D"(5,2,3)>65 AND J1<MJ1 AND COUNT(J1>1,3)>=1,H*1.005,'←卖出'),COLORGREEN;
DRAWTEXT(CROSS("KDJ.D"(18,9,6),"KDJ.K"(18,9,6)) AND "KDJ.D"(18,9,6)>60 AND "KDJ.J"(45,15,15)>90,H*1.03,'←顶'),COLORRED;
DRAWTEXT(CROSS(MA5,MA8) AND "KDJ.K"(5,3,3)>=50 AND "KDJ.J"(5,3,3)<31 ,L*0.92,'←再买'),COLORMAGENTA;
XL1:=((LLV(LOW,3) = LLV(LOW,55)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 - 20));
DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.4),'买点');
DRAWTEXT((XL3 > 0),(LOW - 0.2),'绝对底部');
X6:=REF(CLOSE,1);
X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);
DRAWTEXT(X9,(HIGH * 1.02),'出货'),COLOR9000F5;
STICKLINE(C>1.098*REF(C,1),C,O,0,0),COLORYELLOW;
VVAR1:=AMOUNT/VOL/7;
VVAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;


(二)仪表图
M8:MA(C,8),COLORCCCCCC;
M13:MA(C,13),COLOR00CCCC;
M21:MA(C,21),COLORCC00CC;
M34:MA(C,34),COLORCC00CC;
M89:IF(PERIOD>4,MA(C,89),DRAWNULL),COLOR00CC00;
M144:MA(C,144),COLORCCCC00;
LC:=REF(C,1);
主升浪:=ISLASTBAR AND M8>M21 AND M21>M89 AND M89>M144 AND M21>=REF(M21,1) AND M89>=REF(M89,1) AND M144>=REF(M144,1);
主浪回调:=ISLASTBAR AND C<LC AND (C<M8 OR M8<REF(M8,1)) AND M8>M21 AND M21>M89 AND M21>=REF(M21,1) AND M89>=REF(M89,1);
主浪深调:=ISLASTBAR AND C<LC AND C<M8 AND M8<REF(M8,1) AND M8<M89 AND M8<M21 AND M13>M21 AND M21>M89 AND M21>=REF(M21,1) AND M89>=REF(M89,1);
初升浪:=ISLASTBAR AND C>LC AND C>(M8 OR M13) AND M8>(M21 OR M13) AND M8>=REF(M8,1) AND C>M21 AND (M8 OR M13)>M21 AND M21>=REF(M21,1) AND M89<(C OR M8 OR M13);
底部反弹:=ISLASTBAR AND C>LC AND M144>M89 AND M89>M21 AND M8>M21;
探底阶段:=ISLASTBAR AND C<LC AND C<M8 AND M8<M13 AND M13<M21 AND M21<M89;
观望:=ISLASTBAR AND C<LC AND C<M13 AND M13<M21 AND M13<REF(M13,1) AND M21>REF(M21,1);
有牛:=ISLASTBAR AND C>LC AND M21>=REF(M21,1) AND C>=M89 AND M89<(C OR M8 OR M13) AND C>=M144;
放弃:=ISLASTBAR AND C<LC AND C<M13 AND C<M21 AND M21<M89 AND M21<REF(M21,1);
DRAWGBK(主升浪=0 AND 主浪回调=0 AND 主浪深调=0 AND 初升浪=0 AND 底部反弹=0 AND 探底阶段=0 AND 观望=0 AND 有牛=0 AND
         放弃=0,0,0,0,'观望',0),COLOR00BF00;
DRAWGBK(主升浪,0,0,0,'主升浪',0),COLORFF00FF;
DRAWGBK(主浪回调,0,0,0,'主浪回调',0),COLORFF8080;
DRAWGBK(主浪深调,0,0,0,'主浪深调',0),COLOR009500;
DRAWGBK(初升浪,0,0,0,'初升浪',0),COLOR00FFFF;
DRAWGBK(底部反弹,0,0,0,'底部反弹',0),COLORFFFF00;
DRAWGBK(探底阶段,0,0,0,'探底阶段',0);
DRAWGBK(观望,0,0,0,'观望',0),COLORFFFF00;
DRAWGBK(有牛,0,0,0,'有牛',0),COLOR00FFFF;
DRAWGBK(放弃,0,0,0,'放弃',0),COLOR00BF00;

[ 本帖最后由 大道至简62 于 2015-11-10 16:18 编辑 ]
发消息 加好友
积分
3200 
理想币
147 个 
彩币
50 个 
共享币
1939 个 
注册时间
2014-7-9 

复制

O(∩_∩)O哈哈~
发消息 加好友
积分
2417 
理想币
173 个 
彩币
0 个 
共享币
272 个 
注册时间
2003-6-7 

复制

引用:
原帖由 @大道至简62 于 2015-11-10 16:16 发表
怡情永恒 老师你好,图片已经解决,谢谢你指点。
现在我把“仪表图”和现在用的“神枪手主图”数据放在一起,两者能容和,但有一个问题,就是出现两条日线数据,我截图你看一下。
所以我想把“仪表图”中的日线的 ...    
我也不大懂怎么了,你把神枪手的ma天数才不多的合并成一个变量,下面对应的改一下应该不是太太复杂,自己慢慢弄吧

[ 本帖最后由 怡情永恒 于 2015-11-10 16:26 编辑 ]
发消息 加好友
积分
126128 
理想币
94659 个 
彩币
96244 个 
共享币
6329 个 
注册时间
2010-11-20 

复制

谢谢老师,谢谢分享

谢谢高人呀,不在效果怎么样
发消息 加好友
积分
70 
理想币
3 个 
彩币
0 个 
共享币
76 个 
注册时间
2015-9-19 

复制

支持源码!谢谢分享!楼主辛苦了!
发消息 加好友
积分
16453 
理想币
1144 个 
彩币
0 个 
共享币
1904 个 
注册时间
2009-9-9 

复制

后一页【ctrl+“→”】 【ctrl+“←”】前一页 还有5页内容,点此下一页
发新话题
理想论坛 » 指标公式分享交流区 » 仪表图(源码,通达信,主图,贴图)
指标公式分享交流区:积分规则

快速回复主题

选项

发帖请务遵守本站的相关规则,所有发表(包括转发)政治、色情非法信息者本站将实时提供发贴者个人信息给公安局,追究责任,特此申明!
具体规则请参见 理想论坛会员守则》 《净化论坛环境,打击恶意灌水》。

您需要登录后才可以发帖

[完成后可按 Ctrl+Enter 发布]

理想论坛上的网友发表的帖子纯属个人意见,理想论坛不负任何责任!广告赞助商内容与本站无关!免责声明
理想论坛值班电话[9:30~18:30]: ☎ 400 016 5518-1 ☎ 186 4906 9487(广告)187 1028 6081(广告)
找回密码 软件区:1006648222 百宝箱: 1006267111 广告: 1006269111 广告: 3145821447
诚信档案编号:CX20150604010215010383 信誉编号:TL852015042710940
工业和信息化部信息备案: 京ICP备15035364号 京ICP证151057号
关闭底部 打开底部 回顶部 到页底 理想论坛微信号:lixiang55188 扫描下载理想选股App
关闭
关闭