手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

如何自己制作飞狐解盘指标!

设置
4401 14 ●极乐●了和 Lv.3 发表于 · 2005-5-23 21:05 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
解盘指标是飞狐的特色指标,也是目前很受欢迎的指标之一。

飞狐目前有3个解盘函数:

1.解盘文字

别名: 显示解盘文字
所属类别: 解盘函数  参数数量: 2

在[解]中输出解盘文字。
用法:
EXPLAIN(COND,TEXT),在COND条件满足时在[解]中输出解盘文字,可以用'\n'空一行。
例如:
EXPLAIN(HIGH>=HHV(HIGH,20), '创20天新高\n')
表示在创20天新高时在[解]中输出解说并空1行显示下条解盘文字。

2.解盘数值



别名: 显示解盘数值
所属类别: 解盘函数  参数数量: 5

在[解]中输出带数值的解盘。
用法:
EXPLAINEX(COND,TEXT,NUMBER,PRECISION,SKIPLINES)
在COND条件满足时在[解]中输出数值解说。
PRECISION为小数显示位数,SKIPLINES为空出几行显示下一个解盘
例如:
EXPLAINEX(HIGH>=HHV(HIGH,20), '20天新高价:',HIGH,2,1)表示在创20天新高时在[解]中输出数值解说。

3.解盘图标



别名: 画解盘图标
所属类别: 解盘函数  参数数量: 2

在[解]中绘制解盘图标。
用法:
EXPLAINICON(COND,ICON),在COND条件满足时在[解]中绘制解盘图标
ICON为数字时4种图标编码为1-4(阴雨、初彩、中彩、彩虹)。为字符串表示自制图标
例如:
EXPLAINICON(HIGH>=HHV(HIGH,20), 2)
表示在创20天新高时在[解]中画2号图标(雨后初彩虹)。
EXPLAINICON(HIGH>=HHV(HIGH,20), 'MyBMP')
表示在创20天新高时在[解]中画FmlDLL子目录下的自制图标MyBMP.BMP。
可用ALIGN0中对齐,ALIGN1左对齐,ALIGN2右对齐
我没水平别惹我
Lv.2
发表于 2005-6-2 14:42 复制 查看全部楼层
:D:D:D:D
ddddddddd
聖光
Lv.4
发表于 2005-5-24 05:32 复制 查看全部楼层
谢谢朋友!!!!!!

附件

006.jpg
老李126
Lv.3
发表于 2005-5-23 21:46 复制 查看全部楼层
ddddddddd
股啸龙吟
Lv.3
发表于 2005-5-23 21:22 复制 查看全部楼层
谢谢朋友!!!!!!
●极乐●了和
Lv.3
发表于 2005-5-23 21:15 复制 查看全部楼层
ddddddddddddddd
●极乐●了和
Lv.3
发表于 2005-5-23 21:14 复制 查看全部楼层
分笔成交统计数据解盘

{分笔成交统计}
v1:=VOL;
V2:=ref(v1,1)/240;
t:=intpart(time/100);
m:=IF(T<1000,T-0930,IF(T<1100,T-1000+30,IF(T<1200,T-1100+90,
IF(T<1400,T-1300+120,IF(T<1500,T-1400+180,240))))) ;
V3:=SUM(V,0);
分笔量比:V3/V2/m;
分笔笔数:BARSCOUNT(C) ;
进场筹码:SUM(BUYVOL,0) ;
出场筹码:SUM(SELLVOL,0) ;
主动买单:SUM(IF(BUYVOL>=100,VOL,0),0),COLOR0000FF;
主动卖单:SUM(IF(SELLVOL>=100,VOL,0),0),COLOR00FF00;
a:=BUYVOL>100;
a1:=SELLVOL>100;
a2:=BIDVOL(1);
a3:=ASKVOL(1);
a4:=BUYVOL-a2;
a5:=SELLVOL-a3;
a6:=IF( a>a2 and a2<a,a4,0);
a7:=IF( a1>a3 and a3<a1,a5,0);
隐性买单:SUM(a6,0),pointdot,COLORcyan;
隐性卖单:SUM(a7,0),pointdot,COLORblue;
STICKLINE(a6>0,0,a6,8,0),COLORcyan;
STICKLINE(a7>0,0,a7,8,0),COLORblue;
EXPLAINEX(1=1,'【分笔量比】=',分笔量比,2,0),COLORred;
EXPLAINEX(1=1,'【分笔笔数】=',分笔笔数,2,0),COLORcyan;
EXPLAINEX(1=1,'【进场筹码】=',进场筹码,2,0),COLORMAGENTA;
EXPLAINEX(1=1,'【出场筹码】=',出场筹码,2,0),COLORyellow;
EXPLAINEX(1=1,'【主动买单】=',主动买单,2,0),COLORgreen;
EXPLAINEX(1=1,'【主动卖单】=',主动卖单,2,0),COLORwhite;
EXPLAINEX(1=1,'【隐性买单】=',隐性买单,2,0),COLORblue;
EXPLAINEX(1=1,'【隐性卖单】=',隐性卖单,2,0),COLORred;
●极乐●了和
Lv.3
发表于 2005-5-23 21:13 复制 查看全部楼层
第八种 个股大盘对比22种情况解盘

个股MSD:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
大盘MSD:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
Q1:=个股MSD<=20 AND 大盘MSD<=20;
Q2:=个股MSD>=20 AND 大盘MSD<=20 AND RANGE(个股MSD,20,50) AND 个股MSD> REF(个股MSD,2);
Q3:=RANGE(个股MSD,50,80) AND RANGE(大盘MSD,20,50) AND 个股MSD>=REF(个股MSD,1) AND 大盘MSD>REF(大盘MSD,1);
Q4:=EXIST(cross(个股MSD,20),4) AND 大盘MSD>20 AND 大盘MSD>REF(大盘MSD,1) AND 大盘MSD>个股MSD ;
Q5:=RANGE(大盘MSD,80,100) AND cross(个股MSD,50) AND 个股MSD<80 AND 个股MSD>=REF(个股MSD,2);
Q6:=大盘MSD<20  AND cross(个股MSD,50) ;
Q7:=RANGE(大盘MSD,50,20 ) AND 个股MSD<=20 AND 个股MSD<REF(个股MSD,2);
Q8:=大盘MSD<ref(大盘MSD,2) AND 个股MSD<REF(个股MSD,2) AND 大盘MSD<80 AND 个股MSD<80 AND 大盘MSD>50  AND 个股MSD>50;
Q9:=大盘MSD<ref(大盘MSD,2) AND 个股MSD<REF(个股MSD,2) AND 大盘MSD<50 AND 个股MSD<50 AND 大盘MSD>20 AND 个股MSD>20;
Q10:=大盘MSD< ref(大盘MSD,2) AND RANGE(个股MSD,20,50) AND RANGE(大盘MSD,20,50) AND 个股MSD>REF(个股MSD,1)AND CROSS(个股MSD,大盘MSD);
Q11:=RANGE(个股MSD,80,100) AND RANGE(大盘MSD,80,100) AND 大盘MSD<=ref(大盘MSD,2) AND 个股MSD<=REF(个股MSD,1);
Q12:=RANGE(个股MSD,50,80) AND RANGE(大盘MSD,50,80) AND 大盘MSD<=ref(大盘MSD,2) AND 个股MSD>=REF(个股MSD,1) AND CROSS(个股MSD,大盘MSD);
Q13:=RANGE(个股MSD,80,100) AND RANGE(大盘MSD,80,100) AND 大盘MSD>=ref(大盘MSD,1) AND 个股MSD>=REF(个股MSD,1);
Q14:=RANGE(个股MSD,50,80) AND RANGE(大盘MSD,50,80) AND 大盘MSD>=ref(大盘MSD,1) AND 个股MSD>=REF(个股MSD,1);
Q15:=RANGE(个股MSD,50,80) AND RANGE(大盘MSD,80,100) AND 个股MSD>=REF(个股MSD,1);
Q16:=RANGE(个股MSD,80,100) AND RANGE(大盘MSD,50,80) AND 个股MSD>=REF(个股MSD,1) AND 大盘MSD<=ref(大盘MSD,1);
Q17:=RANGE(个股MSD,80,100) AND RANGE(大盘MSD,50,80) AND 个股MSD<=REF(个股MSD,1) AND 大盘MSD<=ref(大盘MSD,1);
Q18:=RANGE(个股MSD,20,50) AND RANGE(大盘MSD,0,20) AND 个股MSD<=REF(个股MSD,1)AND 大盘MSD<=ref(大盘MSD,1);
Q19:=RANGE(个股MSD,20,50) AND RANGE(大盘MSD,0,20) AND 个股MSD<=REF(个股MSD,1)AND 大盘MSD<=ref(大盘MSD,1) AND ref(大盘MSD,1)>20 AND ref(大盘MSD,2)>20 AND ref(大盘MSD,3)<20;
Q20:=RANGE(个股MSD,0,20) AND RANGE(大盘MSD,20,50) AND 大盘MSD>=ref(大盘MSD,1);
Q21:=EXIST(cross(个股MSD,20),3) AND 大盘MSD>20 AND 大盘MSD>REF(大盘MSD,1) AND 个股MSD>大盘MSD;
Q22:=RANGE(个股MSD,50,80) AND RANGE(大盘MSD,20,50) AND 个股MSD>ref(个股MSD,1) AND ref(个股MSD,1)<ref(个股MSD,2) ;
EXPLAIN(1=1,'     【个股大盘对比分析】'),COLORYELLOW;
EXPLAIN(Q1,'指数与个股的MSD同时处于相对低位区,表明个股与大盘同步下跌,表明大盘与个股处于历史低位,密切关注可能的向上突破;'),COLORFF00FF;
EXPLAIN(Q2,'指数MSD处于低位,个股MSD脱离低位区并向上突破,表明有庄先行介入,择机买入;'),colorred;
EXPLAIN(Q3,'大盘反弹,个股已经突破分水岭,进入强势;'),colorred;
EXPLAIN(Q4 ,'个股随大盘一起启动,赶快行动,切勿错过时机;'),coloryellow;
EXPLAIN(Q5,'后来者居上,个股主升浪开始,买入;'),coloryellow;
EXPLAIN(Q6,'个股逆市上涨,突破分水岭,择机介入,机者成交量,均线和K线的配合;'),colorgreen;
EXPLAIN(Q7,'个股逆市下跌,关注对于20试庄线的突破;'),colorred;
EXPLAIN(Q8 ,'个股随同大盘顺势下跌,个股行情结束,下跌刚刚开始.;'),coloryellow;
EXPLAIN(Q9,'个股顺势继续下跌,个股行情仍没有见底迹象;'),coloryellow;
EXPLAIN(Q10 ,'大盘下跌而个股上涨选择买入时机;'),coloryellow;
EXPLAIN(Q11,'大盘与个股皆处强势拉升的未期,有可能转势,择机卖出;'),colorgreen;
EXPLAIN(Q12,'大盘从高位下跌,而个股逆市上涨,有拉高出货的嫌疑,仔细分析,择机出局;'),colorgreen;
EXPLAIN(Q13,'大盘与个股皆处强势拉升中期;'),colorgreen;
EXPLAIN(Q14,'大盘与个股皆处强势拉升的初级阶段;'),colorgreen;
EXPLAIN(Q15,'大盘处于超强势,个股拉渐渐进入强势;'),colorgreen;
EXPLAIN(Q16,'大盘处于拉升未期,刚开始下跌,个股反而逆市上涨,寻找介入和出货点;'),colorgreen;
EXPLAIN(Q17,'大盘处于拉升未期,刚开始下跌,个股也处拉升的未期,注意见顶;'),colorgreen;
EXPLAIN(Q18,'大盘处于下跌未期,可能是最后一跌,个股可能还有一跌,现在不是介入时机,等待介入时机;'),colorgreen;
EXPLAIN(Q19,'大盘刚突破底部又开始下跌,寻找介入时机;'),colorgreen;
EXPLAIN(Q20,'大盘刚突破底部,个股仍处于底部,寻找介入时机;'),colorgreen;
EXPLAIN(Q21,'个股率先起动,大盘后起动,有可能是领涨股龙头;'),colorgreen;
EXPLAIN(Q22,'个股洗盘结束,再次起动,有可能是领涨股龙头;'),colorgreen;
●极乐●了和
Lv.3
发表于 2005-5-23 21:11 复制 查看全部楼层
第七种 股价预测
EXPLAIN(1=1,'        【股价预测】'),COLORYELLOW;
Var011:=(CLOSE+HIGH+LOW)/3;
Var012:=HIGH-LOW;
Var014:=VAR011+VAR012;
Var015:=VAR011-VAR012;
Var016:=2*VAR011-LOW;
Var017:=2*VAR011-HIGH;
明日转:=(ref(C,2)*2-ref(C,5));
EXPLAINEX(vol>0,'【明天生命】=',明日转,1,0),COLORWHITE;
EXPLAINEX(vol>0,'【明天最高】=',var014,1,0),COLORYELLOW;
EXPLAINEX(vol>0,'【范围上限】=',var016,1,0),COLORMAGENTA;
EXPLAINEX(vol>0,'【范围下限】=',var017,1,0),COLORCYAN;
EXPLAINEX(vol>0,'【明天最低】=',var015,1,0),COLORGREEN;
●极乐●了和
Lv.3
发表于 2005-5-23 21:10 复制 查看全部楼层
第六种 CDP指标分析

{CDP指标分析}
PT:=REF(HIGH,1)-REF(LOW,1);
CDP:=(HIGH+LOW+CLOSE)/3;
最高:=CDP+PT;
最低:=CDP-PT;
近高值:=2*CDP-LOW;
近低值:=2*CDP-HIGH;
EXPLAIN(1=1,'        【CDP指标分析】'),COLORYELLOW;
EXPLAINEX(1=1,'盘中最高价:',最高,2,0),COLORFFCCFF;
EXPLAINEX(1=1,'盘中最低价:',最低,2,0),COLORFFCCFF;
EXPLAINEX(1=1,'盘中近高值:',近高值,2,0),COLORFFCCFF;
EXPLAINEX(1=1,'盘中近低值:',近低值,2,0),COLORFFCCFF;
EXPLAINEX(BETWEEN(O,近高值,近低值),'盘局买入价参考:',近低值,2,0);
EXPLAINEX(BETWEEN(O,近高值,近低值),'盘局卖出价参考:',近高值,2,0);
EXPLAINEX(BETWEEN(O,最高,近高值) OR (O>最高),'盘局买入价参考:',最高,2,0),COLORRED;
EXPLAINEX(BETWEEN(O,最低,近低值) OR (O<最低),'盘局卖出价参考:',最低,2,0),COLORGREEN;
EXPLAIN(1=1,'股价波动不大时,开盘价位于近高值与近低值间
,可在近低值价位买进,近高值价位卖出。'),COLOR0099FF;
EXPLAIN(1=1,'开盘价位于最高值或最低值附近,意味着跳空,是大行情发动的开始,可在最高值价位追买,或最低值价位追卖。'),COLORFF00FF;
●极乐●了和
Lv.3
发表于 2005-5-23 21:10 复制 查看全部楼层
第五种 资金面解盘

EXPLAIN(1=1,'        【资金面分析】'),COLORYELLOW;
Var11:=ma((v/(h-l)),4);
Var33:=abs(c-o);Var44:=v/(h-l);
EXPLAIN(Var44<var11 AND Var33<ma(Var33,4),'资金无入场意愿,萎缩中;'),COLORGREEN;
EXPLAIN(Var44<var11 AND Var33>ma(Var33,4),'场内资金运作行为;'),COLORFFCC66;
EXPLAIN(Var44>var11 AND Var33<ma(Var33,4),'多空双方激烈争夺中;'),COLORFF00FF;
EXPLAIN(Var44>var11 AND Var33>ma(Var33,4),'场外资金介入(或出局)意愿强烈;'),COLORRED;
EXPLAINEX(1=1,'该股五日换手%=',sum(v/capital*100,5),2,0);
EXPLAINEX(1=1,'十日换手%=',sum(v/capital*100,10),2,0);
EXPLAINEX(1=1,'二十日换手%=',sum(v/capital*100,20),2,0);
EXPLAINEX(1=1,'百日换手%=',sum(v/capital*100,100),2,0);
EXPLAINEX(1=1,'获利盘比例=',WINNER(c)*100,2,0);
EXPLAINEX(1=1,'套牢盘比例=',100-WINNER(c)*100,2,0);
●极乐●了和
Lv.3
发表于 2005-5-23 21:09 复制 查看全部楼层
第四种 K线形态分析
EXPLAIN(1=1,'          【形态分析】'),COLORYELLOW;
早晨之星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏之星:=REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);
长十字:=CLOSE=OPEN AND HIGH/LOW >1.03;
垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
早晨十字星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1) > REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) AND
CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5);
倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5);
锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5);
吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);
穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))
OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1));
乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);
曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);
身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 AND
MAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1));
十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1));
平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;
平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001 and abs(ref(low,1)-ref(low,2))/ref(low,1)<=0.001);
大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018;
三个白武士:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100  AND REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
出水芙蓉:=(OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))
AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049);
上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND
REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);
下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4);
跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
光脚阴线:=LOW=CLOSE AND HIGH<>LOW;
光头阳线:=HIGH=CLOSE AND HIGH<>LOW;
分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;
长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;
十字星:=CLOSE=OPEN AND HIGH<>LOW;
大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;
好友反攻:=(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)
OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002);
倾盆大雨:=REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1);
EXPLAIN(倾盆大雨,'倾盆大雨,见顶信号;'),COLORCYAN;
EXPLAIN(大阴烛,'大阴烛,后市向淡,发生逆转;'),COLORCYAN;
EXPLAIN(好友反攻,'好友反攻,跌势已尽,要展开一段反弹行情;'),COLORRED;
EXPLAIN(跳空缺口,'跳空缺口,突破长期盘整,向上跳空,上涨行情开始;向下跳空,下跌行情开始;'),COLORWHITE;
EXPLAIN(光脚阴线,'光脚阴线,下跌信号;'),COLORCYAN;
EXPLAIN(光头阳线,'光头阳线,多方积极上攻态势,后市看涨;'),COLORRED;
EXPLAIN(三只乌鸦,'三只乌鸦站枝头,可能见顶回落;'),COLORCYAN;
EXPLAIN(分离,'分离,注意看涨分离和看跌分离;'),COLORWHITE;
EXPLAIN(长下影,'长下影,持续下跌后出现,有可能止跌回升;在升势末期出现,须多加留意;'),COLORRED;
EXPLAIN(长上影,'长上影,表明行情上档压力沉重,升势受阻;'),COLORCYAN;
EXPLAIN(下跌三部曲,'下跌三部曲,下跌信号;'),COLORRED;
EXPLAIN(上升三部曲,'上升三部曲,上涨信号;'),COLORCYAN;
EXPLAIN(早晨之星,'早晨之星,见底回升;'),COLORRED;
EXPLAIN(黄昏之星,'黄昏之星,见顶回落;'),COLORCYAN;
EXPLAIN(十字星,'十字星,重要的警告信号,原趋势停顿或反转;'),COLORWHITE;
EXPLAIN(长十字,'长十字,重要的警告信号,原趋势停顿或反转;'),COLORWHITE;
EXPLAIN(垂死十字,'垂死十字,下跌信号;'),COLORCYAN;
EXPLAIN(早晨十字星,'早晨十字星,上涨信号,见底回升;'),COLORRED;
EXPLAIN(黄昏十字星,'黄昏十字星,趋势停顿或反转,下跌信号,见顶回落;'),COLORCYAN;
EXPLAIN(射击之星,'射击之星,出现在短期的上升趋势,表明市场顶部就在眼前,可能见顶回落,可靠性低;'),COLORCYAN;
EXPLAIN(倒转锤头,'倒转锤头构成一个看涨信号,可能见底回升;'),COLORRED;
EXPLAIN(锤头,'锤头,可能见底回升,如有量配合,信号强烈;'),COLORRED;
EXPLAIN(吊颈,'吊颈,上升行情中见顶回落,顶部出现,见顶信号;'),COLORCYAN;
EXPLAIN(平顶,'平顶,意味行情摸高见顶,股价行将反转。但反转下跌力度较小;'),COLORCYAN;
EXPLAIN(穿头破脚,'穿头破脚,顶部出现,见顶回落信号;'),COLORCYAN;
EXPLAIN(乌云盖顶,'乌云盖顶,见顶回落信号;'),COLORCYAN;
EXPLAIN(曙光初现,'曙光初现,行情将演化为V型反转或止跌横盘趋势。后市见底回升;'),COLORRED;
EXPLAIN(身怀六甲,'身怀六甲,出现在底部,是见底回升信号;出现在顶部,是见顶回落信号;'),COLORRED;
EXPLAIN(十字胎,'十字胎;'),COLORRED;
EXPLAIN(平底,'平底,行情探低见底,股价行将反转上升,但力度较小;'),COLORRED;
EXPLAIN(大阳烛,'大阳烛,在上升行情中出现,则意味着行情剧烈地向上攀升。在下跌行情中出现,则意味着行情剧烈地向上反弹;'),COLORRED;
EXPLAIN(三个白武士,'三个白武士,每日收盘价上移,表示可能见底回升;'),COLORRED;
EXPLAIN(双飞乌鸦,'双飞乌鸦,行情开始疲软将见顶回落;'),COLORCYAN;
EXPLAIN(孕育线,'孕育线,注意股价位置;'),COLORWHITE;
EXPLAIN(多方炮,'多方炮,在底部出现有上涨可能,在中间出现有可能是上涨中继,顶部出现是复合见顶信号;'),COLORRED;
EXPLAIN(出水芙蓉,'出水芙蓉,阳线穿过20、40、60日季均线,上攻势头初现;'),COLORRED;
●极乐●了和
Lv.3
发表于 2005-5-23 21:08 复制 查看全部楼层
第三种 均线系统解盘



EXPLAIN(1=1,'        【均线系统解盘】'),COLORYELLOW;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA30:=MA(C,30);
MA60:=MA(C,60);
MA125:=MA(C,125);
MA250:=MA(C,250);
EXPLAIN((MA5>MA10 and MA10>MA30 and MA5>MA30),'短期均线多头排列;'),COLORRED;
EXPLAIN((MA5<MA10 and MA10<MA30 and MA5<MA30),'短期均线空头排列;'),COLORGREEN;
EXPLAIN((MA30>MA60 and MA30>MA125 and MA60>MA125),'中期均线多头排列;'),COLORRED;
EXPLAIN((MA30<MA60 and MA30<MA125 and MA60<MA125),'中期均线空头列排;'),COLORGREEN;
EXPLAIN((MA60>MA125 and MA125>MA250 and MA60>MA250),'长期均线多头排列;'),COLORRED;
EXPLAIN((MA60<MA125 and MA125<MA250 and MA60<MA250),'长期均线空头排列;'),COLORGREEN;
EXPLAIN((CROSS(MA5,MA10)),'短期5日10日均线金叉;'),COLORRED;
EXPLAIN((CROSS(MA10,MA5)),'短期5日10日均线死叉;'),COLORGREEN;
EXPLAIN((CROSS(C,MA125)),'今日股价上穿半年线;'),COLORFF00FF;
EXPLAIN((CROSS(MA125,C)),'今日股价跌破半年线;'),COLORGREEN;
EXPLAIN((CROSS(C,MA250)),'今日股价上穿一年线;'),COLORFF00FF;
EXPLAIN((CROSS(MA250,C)),'今日股价跌破一年线;'),COLORGREEN;
EXPLAIN((CROSS(C,MA60) and CROSS(C,MA125) and CROSS(C,MA250)),'股价一阳穿三线;'),COLORRED;
EXPLAIN((MA30>REF(MA30,1)),'30日均线趋势向上;'),COLORRED;
EXPLAIN((MA30>REF(MA30,1) AND MA30<REF(MA30,1)*1.001),'30日均线趋势走平;'),COLORFFCC66;
EXPLAIN((MA30<REF(MA30,1)),'30日均线趋势向下;'),COLORGREEN;
EXPLAIN((MA5>REF(MA5,1)*1.015),'5日均线强劲向上;'),COLORRED;
EXPLAIN((MA5>REF(MA5,1) AND MA5<REF(MA5,1)*1.005),'5日均线方向不明;'),COLORYELLOW;
EXPLAIN((MA5<REF(MA5,1)*0.985),'5日均线快速向下;'),COLORGREEN;
●极乐●了和
Lv.3
发表于 2005-5-23 21:07 复制 查看全部楼层
第二种 常用技术指标分析

EXPLAIN(1=1,'        【常用技术指标分析】'),COLORYELLOW;
DIFF:=(EMA(CLOSE,3) - EMA(CLOSE,13));
DEA:=EMA(DIFF,9);
tj:=(diff>dea);
tj1:=(diff>-0.1);
MACD:=2*(DIFF-DEA);
JC:=CROSS(DIFF,DEA);
SC:=CROSS(DEA,DIFF);
DCJC:=JC AND DEA>0;
EXPLAIN((JC AND DEA>0),'MACD在0轴上金叉提示加仓;'),COLORRED;
EXPLAIN((JC AND DEA<0),'MACD在0轴下金叉酌情买入;'),COLORRED;
EXPLAIN((SC AND DEA>0),'MACD在0轴上多次死叉;'),COLORGREEN;
EXPLAIN((SC AND DEA<0),'MACD在0轴下多次死叉;'),COLORGREEN;
EXPLAIN((MACD<0 AND ABS(MACD)>REF(ABS(MACD),1)),'MACD绿柱增长提示卖出;'),COLORGREEN;
EXPLAIN((MACD<0 AND ABS(MACD)<REF(ABS(MACD),1)),'MACD绿柱缩短提示买入;'),COLORRED;
EXPLAIN((LLV(LOW,60)=LOW)AND(NOT(LLV("MACD.DEA",60)="MACD.DEA")),'MACD底背离提示示买入;'),COLORRED;
EXPLAIN((HHV(HIGH,60)=HIGH)AND(NOT(HHV("MACD.DEA",60)="MACD.DEA")),'MACD顶背离提示卖出;'),COLORGREEN;
EXPLAIN(CROSS("MACD.DIFF","MACD.DEA")AND(BARSLAST(CROSS("MACD.DIFF","MACD.DEA"))>=3),'MACD二次金叉提示买入,股价上涨幅度会较大。'),COLORRED;
EXPLAIN(CROSS("MACD.DEA","MACD.DIFF")AND(BARSLAST(CROSS("MACD.DEA","MACD.DIFF"))>=3),'MACD二次死叉提示卖出,股价下跌幅度会较大。'),COLORGREEN;
EXPLAIN((COUNT(CLOSE<REF(CLOSE,1),30)>18AND(COUNT(CLOSE<REF(CLOSE,1),3)=3))AND(COUNT("MACD.MACD">REF("MACD.MACD",1),30)>18),'MACD反转--股价将可能反转向上。'),COLORRED;
EXPLAIN((COUNT(CLOSE>REF(CLOSE,1),30)>18AND(COUNT(CLOSE>REF(CLOSE,1),3)=3))AND(COUNT("MACD.MACD"<REF("MACD.MACD",1),30)>18),'MACD反转--股价将可能反转向下。'),COLORGREEN;
EXPLAIN((COUNT(DCJC,20)=2 AND JC AND DEA>0),'MACD在0轴上2金叉;')COLORredCOLORred;
EXPLAIN((COUNT(DCJC,20)=3 AND JC AND DEA>0),'MACD在0轴上3金叉;');
EXPLAIN((COUNT(DCJC,20)=4 AND JC AND DEA>0),'MACD在轴上4金叉;');
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
EXPLAIN("RSI.RSI1"<15AND(BARSLAST("RSI.RSI1"<15)>=1),'RSI相对强弱指标超卖,属买入信号。'),COLORRED;
EXPLAIN("RSI.RSI1">85AND(BARSLAST("RSI.RSI1">85)>=1),'RSI相对强弱指标超买,属卖出信号。'),COLORGREEN;
EXPLAIN((((LLV(L,20)=L)AND(NOT(LLV("RSI.RSI1",20)="RSI.RSI1")))OR(COUNT(C<REF(C,1),30)>18AND(COUNT("RSI.RSI1">REF("RSI.RSI1",1),30)>18)))AND("RSI.RSI1"<20),'RSI相对强弱指标底背离,股价在低位时属买入信号。'),COLORRED;
EXPLAIN((((HHV(H,20)=H)AND(NOT(HHV("RSI.RSI1",20)="RSI.RSI1")))OR(COUNT(C>REF(C,1),30)>18AND(COUNT("RSI.RSI1"<REF("RSI.RSI1",1),30)>18)))AND("RSI.RSI1">80),'RSI相对强弱指标顶背离,股价在高位时属卖出信号。'),COLORGREEN;
EXPLAIN(CROSS("RSI.RSI1","RSI.RSI2")AND("RSI.RSI1"<50),'RSI相对强弱指标金叉属买入信号。'),COLORRED;
EXPLAIN(CROSS("RSI.RSI2","RSI.RSI1")AND("RSI.RSI1">50),'RSI相对强弱指标死叉,属卖出信号。'),COLORGREEN;
EXPLAIN("RSI.RSI1"<5,'RSI相对强弱指标极低位,强烈买入信号。'),COLORRED;
EXPLAIN("RSI.RSI1">93,'RSI相对强弱指标极高位,强烈卖出信号。'),COLORGREEN;
EXPLAIN(RSI1<35,'RSI顶背离提示买入;'),COLORRED;
EXPLAIN(CROSS(74,RSI1),'RSI顶背离提示卖出;')COLORGREEN;
EXPLAIN(("KDJ.K"<=20 AND "KDJ.D"<=20),'KD超卖指示买入;')COLORRED;
EXPLAIN(("KDJ.K">=80 AND "KDJ.D">=80),'KD超买逢高卖出;')COLORGREEN;
EXPLAIN(CROSS("KDJ.K","KDJ.D") AND (COUNT(VOL>REF(VOL,1),30)>3 AND (VOL/CAPITAL<=(10/100))) AND (("KDJ.K"<=20 AND "KDJ.D"<=20)),'KD金叉买入,低市值或成交清淡个股应忽略此信号。')COLORRED;
EXPLAIN(CROSS("KDJ.D","KDJ.K") AND ("KDJ.K">=60 AND "KDJ.D">=60) AND (BARSLAST(CROSS("KDJ.D","KDJ.K")AND("KDJ.K">=60 AND "KDJ.D">=60))>=1) AND
(BARSLAST(CROSS("KDJ.D","KDJ.K") AND ("KDJ.K">=60 AND "KDJ.D">=60))<=7),'KD二次死叉提示卖出;')COLORGREEN;
EXPLAIN(("KDJ.J"<0),'KDJ异常逢低买入')COLORRED;
EXPLAIN(((HHV(HIGH,20)=HIGH) AND (NOT(HHV("KDJ.K",20)="KDJ.K" OR (HHV("KDJ.D",20)="KDJ.D")))) OR (COUNT(CLOSE>REF(CLOSE,1),30)>18 AND (COUNT("KDJ.K"<REF("KDJ.K",1),30)>18 OR (COUNT("KDJ.D"<REF("KDJ.D",1),30)>18))),'KD顶背离提示卖出;')COLORGREEN;
EXPLAIN(((LLV(LOW,20)=LOW) AND (NOT(LLV("KDJ.K",20)="KDJ.K" OR (LLV("KDJ.D",20)="KDJ.D")))) OR (COUNT(CLOSE<REF(CLOSE,1),30)>18 AND (COUNT("KDJ.K">REF("KDJ.K",1),30)>18 OR (COUNT("KDJ.D">REF("KDJ.D",1),30)>18))),'KD底背离提示买入;')COLORRED;
日K:="KDJ.K#DAY"(20,5,5);
日D:="KDJ.D#DAY"(20,5,5);
周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);
EXPLAIN((CROSS(日K,日D)),'日KD金叉且底背离买入;')COLORRED;
EXPLAIN((CROSS(日D,日K)),'日KD死叉且顶背离必须卖出;')COLORGREEN;
EXPLAIN((CROSS(周K,周D)),'周KD金叉且底背离买入;')COLORRED;
EXPLAIN((CROSS(周D,周K)),'周KD死叉且顶背离必须卖出;')COLORGREEN;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
UPR:=BBI+3*STD(BBI,10);
DWN:=BBI-3*STD(BBI,10);
var55:=(UPR-DWN)/UPR<0.03;
var56:=(UPR-DWN)/UPR>0.18;
var57:=(MA(CLOSE,60)-MA(CLOSE,5))/MA(CLOSE,60)>0.15;
var58:=(MA(CLOSE,5)-MA(CLOSE,60))/MA(CLOSE,5)>0.15;
EXPLAIN(var55,'布林线收窄可能变盘;')COLORMAGENTA;
EXPLAIN(var57 and var56 and CLOSE>OPEN ,'布林上下乖离太大可能反弹;')COLORFF00FF;
EXPLAIN(var58 and var56 and CLOSE<OPEN ,'布林上下乖离太大可能回落;')COLORGREEN;
EXPLAIN(CROSS(CLOSE,"SAR") AND (ABS(CLOSE-"SAR")/CLOSE>=0.01),'SAR向上突破提示买入;')COLORRED;
EXPLAIN(CROSS("SAR",CLOSE) AND (ABS(CLOSE-"SAR")/CLOSE>=0.01),'SAR向下突破提示卖出;')COLORGREEN;
TYP := (HIGH + LOW + CLOSE)/3;
cci:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
EXPLAIN(cci<-100,'CCI指标底位,买入机会。'),COLORRED;
EXPLAIN(cci>100,'CCI指标高位,卖出机会。'),COLORGREEN;
explain((vol/CAPITAl)>0.075,'换手过大,小心主力出逃,短期头部。'),COLORYELLOW;
wr:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
explain(wr>-20,'W&R超买,即将见顶,应及时卖出。'),COLORGREEN;
explain(wr<-80,'W&R超卖,即将见底,应伺机买进。'),COLORRED;
MTM := CLOSE-REF(CLOSE,6);
MTMMA := MA(MTM,6);
EXPLAIN(CROSS(MTM,MTMMA),'MTM从下向上突破MTMMA,买入信号。'),COLORRED;
EXPLAIN(CROSS(MTMMA,MTM),'MTM从上向下跌破MTMMA,卖出信号。'),COLORGREEN;
EXPLAIN("ARBR.AR"<50,'ARBR人气指标超卖,属买入信号。'),COLORRED;
EXPLAIN("ARBR.AR">200,'ARBR人气指标超买,属卖出信号。'),COLORGREEN;
EXPLAIN(((HHV("ARBR.AR",10)-"ARBR.AR")/HHV("ARBR.AR",10))>=0.5,'ARBR人气指标异常,若股价从高价下跌,属买入信号。'),COLORRED;
EXPLAIN((("ARBR.AR"-LLV("ARBR.AR",10))/LLV("ARBR.AR",10))>=0.5,'ARBR人气指标异常,若股价从低价上升,属卖出信号。'),COLORGREEN;
EXPLAIN("ARBR.BR"<50,'ARBR意愿指标显示股价随时反弹考虑买入。'),COLORRED;
EXPLAIN("ARBR.BR">300,'ARBR意愿指标显示股价随时下挫考虑卖出。'),COLORFF00FF;
EXPLAIN(CROSS("ARBR.AR","ARBR.BR")AND("ARBR.AR"<50OR"ARBR.BR"<50),'ARBR人气意愿指标金叉,属买入信号。'),COLORRED;
EXPLAIN(CROSS("ARBR.BR","ARBR.AR")AND("ARBR.AR">180OR"ARBR.BR">300),'ARBR人气意愿指标死叉,属卖出信号。'),COLORGREEN;
EXPLAIN((COUNT(C<REF(C,1),30)>18AND(COUNT(C<REF(C,1),3)=3))AND((COUNT("OBV.OBV">REF("OBV.OBV",1),30)>18)AND(COUNT("OBV.OBV">REF("OBV.OBV",1),3)=3))AND(COUNT(VOL>REF(VOL,1),30)>3AND(VOL/CAPITAL<=(10/100))),'OBV能量潮显示买盘较强属买入信号。'),COLORRED;
EXPLAIN((COUNT(C>REF(C,1),30)>18AND(COUNT(C>REF(C,1),3)=3))AND((COUNT("OBV.OBV">REF("OBV.OBV",1),30)>18)AND(COUNT("OBV.OBV">REF("OBV.OBV",1),3)=3))AND(COUNT(VOL>REF(VOL,1),30)>3AND(VOL/CAPITAL<=(10/100))),'OBV能量潮显示买盘逐渐加强属买入信号。'),COLORRED;
EXPLAIN((COUNT(C>REF(C,1),30)>18AND(COUNT(C>REF(C,1),3)=3))AND((COUNT("OBV.OBV"<REF("OBV.OBV",1),30)>18)OR(COUNT("OBV.OBV"<REF("OBV.OBV",1),3)=3)),'OBV能量潮显示买盘无力属卖出信号。'),COLORGREEN;
EXPLAIN(CROSS("OBV.OBV",0)AND(COUNT((REF("OBV.OBV",1)<0),3)=3),'OBV能量潮由负转正属买入信号。'),COLORRED;
EXPLAIN(CROSS(0,"OBV.OBV")AND(COUNT((REF("OBV.OBV",1)>0),3)=3),'OBV能量潮由正转负属卖出信号。'),COLORGREEN;
EXPLAIN((HHV(H,20)=H)AND(NOT(HHV("OBV.OBV",20)="OBV.OBV")),'OBV能量潮顶背离属卖出信号。')COLORGREEN;
EXPLAIN((LLV(L,20)=L)AND(NOT(LLV("OBV.OBV",20)="OBV.OBV")),'OBV能量潮底背离属买入信号。'),COLORRED;
EXPLAIN((ABS("OBV.OBV"-REF("OBV.OBV",1))/ABS(MA("OBV.OBV",5))>0.07)AND("OBV.OBV">REF("OBV.OBV",1)),'OBV能量潮异常。若股价在高位属卖出信号,若OBV能量线在低位长时间横向整理后出现,属买入信号。'),COLORFF00FF;
EXPLAIN("CR.CR"<40,'CR能量指标超卖,提示股价形成底部,属买入信号。'),COLORRED;
EXPLAIN("CR.CR"<=400AND"CR.CR">=300,'CR能量指标超买,属卖出信号。'),COLORGREEN;
EXPLAIN((LLV(L,20)=L)AND(NOT(LLV("CR.CR",20)="CR.CR")),'CR能量指标底背离,属买入信号。'),COLORRED;
EXPLAIN((HHV(H,20)=H)AND(NOT(HHV("CR.CR",20)="CR.CR")),'CR能量指标顶背离,属卖出信号。'),COLORGREEN;
EXPLAIN(((ABS("CR.MA1"-"CR.MA2")<5)AND(ABS("CR.MA1"-"CR.MA3")<5)AND(ABS("CR.MA2"-"CR.MA3")<5))OR(((ABS("CR.MA1"-"CR.CR")<5)AND(ABS("CR.MA1"-"CR.MA3")<5)AND(ABS("CR.CR"-"CR.MA3")<5))),'CR能量指标异常,一波或长或短的上升或下跌行情即将展开。'),COLORFF00FF;
EXPLAIN("PSY"<10,'PSY心理线指标低位超卖区,属买入信号。'),COLORRED;
EXPLAIN(BETWEEN("PSY","PSY">10,"PSY"<25),'PSY心理线指标超卖,属买入信号。'),COLORRED;
EXPLAIN("PSY">75,'PSY心理线指标超买,属卖出信号。'),COLORGREEN;
EXPLAIN(CROSS("ROC.ROC",0),'ROC变动速率指标向上突破,属买入信号。'),COLORRED;
EXPLAIN(CROSS(0,"ROC.ROC"),'ROC变动速率指标向下突破,属卖出信号。'),COLORGREEN;
EXPLAIN((LLV(L,20)=L)AND(NOT(COUNT("ROC.ROC"<REF("ROC.ROC",1),30)>18AND(COUNT("ROC.ROC"<REF("ROC.ROC",1),3)=3))),'ROC变动速率指标,显示下跌动力减弱,属买入信号。'),COLORRED;
EXPLAIN((HHV(H,20)=H)AND(NOT(COUNT("ROC.ROC">REF("ROC.ROC",1),30)>18AND(COUNT("ROC.ROC">REF("ROC.ROC",1),3)=3))),'ROC变动速率指标,显示上涨动力减弱,属卖出信号。'),COLORGREEN;
EXPLAIN((COUNT(C>REF(C,1),30)>18AND(COUNT(C>REF(C,1),3)=3))AND(COUNT("ROC.ROC">REF("ROC.ROC",1),30)>18AND(COUNT("ROC.ROC">REF("ROC.ROC",1),3)=3)),'ROC变动速率指标显示短期反弹有望,属买入信号。'),COLORRED;
EXPLAIN((COUNT(C<REF(C,1),30)>18AND(COUNT(C<REF(C,1),3)=3))AND(COUNT("ROC.ROC"<REF("ROC.ROC",1),30)>18AND(COUNT("ROC.ROC"<REF("ROC.ROC",1),3)=3)),'ROC变动速率指标显示短期警惕回落,属卖出信号。'),COLORGREEN;
EXPLAIN("VR"<20,'VR容量比率指标显示股价即将涨升,建议积极买入。'),COLORRED;
EXPLAIN("VR">400,'VR容量比率指标显示后续资金枯竭,股价将可能高位下跌,属卖出信号。'),COLORGREEN;
EXPLAIN((("VR"/REF("VR",1)>=2)OR("VR"/REF("VR",2)>=2))AND(COUNT(C<=REF(C,1),5)>=3),'VR容量比率指标异常,显示股价即将涨升,属买入信号。'),COLORRED;
EXPLAIN("VR">300AND(COUNT("VR"<REF("VR",1),5)>=3)AND(COUNT(C>REF(C,1),5)>=3),'VR容量比率指标显示涨势耗尽,建议卖出。'),COLORGREEN;
VV6:=(2*C+H+L)/4;
VV7:=LLV(L,27);
VV8:=HHV(H,27);
攀:=EMA((VV6-VV7)/(VV8-VV7)*100,13)-50;
金:=EMA(0.618*REF(攀,1)+0.382*攀,3);
起攀:=cross(攀,金) and c>o;
EXPLAIN(cross(攀,金) and c>o,'起攀指标发出起攀买入信号。'),COLORRED;
●极乐●了和
Lv.3
发表于 2005-5-23 21:06 复制 查看全部楼层
下边先举几个网上的例子:
第一种   买卖盘解量
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));//主动买卖盘
主动买盘:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主动卖盘:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2));
促进指数MFL:(HIGH-LOW)*1000000/VOL,LINETHICK0,COLORRED;//促进指数解盘
MFI:=(HIGH-LOW)*1000000/VOL;
绿灯:=MFI>=REF(MFI,1)AND VOL>=REF(VOL,1);
衰退:=MFI<=REF(MFI,1)AND VOL<=REF(VOL,1);
伪装:=MFI>=REF(MFI,1)AND VOL<=REF(VOL,1);
蛰伏:=MFI<=REF(MFI,1)AND VOL>=REF(VOL,1);
卖盘:=VOL-主动买盘;//买卖盘>60%以上信号
卖盘大:=(卖盘-主动买盘)/卖盘>0.6;
买盘大:=(主动买盘-卖盘)/主动买盘>0.6;
WJ:=(HIGH+LOW+CLOSE)/3;//买入卖出量
VD1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
VD2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-WJ);
VD3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
VD4:=IF(HIGH=LOW,1,WJ-MIN(CLOSE,OPEN));
VD5:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
VD6:=(VD1*VD5);
VD7:=(VD2*VD5);
VD8:=(VD3*VD5);
VD9:=(VD4*VD5);
买入量:=(VD9+VD8);
卖出量:=-(VD6+VD7);
卖量:=VOL-买入量;//买卖盘>60%以上信号
卖量大:=(卖量-买入量)/卖量>0.4;
买量大:=(买入量-卖量)/买入量>0.4;
EXPLAIN(1=1,'        【买卖盘解量】'),COLORYELLOW;
EXPLAIN(绿灯,'[绿灯]+实计交易量增加。+MFI促进指数增加。'),COLORRED;
EXPLAIN(衰退,'[衰退]-实计交易量减少。-MFI促进指数减少。'),COLORGREEN;
EXPLAIN(伪装,'[伪装]-实计交易量减少。+MFI促进指数增加。'),color009900;
EXPLAIN(蛰伏,'[蛰伏]+实计交易量增加。-MFI促进指数减少。'),COLORYELLOW;
EXPLAIN(卖盘大,'★主动卖盘大于主动买盘60%以上;'),color009900;
EXPLAIN(买盘大,'★主动买盘大于主动卖盘60%以上;'),COLORYELLOW;
EXPLAIN(卖量大,'☆卖出量大于买入量40%以上;'),color009900;
EXPLAIN(买量大,'☆买入量大于卖出量40%以上;'),COLORYELLOW;
EXPLAIN(1=1,'          【控盘情况】'),COLORYELLOW;
EXPLAINEX(1=1,'当日主动买卖盘(手)=',vol,2,0),COLORFFCCFF;
EXPLAINEX(1=1,'其中主动买盘(手)=',主动买盘,2,0),COLORFFCCFF;
EXPLAINEX(1=1,'        主动卖盘(手)=',主动卖盘,2,0),COLORFFCCFF;
EXPLAINEX(1=1,'当日买卖量(手)=',vol,2,0),COLORFFCCFF;
EXPLAINEX(1=1,'其中买入量(手)=',买入量,2,0),COLORFFCCFF;
EXPLAINEX(1=1,'        卖出量(手)=',卖出量,2,0),COLORFFCCFF;
您需要登录后才可以回帖 免费注册登录

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表