请老师把这个【黄金分割】指标去除时间限制

[通达信] 10219 1
设置
2677942 Lv.2

专栏

发表于 2016-4-25 15:13 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
请老师把这个【黄金分割】指标去除时间限制,
源码如下:



限时日:=1160429;
VAR1:=IF(DATE<=限时日 AND DATE>1160101,1,0);

MA20:MA(C,20),COLOR00FFFF;
JXX:=BARSLASTCOUNT(C<MA20);
JXX1:=BACKSET((JXX>=4)*JXX,JXX);
JXS:=BARSLASTCOUNT(C>MA20);
JXS1:=BACKSET((JXS>=4)*JXS,JXS);

KGC:=BARSLASTCOUNT(NOT(JXX1 OR JXS1));
JXL:=BARSLASTCOUNT(REF(JXX1>0,KGC));
JXH:=BARSLASTCOUNT(REF(JXS1>0,KGC));

XWZ:=FILTERX(LLV(L,JXL)=L,JXL);
SWZ:=FILTERX(HHV(H,JXH)=H,JXH);
{DRAWLINE(XWZ,L,SWZ,H,0),COLOR00FFFF;在高低点连斜线}

高:=REF(H,BARSLAST(SWZ));
低:=REF(L,BARSLAST(XWZ));{这种情况应对目前在20下方,如青松建化16-4-8};

BB:=BARSLAST(JXL=1);{上次JXL等于1距今天数}
顶点2:=REF(高,BARSLAST(JXL))*VAR1,COLORYELLOW;
低点2:=REF(低,BB)*VAR1,COLORYELLOW;{上次等于1对应的低价。或用AA:REF(低,BB);}   
               
H23:=((顶点2-低点2)*0.236+低点2)*VAR1;       H38:=((顶点2-低点2)*0.382+低点2)*VAR1;        H中:=((顶点2-低点2)*0.5+低点2)*VAR1;
H61:=((顶点2-低点2)*0.618+低点2)*VAR1;       H80:=((顶点2-低点2)*0.809+低点2)*VAR1;        H138:=((顶点2-低点2)*1.382+低点2)*VAR1;
H161:=((顶点2-低点2)*1.618+低点2)*VAR1;      H200:=((顶点2-低点2)*2+低点2)*VAR1;

顶点A:REFDATE(顶点2,DATE),COLORYELLOW;               低点A:REFDATE(低点2,DATE),COLORYELLOW;
%23.6:REFDATE(H23,DATE),COLORYELLOW,DOTLINE;        %38.2:REFDATE(H38,DATE),COLORYELLOW,DOTLINE;            
%50:REFDATE(H中,DATE),COLORYELLOW,DOTLINE;          %61.8:REFDATE(H61,DATE),COLORYELLOW;
%80.9:REFDATE(H80,DATE),COLORYELLOW,DOTLINE;        %138.2:REFDATE(H138,DATE),COLORYELLOW,DOTLINE;
%161.8:REFDATE(H161,DATE),COLORYELLOW;              %200:REFDATE(H200,DATE),COLORYELLOW;

DRAWTEXT(ISLASTBAR,顶点A,'顶点')*VAR1,COLORWHITE;         DRAWTEXT(ISLASTBAR,%23.6,'%23.6')*VAR1,COLORYELLOW;
DRAWTEXT(ISLASTBAR,%38.2,'%38.2')*VAR1,COLORMAGENTA;     DRAWTEXT(ISLASTBAR,%50,'%50'),COLORRED;
DRAWTEXT(ISLASTBAR,%61.8,'%61.8')*VAR1,COLORMAGENTA;     DRAWTEXT(ISLASTBAR,%80.9,'%80.9')*VAR1,COLORYELLOW;
DRAWTEXT(ISLASTBAR,低点A,'低点')*VAR1,COLORWHITE;          DRAWTEXT(ISLASTBAR,%138.2,'%138.2')*VAR1,COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%161.8,'%161.8')*VAR1,COLORMAGENTA;   DRAWTEXT(ISLASTBAR,%200,'%200')*VAR1,COLORMAGENTA;
来自 湖南省益阳市

举报

使用道具 扔鸡蛋 回复

2093013
Lv.4

专栏

发表于 2016-4-25 15:25 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 陕西省西安市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
优惠券
优惠券
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表