求老师帮写以下背离指标选股公式

[通达信] 8729 6
设置
1992406 Lv.2

专栏

发表于 2016-4-25 23:06 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
以下是公式,老师帮写出以下指标中出现的 (MACD底背离)(KDJ底背离)(RSI底背离)三个选股公式谢谢了,想上图不懂怎么上
K${I]C}%6LWUIS2}0SG{`L4.png



A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF"(12,26,9),A1+1)<"MACD.DIF"(12,26,9) AND CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9));
MACD底背离:=FILTER(B1>0,5);
STICKLINE(MACD底背离,0,0.75,3,0),COLORGREEN;
DRAWTEXT(MACD底背离,0.57,'MACD底背离'),COLORGREEN;
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
KDJ底背离:=FILTER(B2>0,5);
STICKLINE(KDJ底背离,0,1,3,0),COLORYELLOW;
DRAWTEXT(KDJ底背离,0.80,'KDJ底背离'),COLORYELLOW;
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
RSI底背离:=FILTER(B3>0,5);
STICKLINE(RSI底背离,0,0.5,3,0),COLORFFCC66;
DRAWTEXT(RSI底背离,0.25,'RSI底背离'),COLORFFCC66;
2,COLORRED;
C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9)),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF"(12,26,9),C1+1)>"MACD.DIF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9));
MACD顶背离:=FILTER(D1>0,5);
STICKLINE(MACD顶背离,2,1.25,3,0),COLOR0066FF;
DRAWTEXT(MACD顶背离,1.47,'MACD顶背离'),COLOR0066FF;
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
KDJ顶背离:=FILTER(D2>0,5);
STICKLINE(KDJ顶背离,2,1,3,0),COLORRED;
DRAWTEXT(KDJ顶背离,1.2,'KDJ顶背离'),COLORRED;
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
RSI顶背离:=FILTER(D3>0,5);
STICKLINE(RSI顶背离,2,1.5,3,0),COLORFF00FF;
DRAWTEXT(RSI顶背离,1.75,'RSI顶背离'),COLORFF00FF;
底背离:MACD底背离 OR KDJ底背离 OR RSI底背离;
顶背离:MACD顶背离 OR KDJ顶背离 OR RSI顶背离;


来自 广西南宁市

举报

使用道具 扔鸡蛋 回复

2775844
Lv.2

专栏

发表于 2016-5-19 15:16 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省肇庆市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2599054
Lv.3

专栏

发表于 2016-5-14 17:48 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西贺州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2599054
Lv.3

专栏

发表于 2016-5-14 17:47 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西贺州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2599054
Lv.3

专栏

发表于 2016-5-14 17:46 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西贺州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1992406
Lv.2

专栏

发表于 2016-4-27 12:46 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广西南宁市

举报

使用道具 点亮 支持 扔鸡蛋 回复

3565898
Lv.2

专栏

发表于 2016-4-26 03:56 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 阿尔及利亚

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
7楼
6楼
5楼
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表