发新话题

指标源码

A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
(趋势>80);
DRAWICON(CROSS(趋势,0),0,1);
((A09 > 0 AND (趋势<20 OR 趋势>REF(趋势,1)AND 趋势<50))),COLORFFFF00;
主力建仓区:0,LINETHICK0,COLORFFFF00;
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
STICKLINE(趋势<=13,0,20,5,0),COLORCC9900;
DRAWTEXT(FILTER(趋势<=13,15),30,'铁散备金'),COLORCC9900;
STICKLINE(趋势<=13 AND VAR4>13,0,50,5,0),COLOR0099FF;
VAR5:=FILTER((趋势<=13 AND VAR4>13),10);
DRAWTEXT(VAR5,60,'铁散买入'),COLOR0099FF;
STICKLINE(趋势>=90 AND VAR4,0,30,5,0),COLORGRAY;
VAR6:=FILTER((趋势>=90 AND VAR4),10);
DRAWTEXT(VAR6,40,'铁散清仓'),COLORGRAY;
VAR7:=LLV(LOW,30);
VAR8:=HHV(HIGH,30);
VAR9:=EMA((CLOSE-VAR7)/(VAR8-VAR7)*4,4)*25;
STICKLINE(VAR9>90,100,105,10,2),COLORRED;
VAR10:=(VAR9-LLV(VAR9,4))/(HHV(VAR9,4)-LLV(VAR9,4))*100;
DRAWTEXT(IF(CROSS(VAR9,VAR10) AND VAR9>87,95,0),88,'险'),COLOR00FF00,;
DRAWICON(CROSS(90,VAR9),95,9);
VAR11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
VAR12:=HHV(VAR11,30)*8;
金字塔:EMA(IF(LOW<=VAR7 AND 趋势<40,(VAR11+VAR12),0),3)/618,COLORRED,LINETHICK2;
STICKLINE(金字塔>0,0 ,金字塔*1.2,5,0 ),COLORRED;
VAR13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
VAR14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趋势线: 趋势,COLORFF0000;
VAR16:=MAX(EMA(VAR13,2)-EMA(VAR14,5),0)*200;
VAR17:=EMA(VAR16,5);
铁散波浪峰:VAR17,STICK,COLORFF00FF;
STICKLINE(VAR17<REF(VAR17,1),0,VAR17,1,0),COLOR00FF00;
VAR18:=MA(趋势线,8);
{WWW.88GS.COM}
IF(CROSS(VAR2,VAR18) AND VAR2<15,50,0),COLORRED;
DRAWTEXT(CROSS(趋势线,VAR2)AND 趋势线>REF(趋势线,1)AND 趋势线<50,50,'追涨'),COLORFF0000;
买入:IF(VAR5,60,0);
发消息 加好友
积分
3282 
理想币
1330 个 
彩币
5 个 
共享币
129 个 
注册时间
2015-10-18 

复制

引用:
原帖由 @醉女人 于 2016-6-6 16:17 发表
妞妞老师就是选出出现9号图标的股票    
你的源码呢?没有源码写不了的
发消息 加好友
积分
152735 
理想币
122056 个 
彩币
10604 个 
共享币
56667 个 
注册时间
2013-1-27 

复制

A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
(趋势>80);
DRAWICON(CROSS(趋势,0),0,1);
((A09 > 0 AND (趋势<20 OR 趋势>REF(趋势,1)AND 趋势<50))),COLORFFFF00;
主力建仓区:0,LINETHICK0,COLORFFFF00;
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
STICKLINE(趋势<=13,0,20,5,0),COLORCC9900;
DRAWTEXT(FILTER(趋势<=13,15),30,'铁散备金'),COLORCC9900;
STICKLINE(趋势<=13 AND VAR4>13,0,50,5,0),COLOR0099FF;
VAR5:=FILTER((趋势<=13 AND VAR4>13),10);
DRAWTEXT(VAR5,60,'铁散买入'),COLOR0099FF;
STICKLINE(趋势>=90 AND VAR4,0,30,5,0),COLORGRAY;
VAR6:=FILTER((趋势>=90 AND VAR4),10);
DRAWTEXT(VAR6,40,'铁散清仓'),COLORGRAY;
VAR7:=LLV(LOW,30);
VAR8:=HHV(HIGH,30);
VAR9:=EMA((CLOSE-VAR7)/(VAR8-VAR7)*4,4)*25;
STICKLINE(VAR9>90,100,105,10,2),COLORRED;
VAR10:=(VAR9-LLV(VAR9,4))/(HHV(VAR9,4)-LLV(VAR9,4))*100;
DRAWTEXT(IF(CROSS(VAR9,VAR10) AND VAR9>87,95,0),88,'险'),COLOR00FF00,;
DRAWICON(CROSS(90,VAR9),95,9);
VAR11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
VAR12:=HHV(VAR11,30)*8;
金字塔:EMA(IF(LOW<=VAR7 AND 趋势<40,(VAR11+VAR12),0),3)/618,COLORRED,LINETHICK2;
STICKLINE(金字塔>0,0 ,金字塔*1.2,5,0 ),COLORRED;
VAR13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
VAR14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趋势线: 趋势,COLORFF0000;
VAR16:=MAX(EMA(VAR13,2)-EMA(VAR14,5),0)*200;
VAR17:=EMA(VAR16,5);
铁散波浪峰:VAR17,STICK,COLORFF00FF;
STICKLINE(VAR17<REF(VAR17,1),0,VAR17,1,0),COLOR00FF00;
VAR18:=MA(趋势线,8);
{WWW.88GS.COM}
IF(CROSS(VAR2,VAR18) AND VAR2<15,50,0),COLORRED;
DRAWTEXT(CROSS(趋势线,VAR2)AND 趋势线>REF(趋势线,1)AND 趋势线<50,50,'追涨'),COLORFF0000;
买入:IF(VAR5,60,0);
发消息 加好友
积分
3282 
理想币
1330 个 
彩币
5 个 
共享币
129 个 
注册时间
2015-10-18 

复制

A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
(趋势>80);
DRAWICON(CROSS(趋势,0),0,1);
((A09 > 0 AND (趋势<20 OR 趋势>REF(趋势,1)AND 趋势<50))),COLORFFFF00;
主力建仓区:0,LINETHICK0,COLORFFFF00;
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
STICKLINE(趋势<=13,0,20,5,0),COLORCC9900;
DRAWTEXT(FILTER(趋势<=13,15),30,'铁散备金'),COLORCC9900;
STICKLINE(趋势<=13 AND VAR4>13,0,50,5,0),COLOR0099FF;
VAR5:=FILTER((趋势<=13 AND VAR4>13),10);
DRAWTEXT(VAR5,60,'铁散买入'),COLOR0099FF;
STICKLINE(趋势>=90 AND VAR4,0,30,5,0),COLORGRAY;
VAR6:=FILTER((趋势>=90 AND VAR4),10);
DRAWTEXT(VAR6,40,'铁散清仓'),COLORGRAY;
VAR7:=LLV(LOW,30);
VAR8:=HHV(HIGH,30);
VAR9:=EMA((CLOSE-VAR7)/(VAR8-VAR7)*4,4)*25;
STICKLINE(VAR9>90,100,105,10,2),COLORRED;
VAR10:=(VAR9-LLV(VAR9,4))/(HHV(VAR9,4)-LLV(VAR9,4))*100;
DRAWTEXT(IF(CROSS(VAR9,VAR10) AND VAR9>87,95,0),88,'险'),COLOR00FF00,;
DRAWICON(CROSS(90,VAR9),95,9);
VAR11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
VAR12:=HHV(VAR11,30)*8;
金字塔:EMA(IF(LOW<=VAR7 AND 趋势<40,(VAR11+VAR12),0),3)/618,COLORRED,LINETHICK2;
STICKLINE(金字塔>0,0 ,金字塔*1.2,5,0 ),COLORRED;
VAR13:=(MA(C,1)+MA(C,3)+MA(C,5)+MA(C,7)+MA(C,9))/5;
VAR14:=(MA(C,2)+MA(C,4)+MA(C,6)+MA(C,8)+MA(C,10))/5;
趋势线: 趋势,COLORFF0000;
VAR16:=MAX(EMA(VAR13,2)-EMA(VAR14,5),0)*200;
VAR17:=EMA(VAR16,5);
铁散波浪峰:VAR17,STICK,COLORFF00FF;
STICKLINE(VAR17<REF(VAR17,1),0,VAR17,1,0),COLOR00FF00;
VAR18:=MA(趋势线,8);
{WWW.88GS.COM}
IF(CROSS(VAR2,VAR18) AND VAR2<15,50,0),COLORRED;
DRAWTEXT(CROSS(趋势线,VAR2)AND 趋势线>REF(趋势线,1)AND 趋势线<50,50,'追涨'),COLORFF0000;
买入:IF(VAR5,60,0);
发消息 加好友
积分
3282 
理想币
1330 个 
彩币
5 个 
共享币
129 个 
注册时间
2015-10-18 

复制

A01:=DYNAINFO(7);
A03:=BARSCOUNT(CLOSE);
A04:=(SMA((CLOSE / HHV(HIGH,120)),3,1) * 100);
A05:=IF((A03 > 20),A04,0);
A06:=IF((LOW > A01),0,IF((HIGH < A01),1,(((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))));
A07:=DMA(A06,(VOL / CAPITAL)) * 60;
A09:=IF((((A07 > 0) AND (A07 > REF(A07,1))) AND (A05 <= 88)),A07,0);
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VAR3,3)-10;
(趋势>80);
DRAWICON(CROSS(趋势,0),0,1);
((A09 > 0 AND (趋势<20 OR 趋势>REF(趋势,1)AND 趋势<50))),COLORFFFF00;
主力建仓区:0,LINETHICK0,COLORFFFF00;
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
STICKLINE(趋势<=13,0,20,5,0),COLORCC9900;
DRAWTEXT(FILTER(趋势<=13,15),30,'铁散备金'),COLORCC9900;
STICKLINE(趋势<=13 AND VAR4>13,0,50,5,0),COLOR0099FF;
VAR5:=FILTER((趋势<=13 AND VAR4>13),10);
DRAWTEXT(VAR5,60,'铁散买入'),COLOR0099FF;
STICKLINE(趋势>=90 AND VAR4,0,30,5,0),COLORGRAY;
VAR6:=FILTER((趋势>=90 AND VAR4),10);
DRAWTEXT(VAR6,40,'铁散清仓'),COLORGRAY;
发消息 加好友
积分
3282 
理想币
1330 个 
彩币
5 个 
共享币
129 个 
注册时间
2015-10-18 

复制

怎么这样呀
发消息 加好友
积分
3282 
理想币
1330 个 
彩币
5 个 
共享币
129 个 
注册时间
2015-10-18 

复制

妞妞老师:出现红空心块或9号图标都保留。
附件: 您所在的用户组无法下载或查看附件,请先登陆。如果您还不是本站会员,请先进行注册,然后才能下载或查看。
发消息 加好友
积分
3282 
理想币
1330 个 
彩币
5 个 
共享币
129 个 
注册时间
2015-10-18 

复制

引用:
原帖由 @醉女人 于 2016-6-6 16:17 发表
妞妞老师就是选出出现9号图标的股票    
VAR7:=LLV(LOW,30);
VAR8:=HHV(HIGH,30);
VAR9:=EMA((CLOSE-VAR7)/(VAR8-VAR7)*4,4)*25;
DRAWICON(CROSS(90,VAR9),95,9);
发消息 加好友
积分
152735 
理想币
122056 个 
彩币
10604 个 
共享币
56667 个 
注册时间
2013-1-27 

复制

就这类都要保留
附件: 您所在的用户组无法下载或查看附件,请先登陆。如果您还不是本站会员,请先进行注册,然后才能下载或查看。
发消息 加好友
积分
3282 
理想币
1330 个 
彩币
5 个 
共享币
129 个 
注册时间
2015-10-18 

复制

妞妞老师能否红方块和9号图标都保留,这样公式可以做吗?
发消息 加好友
积分
3282 
理想币
1330 个 
彩币
5 个 
共享币
129 个 
注册时间
2015-10-18 

复制

有这样的类型
附件: 您所在的用户组无法下载或查看附件,请先登陆。如果您还不是本站会员,请先进行注册,然后才能下载或查看。
发消息 加好友
积分
3282 
理想币
1330 个 
彩币
5 个 
共享币
129 个 
注册时间
2015-10-18 

复制

红块出现了,但9号图标没出现
发消息 加好友
积分
3282 
理想币
1330 个 
彩币
5 个 
共享币
129 个 
注册时间
2015-10-18 

复制

谢谢妞妞大师
发消息 加好友
积分
3282 
理想币
1330 个 
彩币
5 个 
共享币
129 个 
注册时间
2015-10-18 

复制

附件: 您所在的用户组无法下载或查看附件,请先登陆。如果您还不是本站会员,请先进行注册,然后才能下载或查看。
发消息 加好友
积分
152735 
理想币
122056 个 
彩币
10604 个 
共享币
56667 个 
注册时间
2013-1-27 

复制

老会员使用

藏金阁订阅免责条款 藏金阁

百宝箱
  • 藏金阁:百宝箱
  • 标题:老会员优惠限一人
  • 金钻:180颗
  • 最大订阅:1人 (订阅人数超过该值后将自动过期,终止订阅)
  • 发布日期: 2016-06-10
  • 订阅有效期: 2016-06-10 (已过期)
  • 描述:感谢老会员
  • 已到期,不公开显示
藏金阁
发消息 加好友
积分
152735 
理想币
122056 个 
彩币
10604 个 
共享币
56667 个 
注册时间
2013-1-27 

复制

老师麻烦你帮我写一下这个刚贴上的条件选股公式,好吗?

http://55188.com/viewthread.php? ... %3D38&frombbs=1
发消息 加好友
积分
9269 
理想币
2101 个 
彩币
0 个 
共享币
1088 个 
注册时间
2010-4-30 

复制

引用:
原帖由 @胜利油田8 于 2016-6-14 21:20 发表
老师麻烦你帮我写一下这个刚贴上的条件选股公式,好吗?

http://55188.com/viewthread.php? ... %3D38&frombbs=1    
T:=BARSLAST(L>REF(H,1));
XG:T<20 AND L>REF(H,T+1) AND L=LLV(L,T+1) AND L<REF(H,T+1)+0.03 AND T>0;
发消息 加好友
积分
152735 
理想币
122056 个 
彩币
10604 个 
共享币
56667 个 
注册时间
2013-1-27 

复制

感谢老师的帮助。。。。。。。。。。。
发消息 加好友
积分
9269 
理想币
2101 个 
彩币
0 个 
共享币
1088 个 
注册时间
2010-4-30 

复制

附件: 您所在的用户组无法下载或查看附件,请先登陆。如果您还不是本站会员,请先进行注册,然后才能下载或查看。
发消息 加好友
积分
152735 
理想币
122056 个 
彩币
10604 个 
共享币
56667 个 
注册时间
2013-1-27 

复制

后一页【ctrl+“→”】 【ctrl+“←”】前一页 还有15页内容,点此下一页
发新话题
理想论坛 » 金钻指标共享交流区 » 指标(42)主图幅图选股源码通达信
金钻指标共享交流区积分规则

快速回复主题

选项

发帖请务遵守本站的相关规则,所有发表(包括转发)政治、色情非法信息者本站将实时提供发贴者个人信息给公安局,追究责任,特此申明!
具体规则请参见 理想论坛会员守则》 《净化论坛环境,打击恶意灌水》。

您需要登录后才可以发帖

[完成后可按 Ctrl+Enter 发布]

理想论坛上的网友发表的帖子纯属个人意见,理想论坛不负任何责任!广告赞助商内容与本站无关!免责声明
理想论坛值班电话[9:30~18:30]: ☎ 400 016 5518-1 ☎ 186 4906 9487(广告)187 1028 6081(广告)
找回密码 软件区:1006648222 百宝箱: 1006267111 广告: 1006269111 广告: 3145821447
诚信档案编号:CX20150604010215010383 信誉编号:TL852015042710940
工业和信息化部信息备案: 京ICP备15035364号 京ICP证151057号
关闭底部 打开底部 回顶部 到页底 理想论坛微信号:lixiang55188 扫描下载理想选股App
关闭
关闭