文华财经自定义的分形指标 日线显示OK其他周期都偏离了,请帮忙看看,谢谢!

[其 他] 7365 1
设置
3024000 Lv.0

专栏

发表于 2016-7-9 11:56 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
定义的分形指标 日线显示OK,其他周期都偏离了,请帮忙看看问题出在哪里,谢谢!
Y:=(H+L)/2;
R1:=REF(SMA(Y,8,1),5);
A:=H;  
A1:=REF(H,1);
A2:=REF(H,2);
A3:=REF(H,3);
A4:=REF(H,4);
A5:=REF(H,5);
A6:=REF(H,6);
A7:=REF(H,7);
A8:=REF(H,8);
B:=L;  
B1:=REF(L,1);
B2:=REF(L,2);
B3:=REF(L,3);
B4:=REF(L,4);
B5:=REF(L,5);
B6:=REF(L,6);
B7:=REF(L,7);
B8:=REF(L,8);
FF1:=A2>A1 AND A2>A AND A2>A3 AND A2>A4;
FF2:=A3=A2 AND A2>A1 AND A2>A AND A2>A4 AND A2>A5;
FF3:=A4=A3 AND A3=A2 AND A2>A1 AND A2>A AND A2>A5 AND A2>A6;
FF4:=A2=A4 AND A2>A1 AND A2>A AND A2>A3 AND A2>A5 AND A2>A6;
FF44:=A2=A3 AND A2=A4 AND A2=A5 AND A2>A1 AND A2>A AND A2>A6 AND A2>A7;
FF5:=A6=A4 AND A4=A2 AND A2>A1 AND A2>A AND A2>A7 AND A2>A8 AND A2>A3 AND A2>A5;
FF6:=B2<B1 AND B2<B AND B2<B3 AND B2<B4;
FF7:=B3=B2 AND B2<B1 AND B2<B AND B2<B4 AND B2<B5;
FF8:=B2=B3 AND B4=B2 AND B2<B1 AND B2<B AND B2<B5 AND B2<B6;
FF9:=B2=B4 AND B2<B1 AND B2<B AND B2<B3 AND B2<B5 AND B2<B6;
FF99:=B2=B3 AND B2=B4 AND B2=B5 AND B2<B1 AND B2<B AND B2<B6 AND B2<B7;
FF10:=B2=B4 AND B2=B6 AND B2<B1 AND B2<B AND B2<B3 AND B2<B5 AND B2<B7 AND B2<B8;
FF11:=FF1 OR FF2 OR FF3 OR FF4 OR FF44 OR FF5;
FF12:=FF6 OR FF7 OR FF8 OR FF9 OR FF99 OR FF10;
FF13:=BACKSET(FF11,3);
FF133:=FILTER(FF13,2);
FF14:=BACKSET(FF12,3);
FF144:=FILTER(FF14,2);
SF:=IF(FF11,A2,REF(A2,BARSLAST(FF11)));
XF:=IF(FF12,B2,REF(B2,BARSLAST(FF12)));
KTEXT(FF133 AND H>R1,0,1.012*H,2,COLORLIGHTGREY,'∧'),ALIGN1,VALIGN0,FONTSIZE10;  
KTEXT(FF144 AND L<R1,0,0.992*L,1,COLORLIGHTGREY,'∨'),ALIGN1,VALIGN0,FONTSIZE10;
KTEXT(FF133 AND H<R1,0,1.012*H,2,COLORLIGHTGREY,'∧'),ALIGN1,VALIGN0,FONTSIZE10;  
KTEXT(FF144 AND L>R1,0,0.992*L,1,COLORLIGHTGREY,'∨'),ALIGN1,VALIGN0,FONTSIZE10;
http://C:\\Users\\Administrator.SDWM-20130504HE\\Desktop\\日线分形.jpg
http://C:\\Users\\Administrator.SDWM-20130504HE\\Desktop\\5分钟分形.jpg
来自 湖南省

举报

使用道具 扔鸡蛋 回复

3024000
Lv.0

专栏

发表于 2016-7-9 11:57 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖南省

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表