请老师帮忙写个机买预警公式,谢谢

[通达信] 2397 2
设置
3590509 Lv.2

专栏

发表于 2016-7-9 13:55 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
请老师帮忙写个预警公式,条件是:1.机构买/机构卖>1.2或者只有机构买,2.涨幅不超过4%且出现机买时预警,谢谢




A1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE<REF(CLOSE,1),-
VOL/CAPITAL*100,0)),0);
成交额:=V*C/100,NODRAW;{万元}
A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A4:=SUM((IF(((成交额/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A5:=SUM((IF(((成交额/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((ISLASTBAR),((100*A2)/A6),0);
A8:=IF((ISLASTBAR),((100*A3)/A6),0);
A9:=IF((ISLASTBAR),((100*A4)/A6),0);
A10:=IF((ISLASTBAR),((100*A5)/A6),0);
增减仓%:A1;
机构买:(A2),LINETHICK6,COLORRED;
机构卖:(A3),LINETHICK6,COLORFFFF55;
机构进出:机构买-机构卖,NODRAW;
散户买:(A4),COLOR5555FF;{细红线}
散户卖:(A5),COLOR55FF55;{细绿线}
强势:((100*A2)/A6>50);
STICKLINE(强势,机构买*1.02,机构买*1.1,1,0),COLORYELLOW;
拉升:((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18;
STICKLINE(拉升,机构买*1.1,机构买*1.2,1,0),COLORFF00FF;
DRAWTEXT(ISLASTBAR=1,机构买*0.95,'●机构买'),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR=1,机构卖*0.95,'○机构卖'),LINETHICK2,COLORFFFF55;
DRAWTEXT(机构进出>0 AND REF(机构进出,1)<=0,机构买*1.02,'●机买'),COLORRED;
DRAWTEXT(机构进出<0 AND REF(机构进出,1)>=0,机构买*0.98,'○机卖'),COLORFFFF55;

DD1:=1;
AAA1:=STRCAT(STRCAT('机构买',CON2STR((100*A2)/A6,0)),'%%');
AAA2:=STRCAT(STRCAT('机构卖',CON2STR((100*A3)/A6,0)),'%%');
AAA3:=STRCAT(STRCAT('散户买',CON2STR((100*A4)/A6,0)),'%%');
AAA4:=STRCAT(STRCAT('散户卖',CON2STR((100*A5)/A6,0)),'%%');
DRAWTEXT_FIX(DD1=1,0,0.02,0,AAA1),COLORRED;
DRAWTEXT_FIX(DD1=1,0,0.13,0,AAA2),COLORFFFF55;
DRAWTEXT_FIX(DD1=1,0,0.24,0,AAA3),COLOR5555FF;
DRAWTEXT_FIX(DD1=1,0,0.35,0,AAA4),COLOR55FF55;
来自 浙江省台州市

举报

使用道具 扔鸡蛋 回复

3590509
Lv.2

专栏

发表于 2016-7-11 08:37 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 浙江省台州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2900049
Lv.4

专栏

发表于 2016-7-9 23:58 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省深圳市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表