请老师帮忙编个(红柱)选股公式(已解决)

[通达信] 3306 3
设置
3538875 Lv.3

专栏

发表于 2016-9-6 20:45 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
副图指标中出现红柱时的选股公式,谢谢


日线锁定:=IFF(PERIOD>=4,1,DRAWNULL);
方向成交量:=IFF(CLOSE>=OPEN,VOL,VOL*(-1));
LHLNMID:=(3*CLOSE+OPEN+HIGH+LOW)/6;
LHLN短线:=WMA(LHLNMID,5);
LHLN中线:=WMA(LHLNMID,10);
LHLN多头:=LHLN短线>LHLN中线;

P01:=SUM(方向成交量,1)>0;
P02:=SUM(方向成交量,2)>0;
P03:=SUM(方向成交量,3)>0;
P04:=SUM(方向成交量,4)>0;
P05:=SUM(方向成交量,5)>0;

SUM11:=SUM(方向成交量,11);
SUM12:=SUM(方向成交量,12);
SUM13:=SUM(方向成交量,13);
SUM14:=SUM(方向成交量,14);
SUM15:=SUM(方向成交量,15);
SUM16:=SUM(方向成交量,16);
SUM17:=SUM(方向成交量,17);
SUM18:=SUM(方向成交量,18);
SUM19:=SUM(方向成交量,19);
SUM20:=SUM(方向成交量,20);

P11:=SUM11>0 AND SUM11>REF(SUM11,1);
P12:=SUM12>0 AND SUM12>REF(SUM12,1);
P13:=SUM13>0 AND SUM13>REF(SUM13,1);
P14:=SUM14>0 AND SUM14>REF(SUM14,1);
P15:=SUM15>0 AND SUM15>REF(SUM15,1);
P16:=SUM16>0 AND SUM16>REF(SUM16,1);
P17:=SUM17>0 AND SUM17>REF(SUM17,1);
P18:=SUM18>0 AND SUM18>REF(SUM18,1);
P19:=SUM19>0 AND SUM19>REF(SUM19,1);
P20:=SUM20>0 AND SUM20>REF(SUM20,1);

MAZJ05:=MA(方向成交量,5);
MAZJ10:=MA(方向成交量,10);
MAZJ15:=MA(方向成交量,15);
MAZJ20:=MA(方向成交量,20);
MA01:=MAZJ05>MAZJ10;
MA02:=MAZJ05>MAZJ15;
MA03:=MAZJ05>MAZJ20;
MA04:=MAZJ10>MAZJ15;
MA05:=MAZJ10>MAZJ20;
MA06:=MAZJ15>MAZJ20;

基准线1:=EMA(EMA(EMA(EMA(IFF(方向成交量>=0,方向成交量,0),20),2),2),2);
基准线6:=基准线1*6;
ZJDL10:=IFF(方向成交量>基准线6,10,IFF(方向成交量<=基准线6 AND 方向成交量>0,10*方向成交量/基准线6,0));


{长中短线}
短线总量:=SUM(方向成交量,3);
短线总量10:=EMA(短线总量,10);
短线总量60:=EMA(短线总量,60);
短线总量20:=EMA(短线总量,20);
短线总量30:=EMA(短线总量,30);
CZD01:=短线总量>短线总量10;
CZD02:=短线总量20>短线总量30;
CZD03:=短线总量10>短线总量60;
{长中短线}

总权:=53;
量化量能X:=IFF(日线锁定 AND C>0,EMA(EMA(100*(P01*2+P02*2+P03*5+P04*2+P05*2+P11*1+P12*1+P13*1+P14*1+P15*1+P16*1+P17*1+P18*1+P19*1+P20*1+
MA01*2+MA02*2+MA03*1+MA04*1+MA05*1+MA06*1+ZJDL10+CZD01*5+CZD02*4+CZD03*3)/总权,2),2),DRAWNULL),NODRAW,COLORRED;
量化量能XX:=IFF(LHLN多头,量化量能X*1.2,量化量能X);
量化量能:WMA(IFF(量化量能XX>=100,100,量化量能XX),3),NODRAW,COLORRED;

▲35线:IFF(日线锁定,35,DRAWNULL),COLORGREEN;
▲50线:IFF(日线锁定,50,DRAWNULL),COLORYELLOW;
▲80线:IFF(日线锁定,80,DRAWNULL),COLORWHITE;


{3D柱线形式}
STICKLINE(量化量能>=REF(量化量能,1),0,量化量能,2,0),COLORRED;
STICKLINE(量化量能<REF(量化量能,1),0,量化量能,2,0),COLORFFFF00;

[ 本帖最后由 福阿德 于 2016-9-6 21:35 编辑 ]
来自 江苏省南通市

举报

使用道具 扔鸡蛋 回复

2080049
Lv.3

专栏

发表于 2016-9-6 21:10 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江西省萍乡市

举报

使用道具 点亮 支持 扔鸡蛋 回复

3538875
Lv.3

专栏

发表于 2016-9-6 20:58 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省南通市

举报

使用道具 点亮 支持 扔鸡蛋 回复

612112
Lv.2

专栏

发表于 2016-9-6 20:53 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 河北省邯郸市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
4楼
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表