老师辛苦改一个MAC D公式(已解答:熊市新手2008)

[通达信] 3703 1
设置
3505209 Lv.1

专栏

发表于 2016-12-1 21:24 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
要求MACD的坐标改为百分比,再加上+2%和-2%线。

{参数:SHORT(2,200,12);LONG(2,200,26);MID(2,200,9);M(2,100,3)}


WXS:=(LONG-SHORT)/2;{系数}
JGL_DF:=WXS*(EMA(CLOSE,SHORT)-REF(EMA(CLOSE,SHORT),1));{微分}
DIF_J:EMA(JGL_DF,LONG),COLOR1234AA,LINETHICK2;{积分}
DEA_G:EMA(DIF_J,MID),COLOR338833,LINETHICK2;{平滑}
MACD_L:(DIF_J-DEA_G)*2,COLORA9A813,COLORSTICK;
K_DF:SMA(JGL_DF,M,1)*1,COLORFEDCBA;{以下为“类KDJ”}
D_DF:SMA(K_DF,M,1),COLOR13F8F9;
J_DF:3*K_DF-2*D_DF,COLORF813F9;
{以下显示“J_DF前差值柱”,柱子太薄时显示“十”字星}
RF:=REF(J_DF,1);
DJ:=ABS(J_DF-RF);
MM:=(HHV(DJ,240)+LLV(DJ,240))/2;
STICKLINE(J_DF>RF,J_DF,RF,2.3,0),COLOR1388D3;
STICKLINE(J_DF>RF,J_DF,RF,1.0,0),COLOR13AAD3;
STICKLINE(J_DF<RF,J_DF,RF,2.3,0),COLOR338833;
STICKLINE(J_DF<RF,J_DF,RF,1.0,0),COLOR33AA33;
STICKLINE(J_DF<RF AND DJ<0.2*MM,J_DF-0.1*MM,RF+0.1*MM,0.1,0),COLOR33AA33;
STICKLINE(J_DF>=RF AND DJ<0.2*MM,J_DF+0.1*MM,RF-0.1*MM,0.1,0),COLOR13AADD;

[ 本帖最后由 任刚 于 2016-12-2 20:07 编辑 ]
来自 浙江省绍兴市

举报

使用道具 扔鸡蛋 回复

1415848
Lv.4

专栏

发表于 2016-12-1 23:17 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表