烦将关注两个指标合成一个选股指标谢谢!

[通达信] 2523 2
设置
1371086 Lv.3

专栏

发表于 2017-2-20 21:32 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
第一个指标已整合

R1:=MA(CLOSE,1);R2:=MA(CLOSE,3);R3:=(MA(R2,1)*1);R4:=(MA(R2,3)*1);
进:=CROSS(R3,R4);
BBB1:=MA(C,1);B2:=SMA(SMA(SMA(BBB1,2,1),2,1),2,1);
SMA2:=MA(B2,2);
VARB1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
买:=CROSS(VARB1,VAR3) AND B2>SMA2;
Y:=进  AND 买;


N1:=3;N2:=5;N3:=9;N4:=13;N5:=21;N6:=34;
DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);
DEA:=EMA(DIFF,N2);
A1:=DIFF>DEA;
RSV1:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
K:=SMA(RSV1,N1,1);
D:=SMA(K,N1,1);
A2S:=K>D;
LCS:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LCS,0),N2,1))/(SMA(ABS(CLOSE-LCS),N2,1))*100;
RSI2:=(SMA(MAX(CLOSE-LCS,0),N4,1))/(SMA(ABS(CLOSE-LCS),N4,1))*100;
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;
LWR1:=SMA(RSV,N1,1);
LWR2:=SMA(LWR1,N1,1);
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);
MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);
A6:=MMS>MMM;
BIAS:=(C-MA(C,N2))/MA(C,N2);
DIF:=(BIAS-REF(BIAS,16));
DBCD:=SMA(DIF,76,1);
MM:=MA(DBCD,5);
A7:=DBCD>MM;
持股:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
下跌:=MA(持股,12);
A8:=持股>下跌;
MT:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MT,N3),N3)/EMA(EMA(ABS(MT),N3),N3);
MAZL:=MA(ZLGJ,5);
A9:=ZLGJ>MAZL;
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2));
HSL:=(XVL/20)/1.15;
GJLL:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
LLJX:=EMA(GJLL,3);
ZJL:=LLJX;
A10:=ZJL>0;
JCS:=(A1+A2S+A3+A4+A5+A6+A7+A8+A9+A10);
PP:=IF(JCS>5,1,0);
金牛:=IF((CROSS(PP,0.99)),13,0);
Y2:=IF(金牛,1,0);
{第三指标}
X:=(3*C+L+O+H)/6;
多空线:=(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210;
Y3:=CROSS(C,多空线);
XG:Y AND Y2 AND Y3;

第二个是此指标中出现“关注”
P1  0  600  7
P2  0  600  21
P3  0  600  250

MA1:EMA(CLOSE,P1);
MA2:EMA(CLOSE,P2);
MA3:EMA(CLOSE,P3);
工作线: EMA(CLOSE,P1),COLORWHITE,LINETHICK3;
神秘线: EMA(CLOSE,P2),COLORRED,LINETHICK3;
生命线: EMA(CLOSE,P3),COLORWHITE,LINETHICK2;
DRAWTEXT(CROSS(工作线,神秘线),工作线,'★建仓') ,COLORYELLOW;
DRAWTEXT(CROSS(神秘线,工作线),神秘线,'★空仓') ,COLORFFCC00;
LC:=REF(CLOSE,3);
JH:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(FILTER(CROSS(JH,30),55),LOW*0.98,'↑关注'),COLORYELLOW,LINETHICK1;
DRAWTEXT(FILTER(CROSS(84,JH),22),HIGH*1.02,'↓小心'),COLOR00FF00;

请将第一个与第二个中的关注合成一个选股指标,谢谢
来自 湖南省长沙市

举报

使用道具 扔鸡蛋 回复

1371086
Lv.3

专栏

发表于 2017-2-21 08:21 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖南省长沙市

举报

使用道具 支持 扔鸡蛋 回复

3553380
Lv.5

专栏

发表于 2017-2-20 21:55 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 安徽省芜湖市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
3楼
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表