手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
RSS
  • 搜帖子

{大赛排名第一选股公式作者:公式帮手}谁能做个选股(已解答:深山水寒)

[通达信]
设置
35211 58 士123我 Lv.2 发表于 · 2017-4-8 10:19 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
[local]1[/local]{大赛排名第一选股公式作者:公式帮手}

BIAS0:= (C-MA(C,2))/MA(C,2)*100;
HXL:=V/CAPITAL*100;
D1:=INDEXC;
D2:=MA(D1,13);
DR2:=D2>1.050*D1;
E1:=(C-HHV(C,12))/HHV(C,12)*10;
E2:=(C-REF(C,26))/REF(C,26)*10;
E3:=MA(C,3);
SJ1:=DR2;
SJ2:=E2<-2.30;
SJ3:=BIAS0<-2.7;
SJ5:=SJ1 AND SJ2 AND SJ3;
SJ6:=CROSS(0.5,SJ5);
JS1:=CROSS(SJ6,0.5);JS2:=BARSLAST(JS1=1);
JS3:=JS2<=5 AND C<REF(C,JS2);
大赛排名第一:SJ6 OR JS3,NODRAW;
STICKLINE(大赛排名第一,4,0,4,1),COLORMAGENTA,LINETHICK1;
{BFBZ (20天10%利润,成功率98.52%信号量2209) }
VAR1:=INDEXC;
VAR2:=MA(VAR1,6);
VAR3:=MA(VAR1,24);
VAR4:=MA(VAR1,32);
VAR5:=MA(VAR1,62);
VAR6:=MA(VAR1,105);
VAR7:=VAR5<REF(VAR5,1) AND VAR6<REF(VAR6,1) AND VAR5<VAR6*0.98;
VAR8:=VAR4>VAR2*1.11 AND VAR3>VAR2*1.095;
VAR9:=VAR2>VAR1*0.95;
BFBZ:VAR7 AND VAR8 AND VAR9 AND CLOSE/COST(8)<=0.8
AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(CLOSE,1)>REF(OPEN,1)
OR REF(CLOSE,1)<REF(OPEN,1)),NODRAW,COLORYELLOW;
STICKLINE(BFBZ,1,0,3,0),COLORYELLOW,LINETHICK1;
{飞鹰优化 (90.87%缺省周期:日线}
飞鹰VAR1:=CLOSE/MA(CLOSE,40)*100<78;
飞鹰VAR2:=CLOSE/MA(CLOSE,60)*100<74;
飞鹰VAR3:=HIGH>LOW*1.051;
飞鹰VAR4:=飞鹰VAR3 AND COUNT(飞鹰VAR3,5)>1;
飞鹰TYP:=(HIGH+LOW+CLOSE)/3;
飞鹰CCI:=(飞鹰TYP-MA(飞鹰TYP,14))/(0.015*AVEDEV(飞鹰TYP,14));
飞鹰优化:飞鹰VAR4 AND (飞鹰VAR1 OR 飞鹰VAR2) AND
MA(C,27)/CLOSE>1.169 AND MA(C,17)/CLOSE>1.158 AND
CLOSE<MA(C,120) AND MA(C,60)<MA(C,120) AND MA(C,60)>MA(C,30) AND 飞鹰CCI>-210,NODRAW,COLORBROWN;
STICKLINE(飞鹰优化,2,1,3,0),COLORBROWN,LINETHICK1;
{BIMOWANG (成功率93.12 信号3736 缺省周期:日线}
BIMOWANGVAR1:=EMA(WINNER(CLOSE)*70,3);
BIMOWANGVAR2:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
BIMOWANGVAR3:=CLOSE/MA(CLOSE,40)*100<76;
BIMOWANGVAR4:=CLOSE/MA(CLOSE,60)*100<74;
BIMOWANGVAR5:=HIGH>LOW*1.051;
BIMOWANGVAR6:=BIMOWANGVAR5 AND COUNT(BIMOWANGVAR5,5)>1;
BIMOWANG:BIMOWANGVAR6 AND (BIMOWANGVAR3 OR BIMOWANGVAR4) AND BIMOWANGVAR2<20 AND BIMOWANGVAR1<20
AND (WINNER(CLOSE*125/100)-WINNER(CLOSE))*100<7.5,NODRAW,COLORBLUE;
STICKLINE(BIMOWANG,3,2,3,0),COLORBLUE,LINETHICK1;
{股神选股 (20天 10利润成功率92.88% 信号量4310 缺省周期:日线}

股神VAR1:=IF(DATE>=1031231, 0, 1);
股神VAR2:=CLOSE<0.980*REF(CLOSE, 1);
股神VAR3:=OPEN<REF(CLOSE, 1);
股神VAR4:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100*股神VAR1;
股神VAR5:=(CLOSE-REF(OPEN, 29))/REF(OPEN, 29)*100*股神VAR1;
股神VAR6:=MA(COST(22)/LOW, 3);
股神VAR7:=股神VAR6>1.5 AND 股神VAR4>5 AND 股神VAR5<-30;
股神Q:股神VAR7 OR (COUNT(股神VAR7, 10) AND 股神VAR2 OR COUNT(股神VAR7, 20)
AND 股神VAR3)*股神VAR1,COLORGREEN,NODRAW;
STICKLINE(股神Q,4,3,3,0),COLORGREEN,LINETHICK1;
{CDYXA01 (20天10%成功率96.66%) 缺省周期:日线}
CDYXA01VAR1:=99999999;
CDYXA01VAR2:=1;
CDYXA01VAR3:=CDYXA01VAR2*(CLOSE-MA(CLOSE,42))/MA(CLOSE,42)*100;
CDYXA01:HHV(CLOSE,20)/CLOSE>1.15 AND HIGH/LOW>1.05 AND CROSS(-28,CDYXA01VAR3) ,COLORRED,NODRAW;
STICKLINE(CDYXA01,8,7,3,0),COLORRED,LINETHICK1;
{XZP647-1 (分析家公式网缺省周期:日线}
XZP647VAR1:=DMA(CLOSE,VOL/MA(VOL,4)/4);
XZP647VAR2:=DMA(CLOSE,VOL/MA(VOL,33)/33);
XZP647VAR3:=(CLOSE-XZP647VAR1)/XZP647VAR1*100<-11;
XZP647VAR4:=(XZP647VAR1-XZP647VAR2)/XZP647VAR2*100<-22.3;
XZP647VAR5:=(WINNER(CLOSE*125/100)-WINNER(CLOSE))*100<8;
XZP647:XZP647VAR5 AND XZP647VAR4,NODRAW,COLORCYAN;
STICKLINE(XZP647,5,4,3,0),COLORCYAN,LINETHICK1;
{RS98(V) 缺省周期:日线}

RS98VAR1:=(REF(CLOSE,2)-REF(CLOSE,1))/REF(CLOSE,2)>0.05;
RS98VAR2:=(REF(CLOSE,3)-REF(CLOSE,2))/REF(CLOSE,3)>0.05;
RS98VAR3:=REF(HIGH,2)-REF(HIGH,1);
RS98VAR4:=REF(HIGH,1)-RS98VAR3;
RS98VAR5:=VOL/CAPITAL*100;
RS98:RS98VAR5<15 AND (HIGH-LOW)/CLOSE>0.045 AND CLOSE>RS98VAR4
AND RS98VAR1 AND RS98VAR2 AND CLOSE>OPEN AND
MA(CLOSE,60)-MA(CLOSE,9)/2.68>CLOSE,COLORMAGENTA,NODRAW;
STICKLINE(RS98,6,5,3,0),COLORMAGENTA,LINETHICK1;
{ZZXU (追涨选股 20天 10利润成功率:93.38%,共发出指示:2982 ) 缺省周期:日线}
ZZXUVAR1:=1;
ZZXUVAR2:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100*ZZXUVAR1;
ZZXUVAR3:=(CLOSE-REF(OPEN, 29))/REF(OPEN, 29)*100*ZZXUVAR1;
ZZXUVAR4:=VOL/MA(VOL, 5)*ZZXUVAR1;
ZZXUVAR5:=WINNER(CLOSE)*100;
ZZXUVAR6:=VOL/CAPITAL*100*ZZXUVAR1;
ZZXUVAR7:=LLVBARS(LOW, 50)*ZZXUVAR1;
ZZXUVAR8:=SUM(VOL, ZZXUVAR7)*ZZXUVAR1;
ZZXUVAR9:=HHVBARS(HIGH, 50)*ZZXUVAR1;
ZZXUVAR10:=SUM(VOL, ZZXUVAR9)*ZZXUVAR1;
ZZXUVAR11:=(CLOSE-REF(OPEN, ZZXUVAR9))/REF(OPEN, ZZXUVAR9)*100*ZZXUVAR1;
ZZXUVAR12:=ZZXUVAR10/CAPITAL*100*ZZXUVAR1;
ZZXUVAR13:=(CLOSE-REF(OPEN, ZZXUVAR7))/REF(OPEN, ZZXUVAR7)*100*ZZXUVAR1;
ZZXUVAR14:=ZZXUVAR8/CAPITAL*100*ZZXUVAR1;
ZZXUVAR15:=(CLOSE-LLV(LOW, 45))/(HHV(HIGH, 45)-LLV(LOW, 45))*100;
ZZXUVAR16:=SMA(ZZXUVAR15, 3, 1);
ZZXUVAR17:=SMA(ZZXUVAR16, 3, 1);
ZZXUVAR18:=3*ZZXUVAR16-2*ZZXUVAR17;
ZZXUVAR19:=CLOSE<REF(CLOSE, 1);
ZZXUVAR20:=OPEN<REF(CLOSE, 1);
ZZXUVAR21:=ZZXUVAR17<10 AND ZZXUVAR3<-30 AND ZZXUVAR2>8;
ZZXUQ:ZZXUVAR21 OR (COUNT(ZZXUVAR21, 15) AND ZZXUVAR19 OR COUNT(ZZXUVAR21, 15)
AND ZZXUVAR20)*ZZXUVAR1,COLORWHITE,NODRAW;
STICKLINE(ZZXUQ,7,6,3,0),COLORWHITE,LINETHICK1;
{超级选股 ( 指示:3811 成功指示:3493) 缺省周期:日线}
超级选股:(C<DMA(EMA(C,21),SUM(V,8)/5/CAPITAL)*0.76 AND C<REF(H,13)*0.775)
AND "VMACD.MACD"(13,63,10)>0
AND (MAX(ABS(H-AMOUNT/V/100),ABS(AMOUNT/V/100-L))+
ABS((O+C)/2-AMOUNT/V/100))/(AMOUNT/V/100)*50>2.1
AND REF(L,1)/H<1.02 AND V<REF(V,1)*3
AND "KDJ.J"(28,14,7)<10 AND MA(V,10)<MA(V,50)*1.7,NODRAW,COLORLIGRAY;
STICKLINE(超级选股,9,8,1,0),COLORLIGRAY,LINETHICK1;
{智仁LH-D(LHZ-D优化)}
智仁VAR1:=DMA(CLOSE,VOL/SUM(VOL,34));
智仁VAR2:=DMA(CLOSE,VOL/SUM(VOL,13));
智仁VAR3:=(CLOSE-智仁VAR1)/智仁VAR1*100;
智仁VAR4:=(CLOSE-智仁VAR2)/智仁VAR2*100;
智仁LH:智仁VAR4<=-12 AND 智仁VAR3<=-19 ;
{神奇乖离}
SQGL:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100;
神奇乖离:CROSS(-27,SQGL);


跳空缺口: OPEN > REF(H, 1)   AND OPEN / REF(CLOSE,1)  >=1.03 AND C > OPEN
AND REF(H, 1)  <  LOW   AND H / C  <= 1.01 AND
(CLOSE-REF(CLOSE,4))/REF(CLOSE,4)<0.3 ,NODRAW;
STICKLINE(跳空缺口,0,-1,1,0),COLORMAGENTA,LINETHICK1;

四阳3阴:C<O AND REF(C,1)<REF(O,1) AND REF(C,2)<REF(O,2)
AND REF(C,3)>REF(O,3) AND REF(C,4)>REF(O,4) AND REF(C,5)>REF(O,5) AND REF(C,6)>REF(O,6);

绝地鹰王VAR1:=CLOSE/MA(CLOSE,20)*100<80;
绝地鹰王VAR2:=CLOSE/MA(CLOSE,40)*100<78;
绝地鹰王VAR3:=CLOSE/MA(CLOSE,60)*100<72;
绝地鹰王VAR4:=HIGH>LOW*1.051;
绝地鹰王VAR5:=绝地鹰王VAR4 AND COUNT(绝地鹰王VAR4,5)>1;
绝地鹰王:绝地鹰王VAR5 AND (绝地鹰王VAR1 OR 绝地鹰王VAR2 OR 绝地鹰王VAR3);

第九VAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
第九VAR2:=SMA(第九VAR1,3,1);
第九VAR3:=SMA(第九VAR2,3,1);
第九VAR4:=3*第九VAR2-2*第九VAR3;
第九VAR5:="RSI";
第九VAR6:="MACD";
第九VAR7:=1;
第九A:=AMOUNT/(100*VOL);
第九VAR8:=100*(CLOSE-MA(第九A,26))/MA(第九A,26);
第九VAR9:=第九VAR8<-17.5 AND 第九VAR8>-36 AND CLOSE*第九VAR7<10 AND CLOSE*第九VAR7/REF(CLOSE,1)>0.935 AND CROSS(第九VAR4,第九VAR2);
第九:第九VAR9/第九VAR7,NODRAW;
STICKLINE(第九,0,-2,-1,0),COLORRED,LINETHICK1;

[ 本帖最后由 任刚 于 2017-4-10 08:01 编辑 ]
理想369a7b
Lv.1
发表于 2019-7-14 13:35 复制 查看全部楼层
@飞远国际

收到,感谢飞远老师
飞远国际
Lv.6
发表于 2019-7-14 13:11 复制 查看全部楼层
理想369a7b 发表于 2019-7-14 12:40
@飞远国际

{未来函数XMA}

VARR1:=(C+H+O+L)/4;
BBB1:=XMA(VARR1,32)*(1-100/1000);
SJXZ:=IF(DATE<1931128,1,0);
买入:=BBB1*SJXZ;
现价:=C;
XG:CROSS(买入,现价);
理想369a7b
Lv.1
发表于 2019-7-14 12:40 复制 查看全部楼层
@飞远国际

{未来函数XMA}
VARR1:=(C+H+O+L)/4;
BBB1:=XMA(VARR1,32)*(1-100/1000);
SJXZ:=IF(DATE<1931128,1,0);
买入:=BBB1*SJXZ;
现价:=C;
XG:CROSS(现价,买入);

飞远老师周末好,上次您帮做的这个是红线上穿白线的,可以帮做一个红线下穿白线的选股公式吗?我是作为备选观察股使用.
预见先生,人生大幸!感谢感谢!
理想369a7b
Lv.1
发表于 2019-7-12 09:41 复制 查看全部楼层
@飞远国际
十分感谢飞远老师,辛苦了
飞远国际
Lv.6
发表于 2019-7-11 20:56 复制 查看全部楼层
理想369a7b 发表于 2019-7-11 20:00
@飞远国际
或者做一个红线出白线的选股公式,谢谢老师


{未来函数XMA}
VARR1:=(C+H+O+L)/4;
BBB1:=XMA(VARR1,32)*(1-100/1000);
SJXZ:=IF(DATE<1931128,1,0);
买入:=BBB1*SJXZ;
现价:=C;
XG:CROSS(现价,买入);
飞远国际
Lv.6
发表于 2019-7-11 20:52 复制 查看全部楼层

{未来函数XMA}
VARR1:=(C+H+O+L)/4;
AAA1:=XMA(VARR1,20)*(1+80/1000);
BBB1:=XMA(VARR1,32)*(1-100/1000);
SJXZ:=IF(DATE<1931128,1,0);
卖出:=AAA1*SJXZ;
买入:=BBB1*SJXZ;
XG:CROSS(买入,卖出);
理想369a7b
Lv.1
发表于 2019-7-11 20:00 复制 查看全部楼层
@飞远国际
或者做一个红线出白线的选股公式,谢谢老师
理想369a7b
Lv.1
发表于 2019-7-11 19:43 复制 查看全部楼层
@飞远国际


VARR1:=(C+H+O+L)/4;
AAA1:=XMA(VARR1,20)*(1+80/1000);
BBB1:=XMA(VARR1,32)*(1-100/1000);
SJXZ:=IF(DATE<1931128,1,0);
卖出:AAA1*SJXZ,COLORGREEN,LINETHICK2;
买入:BBB1*SJXZ,COLORWHITE,LINETHICK2;
现价:C,COLORRED;

飞远老师您好,可以帮做一个绿线和白线交叉或收拢靠近的选股公式吗?感谢感谢
理想ab9d53
Lv.1
发表于 2018-7-25 11:09 复制 查看全部楼层
@深山水寒 谢谢,感恩你的分享
理想ab9d53
Lv.1
发表于 2018-7-25 10:58 复制 查看全部楼层
尊敬的楼主您好,我黏贴以下这段进去指标公式里
BIAS0:= (C-MA(C,2))/MA(C,2)*100;
HXL:=V/CAPITAL*100;
D1:=INDEXC;
D2:=MA(D1,13);
DR2:=D2>1.050*D1;
E1:=(C-HHV(C,12))/HHV(C,12)*10;
E2:=(C-REF(C,26))/REF(C,26)*10;
E3:=MA(C,3);
SJ1:=DR2;
SJ2:=E2<-2.30;
SJ3:=BIAS0<-2.7;
SJ5:=SJ1 AND SJ2 AND SJ3;
SJ6:=CROSS(0.5,SJ5);
JS1:=CROSS(SJ6,0.5);JS2:=BARSLAST(JS1=1);
JS3:=JS2<=5 AND C<REF(C,JS2);
大赛排名第一:SJ6 OR JS3,NODRAW;
STICKLINE(大赛排名第一,4,0,4,1),COLORMAGENTA,LINETHICK1;
{BFBZ (20天10%利润,成功率98.52%信号量2209) }
VAR1:=INDEXC;
VAR2:=MA(VAR1,6);
VAR3:=MA(VAR1,24);
VAR4:=MA(VAR1,32);
VAR5:=MA(VAR1,62);
VAR6:=MA(VAR1,105);
VAR7:=VAR5<REF(VAR5,1) AND VAR6<REF(VAR6,1) AND VAR5<VAR6*0.98;
VAR8:=VAR4>VAR2*1.11 AND VAR3>VAR2*1.095;
VAR9:=VAR2>VAR1*0.95;
BFBZ:VAR7 AND VAR8 AND VAR9 AND CLOSE/COST(8)<=0.8
AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(CLOSE,1)>REF(OPEN,1)
OR REF(CLOSE,1)<REF(OPEN,1)),NODRAW,COLORYELLOW;
STICKLINE(BFBZ,1,0,3,0),COLORYELLOW,LINETHICK1;
{飞鹰优化 (90.87%缺省周期:日线}
飞鹰VAR1:=CLOSE/MA(CLOSE,40)*100<78;
飞鹰VAR2:=CLOSE/MA(CLOSE,60)*100<74;
飞鹰VAR3:=HIGH>LOW*1.051;
飞鹰VAR4:=飞鹰VAR3 AND COUNT(飞鹰VAR3,5)>1;
飞鹰TYP:=(HIGH+LOW+CLOSE)/3;
飞鹰CCI:=(飞鹰TYP-MA(飞鹰TYP,14))/(0.015*AVEDEV(飞鹰TYP,14));
飞鹰优化:飞鹰VAR4 AND (飞鹰VAR1 OR 飞鹰VAR2) AND
MA(C,27)/CLOSE>1.169 AND MA(C,17)/CLOSE>1.158 AND
CLOSE<MA(C,120) AND MA(C,60)<MA(C,120) AND MA(C,60)>MA(C,30) AND 飞鹰CCI>-210,NODRAW,COLORBROWN;
STICKLINE(飞鹰优化,2,1,3,0),COLORBROWN,LINETHICK1;
{BIMOWANG (成功率93.12 信号3736 缺省周期:日线}
BIMOWANGVAR1:=EMA(WINNER(CLOSE)*70,3);
BIMOWANGVAR2:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
BIMOWANGVAR3:=CLOSE/MA(CLOSE,40)*100<76;
BIMOWANGVAR4:=CLOSE/MA(CLOSE,60)*100<74;
BIMOWANGVAR5:=HIGH>LOW*1.051;
BIMOWANGVAR6:=BIMOWANGVAR5 AND COUNT(BIMOWANGVAR5,5)>1;
BIMOWANG:BIMOWANGVAR6 AND (BIMOWANGVAR3 OR BIMOWANGVAR4) AND BIMOWANGVAR2<20 AND BIMOWANGVAR1<20
AND (WINNER(CLOSE*125/100)-WINNER(CLOSE))*100<7.5,NODRAW,COLORBLUE;
STICKLINE(BIMOWANG,3,2,3,0),COLORBLUE,LINETHICK1;
{股神选股 (20天 10利润成功率92.88% 信号量4310 缺省周期:日线}
结果出现:一片空白(无法上传截图,抱歉)请问是哪里出问题了?
理想ab9d53
Lv.1
发表于 2018-7-25 10:51 复制 查看全部楼层
当前公式 : 第二 (条件选股公式)  
错误句 :
大赛排名第一:SJ6 OR JS3,NODRAW
详细信息 : 不是画线指标公式,不能指定画线类型!
错误起始位置 : 336 ; 长度: 1

你好,为何我都是出现这样的提示?能给一个直接黏贴进去就能用的版本吗?
Q_3011741
Lv.1
发表于 2018-4-5 17:28 复制 查看全部楼层
当前公式 : 排名第一 (条件选股公式)  
错误句 :
大赛排名第一:SJ6 OR JS3,NODRAW
详细信息 : 不是指标画线公式,不能指定画线类型!
错误起始位置 : 336 ; 长度: 1
士123我
Lv.2
发表于 2018-1-14 16:24 复制 查看全部楼层
@飞远国际 红柱买入
士123我
Lv.2
发表于 2018-1-14 16:22 复制 查看全部楼层
@飞远国际 H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8,COLORGREEN;
支撑:=L1+P1*0.5/8,COLORRED;
中线:=(支撑+阻力)/2;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:=EMA(V11,3),LINETHICK2,COLORLIMAGENTA;
V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*100;
AA:=(趋势线<11) AND FILTER((趋势线<=11),15) AND C<中线;
BB0:=REF(趋势线,1)<11 AND CROSS(趋势线,11) AND C<中线;
BB1:=REF(趋势线,1)<11 AND REF(趋势线,1)>6 AND CROSS(趋势线,11);
BB2:=REF(趋势线,1)<6 AND REF(趋势线,1)>3 AND CROSS(趋势线,6);
BB3:=REF(趋势线,1)<3 AND REF(趋势线,1)>1 AND CROSS(趋势线,3);
BB4:=REF(趋势线,1)<1 AND REF(趋势线,1)>0 AND CROSS(趋势线,1);
BB5:=REF(趋势线,1)<0 AND CROSS(趋势线,0);
BB:=BB1=1 OR BB2=1 OR BB3=1 OR BB4=1 OR BB5=1;
下单买入:=STICKLINE(BB=1 AND C<中线,11,50,5,0),COLORRED;
A:=BB=1 AND C<中线;
XG:下单买入 AND A;
这两个合并一下
飞远国际
Lv.6
发表于 2018-1-14 10:35 复制 查看全部楼层
@士123我

VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
XG:CROSS(VAR1D,0.015);
士123我
Lv.2
发表于 2018-1-14 10:24 复制 查看全部楼层
@飞远国际 VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3*VAR6-2*VAR7;
VAR1A:=IF(CROSS(VAR6,VAR8) AND CROSS(VAR7,VAR8) AND CROSS(VAR7,VAR6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:IF(VAR1D>0.015,VAR1F,0)/45,COLORMAGENTA;
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
主力资金:POW(VAR11,3)*0.1+POW(VAR11,1),COLORRED;
0,COLORYELLOW;



做一个紫色线出现时的选股公式可以吗老师
山鹰66
Lv.2
发表于 2017-12-24 21:33 复制 查看全部楼层
谢谢分享
士123我
Lv.2
发表于 2017-4-26 09:07 复制 查看全部楼层
@飞远国际 VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR2:=2*ABS(VAR1);
VAR3:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR4:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR5:=(HIGH+LOW+CLOSE)/3;
VAR6:=(VAR5-MA(VAR5,14))/(0.015*AVEDEV(VAR5,14));
VAR7:=(VAR5-MA(VAR5,70))/(0.015*AVEDEV(VAR5,70));
VAR8:=IF(VAR6>=150 AND VAR6<200 AND VAR7>=150 AND VAR7<200,10,0);
VAR9:=IF(VAR6<=-150 AND VAR6>-200 AND VAR7<=-150 AND VAR7>-200,-10,VAR8);
VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VARB:=100-ABS(VARA);
VARC:=3*SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VARD:=3*SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=VAR11-CLOSE;
VAR13:=REF(CLOSE,1);
VAR14:=SMA(MAX(CLOSE-VAR13,0),7,1)/SMA(ABS(CLOSE-VAR13),7,1)*100;
VAR15:=SMA(MAX(CLOSE-VAR13,0),13,1)/SMA(ABS(CLOSE-VAR13),13,1)*100;
VAR16:=BARSCOUNT(CLOSE);
VAR17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
VAR18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;
VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1A:=(SMA(VAR19,4,1)-50)*2;
VAR1B:=SMA(VAR1A,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=IF(VAR17<=25 AND VAR18<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR12>=-0.25 AND VAR14<22 AND VAR15<28 AND VAR16>50,80,0);
情报: VAR3;
天线: IF(VARB<90,VARB,100);
{www.55188.com 理想论坛_最新股票指标公式}
红军: IF(VAR1>0,VAR1,0),COLORRED, LINESTICK;
绿军: IF(VAR1<0,VAR2,0),COLORGREEN,LINESTICK;
导弹: VAR20;
预警系统: IF(VAR7>=200 AND VAR6>=150,15,IF(VAR7<=-200 AND VAR6<=-150,-15,VAR9))+60;
STICKLINE(VAR3>=REF(VAR4,1),VAR3,VAR4,8,0);
STICKLINE(VAR3<REF(VAR4,1),VAR3,VAR4,8,0);
VAR21:=CLOSE>MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1);
VAR22:=CLOSE<MA(CLOSE,20) AND MA(CLOSE,20)<REF(MA(CLOSE,20),1);
VAR23:=红军>50 AND 预警系统>60 AND 天线=100;
VAR24:=红军>48 AND 预警系统>60 AND 天线<100;
VAR25:=绿军>38 AND 预警系统<55;
VAR26:=导弹>50 AND 天线<90;
VAR27:=VAR3<REF(VAR4,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VAR28:=VAR3>=REF(VAR4,1) AND CLOSE<REF(CLOSE,1) AND 预警系统=60 AND 导弹=0 AND 绿军>=REF(绿军,1) AND VARC<REF(VARD,1);
DRAWTEXT(VAR21 AND COUNT(VAR21,30)=1,100,'上升通道,持股待长或高抛低吸!');
DRAWTEXT(VAR22 AND COUNT(VAR22,30)=1,90,'下降通道,小心无量阴跌! ');
DRAWTEXT(VAR23 AND COUNT(VAR23,30)=1,70,'上涨过急,需要调整,短线先抛出! ');
DRAWTEXT(VAR24 AND COUNT(VAR24,30)=1,80,'庄家出货,大跌在即,中线抛出! ');
DRAWTEXT(VAR25 AND COUNT(VAR25,30)=1,50,'不必杀跌,应有小反弹 ,跌停除外!');
DRAWTEXT(VAR26 AND COUNT(VAR26,30)=1,30,'坚决抢反弹,但巨量封跌停除外 ');
DRAWTEXT(VAR27 AND COUNT(VAR27,30)=1,40,'有大资金进场迹象,关注!');
DRAWTEXT(VAR28 AND COUNT(VAR28,30)=1,20,'见顶回落')
白色的导弹提示选股公式能帮我做以下吗谢谢老师了
士123我
Lv.2
发表于 2017-4-25 17:52 复制 查看全部楼层
@飞远国际 VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR2:=2*ABS(VAR1);
VAR3:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR4:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR5:=(HIGH+LOW+CLOSE)/3;
VAR6:=(VAR5-MA(VAR5,14))/(0.015*AVEDEV(VAR5,14));
VAR7:=(VAR5-MA(VAR5,70))/(0.015*AVEDEV(VAR5,70));
VAR8:=IF(VAR6>=150 AND VAR6<200 AND VAR7>=150 AND VAR7<200,10,0);
VAR9:=IF(VAR6<=-150 AND VAR6>-200 AND VAR7<=-150 AND VAR7>-200,-10,VAR8);
VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VARB:=100-ABS(VARA);
VARC:=3*SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VARD:=3*SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1)-2*SMA(SMA((INDEXO-LLV(INDEXL,75))/(HHV(INDEXH,75)-LLV(INDEXL,75))*100,20,1),15,1);
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=VAR11-CLOSE;
VAR13:=REF(CLOSE,1);
VAR14:=SMA(MAX(CLOSE-VAR13,0),7,1)/SMA(ABS(CLOSE-VAR13),7,1)*100;
VAR15:=SMA(MAX(CLOSE-VAR13,0),13,1)/SMA(ABS(CLOSE-VAR13),13,1)*100;
VAR16:=BARSCOUNT(CLOSE);
VAR17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
VAR18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+50)*2;
VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1A:=(SMA(VAR19,4,1)-50)*2;
VAR1B:=SMA(VAR1A,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=IF(VAR17<=25 AND VAR18<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR12>=-0.25 AND VAR14<22 AND VAR15<28 AND VAR16>50,80,0);
情报: VAR3;
天线: IF(VARB<90,VARB,100);
{www.55188.com 理想论坛_最新股票指标公式}
红军: IF(VAR1>0,VAR1,0),COLORRED, LINESTICK;
绿军: IF(VAR1<0,VAR2,0),COLORGREEN,LINESTICK;
导弹: VAR20;
预警系统: IF(VAR7>=200 AND VAR6>=150,15,IF(VAR7<=-200 AND VAR6<=-150,-15,VAR9))+60;
STICKLINE(VAR3>=REF(VAR4,1),VAR3,VAR4,8,0);
STICKLINE(VAR3<REF(VAR4,1),VAR3,VAR4,8,0);
VAR21:=CLOSE>MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1);
VAR22:=CLOSE<MA(CLOSE,20) AND MA(CLOSE,20)<REF(MA(CLOSE,20),1);
VAR23:=红军>50 AND 预警系统>60 AND 天线=100;
VAR24:=红军>48 AND 预警系统>60 AND 天线<100;
VAR25:=绿军>38 AND 预警系统<55;
VAR26:=导弹>50 AND 天线<90;
VAR27:=VAR3<REF(VAR4,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VAR28:=VAR3>=REF(VAR4,1) AND CLOSE<REF(CLOSE,1) AND 预警系统=60 AND 导弹=0 AND 绿军>=REF(绿军,1) AND VARC<REF(VARD,1);
DRAWTEXT(VAR21 AND COUNT(VAR21,30)=1,100,'上升通道,持股待长或高抛低吸!');
DRAWTEXT(VAR22 AND COUNT(VAR22,30)=1,90,'下降通道,小心无量阴跌! ');
DRAWTEXT(VAR23 AND COUNT(VAR23,30)=1,70,'上涨过急,需要调整,短线先抛出! ');
DRAWTEXT(VAR24 AND COUNT(VAR24,30)=1,80,'庄家出货,大跌在即,中线抛出! ');
DRAWTEXT(VAR25 AND COUNT(VAR25,30)=1,50,'不必杀跌,应有小反弹 ,跌停除外!');
DRAWTEXT(VAR26 AND COUNT(VAR26,30)=1,30,'坚决抢反弹,但巨量封跌停除外 ');
DRAWTEXT(VAR27 AND COUNT(VAR27,30)=1,40,'有大资金进场迹象,关注!');
DRAWTEXT(VAR28 AND COUNT(VAR28,30)=1,20,'见顶回落')
白色的导弹提示选股公式能帮我做以下吗
士123我
Lv.2
发表于 2017-4-25 17:00 复制 查看全部楼层
@飞远国际 (1)当天收阳,且涨幅小于8%;

(2)缩量上涨;

解释:缩量上涨说明庄家的筹码锁定得较好,符合风险偏好高的资金的炒作条件,后市有戏!

(3)大单净量大于0.2;

(4)这只股票不是创业板,也不是ST;
可以做个选股器吗
士123我
Lv.2
发表于 2017-4-25 16:51 复制 查看全部楼层
@飞远国际 VAR1:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
VAR2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR3:=(SMA(VAR2,3,1)-18)*1.55;
VAR4:=SMA(VAR3,3,1);
VAR5:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100;
VAR6:=SMA(VAR5,10,1);
VAR7:=(EMA(SMA(VAR6,8,1),34)-25)*2.6;
VAR8:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VAR9:=POW(MA(LOW,5),2)+MA(LOW,5);
VARA:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VARB:=((VAR8-LLV(VAR9,64))/(HHV(VARA,64)-LLV(VAR9,64))*150+65-10)/2;
VARC:=SMA(VARB,3,1)*1.5-46;
VARD:=SMA(VARC,3,1);
VARE:=3*VARC-2*VARD;
VARF:=(VAR1+VAR2+VAR5)/3;
VAR10:=((VAR3+VAR3+VAR6+VARC)/4-15)*1.67;
VAR11:=((VAR4+VAR4+VAR7+VARD)/4-15)*1.67;
VAR12:=((VAR1+VAR5*2+VARF+VAR10+VAR11+VARB+VARC+VARD+VARE)/10-15)*1.67;
VAR13:=(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*(-1)+0.9;
VAR14:=(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*(-1)+0.92;
VAR15:=(HHV(HIGH,15)-CLOSE)/(HHV(HIGH,15)-LLV(LOW,15))*(-1)+0.93;
VAR16:=(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55))*(-1)+0.94;
VAR17:=(HHV(HIGH,89)-CLOSE)/(HHV(HIGH,89)-LLV(LOW,89))*(-1)+0.95;
VAR18:=(HHV(HIGH,120)-CLOSE)/(HHV(HIGH,120)-LLV(LOW,120))*(-1)+0.91;
VAR19:=(HHV(HIGH,180)-CLOSE)/(HHV(HIGH,180)-LLV(LOW,180))*(-1)+0.96;
VAR1A:=((VAR13*8+VAR14*8+VAR15*8+VAR16+VAR17+VAR18+VAR19)/28-0.1)*185;
VAR1B:=SMA(VAR1A,3,1);
VAR1C:=(SMA(VAR1B,8,1)-8)*1.18;
浮动筹码: (VAR10+VAR11+VAR12+VARC+VARD+VARE+VAR1C+VAR7)/13 ;
浮动筹码1: (VAR10+VAR11+VAR12+VARC+VARD+VARE+VAR1C+VAR7)/21 ;
浮动筹码2: (VAR10+VAR11+VAR12+VARC+VARD+VARE+VAR1C+VAR7)/34;
获利筹码: (VAR3+VAR6+VAR1B*2)/4 ;
40;
20;
0;
VARA1:=(CLOSE-LLV(LOW,60.13547854))/(HHV(HIGH,60.13547854)-LLV(LOW,60))*80;
VARB1:=SMA(VARA1,7,1);
VARC1:=SMA(VARB1,5,1);
英雄:IF(CROSS(VARB,VARC) AND VARB<20,100,0),LINETHICK2,COLORRED;
VAR2N:=LLV(LOW,3)<=LLV(LOW,60);
VAR3N:=  C>O AND (C/O>1.03 OR C>1.03*REF(C,1));
绝地反击:IF(VAR2N AND VAR3N,90,0),COLORYELLOW,LINETHICK2;


老师这个帮我作何选股公式谢谢
飞远国际
Lv.6
发表于 2017-4-23 23:00 复制 查看全部楼层
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
长庄线:=A+100;
游资线:=B+100;
主力线:=D+100;
绿柱:(长庄线<12 AND 主力线<8 AND (游资线<7.2 OR REF(游资线,1)<5) AND (主力线>REF(主力线,1) OR 游资线>REF(游资线,1)))
OR (长庄线<8 AND 主力线<7 AND 游资线<15 AND 游资线>REF(游资线,1)) OR (长庄线<10 AND 主力线<7 AND 游资线<1) ;
士123我
Lv.2
发表于 2017-4-23 10:34 复制 查看全部楼层
@飞远国际 VAR2:=LLV(LOW,33);
VAR3:=HHV(HIGH,21);
VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*100,20)*0.998;
100,STICK,LINETHICK7, COLORFFCC33;
80, STICK,LINETHICK7, COLORFF9933;
50,STICK,LINETHICK7, COLORBLUE;
20,STICK,LINETHICK7,COLORCC0033;
20,COLORWHITE;
50,COLORYELLOW;
80,COLORCYAN;
DRAWTEXT(FILTER(CLOSE>0,25),10,'底部吸筹区'),, COLORWHITE;
DRAWTEXT(FILTER(CLOSE>0,25),30,'主力建仓区'), , COLORWHITE;
DRAWTEXT(FILTER(CLOSE>0,25),65,'主力拉高区'), , COLORWHITE;
DRAWTEXT(FILTER(CLOSE>0,25),88,'主力出货区'), , COLORWHITE;
当前安全度:=100-EMA(0.667*REF(VAR4,1)+0.333*VAR4,1),LINETHICK2 ,COLORRED;
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK2;
长庄线:=A+100,COLORMAGENTA;
游资线:=B+100,COLORYELLOW,LINETHICK2;
主力线:D+100,COLORRED,LINETHICK4;
见顶:=(REF(主力线,1)>85 AND REF(游资线,1)>85 AND REF(长庄线,1)>65) AND CROSS(长庄线,游资线) ;
顶部区域:=(主力线<REF(主力线,1) AND REF(主力线,1)>80) AND (REF(游资线,1)>95 OR REF(游资线,2)>95 ) AND 长庄线>60 AND 游资线<83.5
AND 游资线<主力线 AND 游资线<长庄线+4;
顶部:=FILTER(顶部区域,4);
操盘顾问:(长庄线<12 AND 主力线<8 AND (游资线<7.2 OR REF(游资线,1)<5) AND (主力线>REF(主力线,1) OR 游资线>REF(游资线,1)))
OR (长庄线<8 AND 主力线<7 AND 游资线<15 AND 游资线>REF(游资线,1)) OR (长庄线<10 AND 主力线<7 AND 游资线<1) ;
STICKLINE( {见顶 OR} 顶部,99,103,20,1 ),COLORRED,LINETHICK2;
STICKLINE(操盘顾问,-4,0,22,0 ),COLORGREEN;
长短顾问:长庄线<15 AND REF(长庄线,1)<15 AND 主力线<18 AND 游资线>REF(游资线,1) AND CROSS(游资线,长庄线) AND 游资线>主力线
AND (REF(游资线,1)<5 OR REF(游资线,2)<5 ) AND (主力线>=长庄线 OR REF( 游资线,1)<1 );
STICKLINE(长短顾问,0,5,11,0 ),COLORRED;
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),90,5);
DRAWTEXT(CROSS(82,VARR1),95,'逃'),COLORRED,LINETHICK4;


这个指标的绿柱选股可以做吗谢谢老师
飞远国际
Lv.6
发表于 2017-4-22 19:52 复制 查看全部楼层
@士123我
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
金叉二:CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
士123我
Lv.2
发表于 2017-4-22 19:09 复制 查看全部楼层
@飞远国际 麻烦 你了老师
士123我
Lv.2
发表于 2017-4-22 18:56 复制 查看全部楼层
@飞远国际 DRAWGBK(C>0, RGB(40,120,20),RGB(00,00,00),0,0,1),LINETHICK2;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9),COLORGREEN,LINETHICK2;
MACD:(DIF-DEA)*2,COLORSTICK;
DIF1:EMA(CLOSE,8)-EMA(CLOSE,18),COLORYELLOW,LINETHICK2;
DEA1:=EMA(DIF1,8),COLORWHITE,LINETHICK2;
空中加油:IF(DIF>REF(DIF,1) AND DIF>=DEA AND REF(DIF,1)<=REF(DIF,2) AND REF(DIF,1)>=REF(DEA,1) ,1,0),NODRAW;
DRAWICON(空中加油=1,DIF,23);

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR00BBFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR00DDFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0,0 ),COLOR00FFFF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR0011EE;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1,0 ),COLOR0033DD;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0,0 ),COLOR0055FF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORBB11BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORDD33BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0,0 ),COLORFF55BB;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLORFFBB11;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFFDD33;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0,0 ),COLORFFFF55;

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,-0.18,6,0),COLORFF00FF;
DRAWICON(二次金叉,DEA*1.1,13) ;


VAR0004:="MACD.DIF#WEEK"(6,13,5);
VAR0005:="MACD.DEA#WEEK"(6,13,5);
VAR0006:="MACD.MACD#WEEK"(6,13,5);
VAR7:="MACD.DIF#MONTH"(6,13,5);
VAR8:="MACD.DEA#MONTH"(6,13,5);
周金叉:IF(CROSS(VAR0004,VAR0005),0.3,0)LINESTICK, COLORRED,LINETHICK3;
月金叉:IF(CROSS(VAR7,VAR8),-0.5,0)LINESTICK, COLORYELLOW,LINETHICK3;
零轴金叉:IF(CROSS(VAR0004,0),0.2,0)LINESTICK,COLORGREEN,LINETHICK2;
0,LINETHICK3;
DRAWICON(CROSS(MACD,0),MACD,1);
DRAWICON(CROSS(DIF1,0),DIF1,1);
DRAWICON(CROSS(DIF,DEA),DIF,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);
低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;
DRAWTEXT(低位金叉,-0.2,' 金叉'),COLORFFFFFF;
JCCOUNT1:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉1:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,0,-0.18,10,0),COLOR0042CC;
STICKLINE(二次金叉,0,-0.18,8,0),COLOR004FF2;
STICKLINE(二次金叉,0,-0.18,8,0),COLOR3375FF;
DRAWTEXT(二次金叉,-0.2,' 金叉二'),COLOR3375FF;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
STICKLINE(底背离,0,0.13,10,0),COLORCECE00;
STICKLINE(底背离,0,0.13,4,0),COLORFFFF00;
STICKLINE(底背离,0,0.13,2,0),COLORFFFF44;
DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORFFFFFF,LINETHICK1;
DRAWTEXT(底背离,0.3,' 底背离'),COLORFFFF26;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK1;

这个里面的金叉二能做个选股公式吗
飞远国际
Lv.6
发表于 2017-4-22 18:55 复制 查看全部楼层
@士123我
macd.dif<-3;
士123我
Lv.2
发表于 2017-4-22 18:40 复制 查看全部楼层
@飞远国际 macd的dif线低于-3的选股可以帮我做以下吗老师
飞远国际
Lv.6
发表于 2017-4-22 13:12 复制 查看全部楼层
@士123我 这个指标建议不要用,指标中用到通达信特有的未来函数ZXNH,特飘!
您需要登录后才可以回帖 登录 | 免费注册

本版积分规则

回顶部 到页底
快速回复 返回顶部 返回列表