请老师帮忙写一个突破中轨的选股公式(谢谢智甜有懵老师 已经解决)

[通达信] 6233 10
设置
2664980 Lv.2

专栏

发表于 2017-4-13 13:35 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
源代码:
      有一条中轨0轴,我的意思就是红K线的最低价在0轴下方,高点在0轴上方,我截了一个图参考,中间那个黄色线是中轴
源代码:
VAR1:=REF(MA(C,20),10);开:=O-VAR1;高:=H-VAR1;低:=L-VAR1;收:=C-VAR1;MID:=MA(C,20);
UPPER:=MID+2*STD(C,20);LOWER:=MID-2*STD(C,20);V1:=(C-LOWER)/(UPPER-LOWER)*100;
V2:=V1-EMA(V1,5);K1:=SUM(LLV(V2,4),4)/4;V3:=EMA(V2,64)*10;V4:=EMA(0.4*V2*(-1),3);
V5:=-1*EMA(V2,39)*10;A:=V3>10;B:=V2>V4;D:=V5>10;E:=V3<=10 OR V2<=V4 OR V5<=10;
STICKLINE(C,0,0,6,0), COLORYELLOW;
STICKLINE(收>=开 AND E,高,低,0,0), COLORRED;
STICKLINE(收>=开 AND E,收,开,3,0) ,COLORRED;
STICKLINE(收< 开 AND E,高,低,0,0) ,COLORGREEN;
STICKLINE(收< 开 AND E,收,开,3,0) ,COLORGREEN;
STICKLINE(开> 收 AND A ,低,高,0,0),COLORFF0000;
STICKLINE(开> 收 AND A ,收,开,3,0),COLORFF0000;
STICKLINE(开<=收 AND A,低,高,0,0),COLORYELLOW;
STICKLINE(开<=收 AND A,收,开,3,1),COLORYELLOW;
STICKLINE(开> 收 AND B,低,高,0,0),COLORRED;
STICKLINE(开> 收 AND B,收,开,3,0),COLORRED;
STICKLINE(开<=收 AND B,低,高,0,0),COLORRED;
STICKLINE(开<=收 AND B,收,开,3,1),COLORRED;
STICKLINE(开> 收 AND D,低,高,0,0),COLORGREEN;
STICKLINE(开> 收 AND D,收,开,3,0),COLORGREEN;
STICKLINE(开<=收 AND D,收,开,3,1),COLORGREEN;

[ 本帖最后由 舒国洪 于 2017-4-13 14:26 编辑 ]

附件

QQ截图20170413132659.png
来自 山东省临沂市

举报

使用道具 扔鸡蛋 回复

2664980
Lv.2

专栏

发表于 2017-5-9 09:16 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省临沂市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2100067
Lv.4

专栏

发表于 2017-4-19 12:46 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

附件

2017-04-19_124559.png
来自 广东省清远市

举报

使用道具 支持 扔鸡蛋 回复

2664980
Lv.2

专栏

发表于 2017-4-19 12:06 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省临沂市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2100067
Lv.4

专栏

发表于 2017-4-19 11:56 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省清远市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2664980
Lv.2

专栏

发表于 2017-4-19 11:52 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省临沂市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2664980
Lv.2

专栏

发表于 2017-4-19 11:52 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省临沂市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2100067
Lv.4

专栏

发表于 2017-4-19 11:38 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省清远市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2664980
Lv.2

专栏

发表于 2017-4-19 11:30 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 山东省临沂市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2664980
Lv.2

专栏

发表于 2017-4-19 11:06 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...

附件

QQ截图20170419110435.png
QQ截图20170419110451.png
来自 山东省临沂市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2100067
Lv.4

专栏

发表于 2017-4-13 13:48 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 广东省清远市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
10楼
9楼
8楼
7楼
6楼
5楼
4楼
3楼
2楼
楼主
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表