新股民,哪位好心老师能将下面通达信公式改为“盯盘系统能用的公式”——好人好报!

[其 他] 3936 1
设置
3560128 Lv.2

专栏

发表于 2017-4-13 20:00 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
阶段卖: 3.2,COLORC6C600;

清仓: 3.5,COLORFF75FF;
动力线:= EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4);
STICKLINE(动力线>REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLORRED;
STICKLINE(动力线<=REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLOR00FF00;
底部:0.2,COLOR70DB93;
关注:0.5,COLORYELLOW;
DRAWICON( FILTER(CROSS(动力线,关注),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(清仓,动力线),20),动力线+0.02,2);
DRAWICON( FILTER(CROSS(动力线,底部),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(阶段卖,动力线),20),动力线+0.02,2);
界线:1.75,POINTDOT,LINETHICK2,COLOR70DB93;
数值:=动力线;
最佳买入: ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2),COLORLIMAGENTA,LINETHICK0;
DRAWTEXT(最佳买入=1,2.3,'买入'),COLORYELLOW;

ZYX1:="DMI.PDI"(12,6);
ZYX2:="DMI.MDI"(12,6);
ZYX3:=ZYX1>65 AND ZYX1>REF(ZYX1,1);
ZYX4:=LLV(ZYX1,0);
ZYX5:=BARSLAST(ZYX4=ZYX1);
ZYX6:=(0-REF(ZYX2,4))/(ZYX4-REF(ZYX2,ZYX5))>2;
ZYX7:=ZYX1>REF(ZYX1,1);
ZYX8:=VOL>2*MA(VOL,30);
ZYX9:="DMI.ADX"(12,6);
ZYXA:="DMI.ADXR"(12,6);
ZYXB:=CLOSE>MA(CLOSE,30) AND CLOSE<MA(CLOSE,30)*1.04;
ZYXC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);
ZYXD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))<BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));
{ZYXE:=0-"MACD.DIFF"(7,21,3);}
ZYXF:=TROUGHBARS(3,15,1)<4;
ZYX10:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);
ZYX11:=IF(ZYXF=1,50,0);
ZYX12:=CROSS(ZYX2,ZYX1) AND CROSS(ZYXA,ZYX9);
ZYX13:=CROSS(ZYX2,ZYX1) AND CROSS(ZYX9,ZYXA);
ZYX14:=ZYXB AND ZYXC AND ZYXD AND ZYX10 AND ZYX6 AND ZYX7 AND ZYX8*50;
ZYX15:=BARSLAST(CROSS(ZYX2,ZYX1)=1);
ZYX16:=BARSLAST(CROSS(ZYX1,ZYX2)=1);
ZYX17:=HHV(ZYX1,ZYX16);
ZYX18:=BARSLAST(ZYX1=ZYX17);
多空:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3);
STICKLINE(FILTER(ZYXF=1,5) AND 多空<-10,2.5,0.5,3,0),COLORRED;
STICKLINE(FILTER(ZYXF=1,5),2.5,0.5,1,0),COLORRED;
ZYX19:=ZYX3 OR ZYX12 OR ZYX13*100;
ZYX1A:=ZYX13*100;
DRAWTEXT(FILTER(ZYXF=1,3),1.3,'-铁底'),COLORYELLOW;

A1:=EMA(CLOSE,7)-EMA(CLOSE,21);
B1:=EMA((0.668*REF(A1,1)+0.333*A1),1);
短多:=IF(A1>=B1,A1,B1);
短空:=B1;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),4,1)/SMA(ABS(CLOSE-LC),4,1)*100;
RSI4:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
RSI5:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI6:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
RSI7:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
RSI8:=SMA(MAX(CLOSE-LC,0),9,1)/SMA(ABS(CLOSE-LC),9,1)*100;
RSI9:=SMA(MAX(CLOSE-LC,0),10,1)/SMA(ABS(CLOSE-LC),10,1)*100;
RSI10:=SMA(MAX(CLOSE-LC,0),11,1)/SMA(ABS(CLOSE-LC),11,1)*100;
RSI11:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI12:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
RSI13:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
RSI14:=SMA(MAX(CLOSE-LC,0),15,1)/SMA(ABS(CLOSE-LC),15,1)*100;
RSI15:=SMA(MAX(CLOSE-LC,0),16,1)/SMA(ABS(CLOSE-LC),16,1)*100;
RSI16:=SMA(MAX(CLOSE-LC,0),17,1)/SMA(ABS(CLOSE-LC),17,1)*100;
RSI17:=SMA(MAX(CLOSE-LC,0),18,1)/SMA(ABS(CLOSE-LC),18,1)*100;
RSI18:=SMA(MAX(CLOSE-LC,0),19,1)/SMA(ABS(CLOSE-LC),19,1)*100;
RSI19:=SMA(MAX(CLOSE-LC,0),20,1)/SMA(ABS(CLOSE-LC),20,1)*100;
RSI21:=SMA(MAX(CLOSE-LC,0),21,1)/SMA(ABS(CLOSE-LC),21,1)*100;
RSI30:=SMA(MAX(CLOSE-LC,0),30,1)/SMA(ABS(CLOSE-LC),30,1)*100;
RSI40:=SMA(MAX(CLOSE-LC,0),40,1)/SMA(ABS(CLOSE-LC),40,1)*100;
RSI50:=SMA(MAX(CLOSE-LC,0),50,1)/SMA(ABS(CLOSE-LC),50,1)*100;
RSI60:=SMA(MAX(CLOSE-LC,0),60,1)/SMA(ABS(CLOSE-LC),60,1)*100;
RSI70:=SMA(MAX(CLOSE-LC,0),70,1)/SMA(ABS(CLOSE-LC),70,1)*100;
RSI80:=SMA(MAX(CLOSE-LC,0),80,1)/SMA(ABS(CLOSE-LC),80,1)*100;
RSI90:=SMA(MAX(CLOSE-LC,0),90,1)/SMA(ABS(CLOSE-LC),90,1)*100;
RSI100:=SMA(MAX(CLOSE-LC,0),100,1)/SMA(ABS(CLOSE-LC),100,1)*100;
RSI110:=SMA(MAX(CLOSE-LC,0),110,1)/SMA(ABS(CLOSE-LC),110,1)*100;
RSI120:=SMA(MAX(CLOSE-LC,0),120,1)/SMA(ABS(CLOSE-LC),120,1)*100;
短线RSI:=(RSI1+RSI2+RSI3+RSI4+RSI5)/5,COLORWHITE;
中线RSI:=(RSI6+ RSI7+ RSI8+ RSI9+ RSI10+ RSI11+ RSI12+ RSI13+ RSI14+ RSI15+ RSI16+ RSI17+ RSI18+ RSI19+ RSI21)/15,COLORYELLOW;
长线RSI:=(RSI21+RSI30+RSI40+RSI50+RSI60+RSI70+RSI80+RSI90+RSI100+RSI110+RSI120)/11;
A:=CROSS(短线RSI,中线RSI);
B:=CROSS(中线RSI,短线RSI);
A11:=3*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)-2*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5);
A21:=LLV(L,21);
A31:=LLV(L,30);
A41:=EMA(A11,5);
A51:=(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))*100;
DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
基础:=DIFF<-0.1 AND DIFF>DEA;
中线买入:=CROSS(A11,A41) AND (A51-A41)>40 AND 基础;
STICKLINE(中线买入,0.5,2,1,0),COLORMAGENTA;
DRAWTEXT(中线买入,1.8,'-冲天'),COLORYELLOW;

XX1:=CROSS(((-((100)*(HHV(HIGH,IF((IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1) > 0.35),6,65)) - CLOSE))/(HHV(HIGH,IF((IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1) > 0.35),6,65)) - LLV(LOW,IF((IF((BARSCOUNT(CLOSE) > 7),(100)*((MA(CLOSE,7))/(LLV(MA(CLOSE,7),7)) - 1),1) > 0.35),6,65)))))*((DATE < 20070110)),(-2));
R:=MA(CLOSE,26);
UP:=R + 2*STD(CLOSE,26);
LOWER:=R - 2*STD(CLOSE,26);
W1:=C=HHV(C,20);
W2:=BARSLAST(W1);
W3:=IF(W2>0,REF(C,W2),REF(C,W2));
W4:=CROSS(C,REF(W3,1));
XX2:=IF(W4 AND COUNT(W4,5)=1,20,0);
VAR1:=EMA(C,2);
VARR2:=EMA(SLOPE(C,21)*20+C,42);
XX3:=CROSS(VAR1,VARR2);
STICKLINE((XX1 AND XX2 AND XX3),0.5,2,1,0),COLORMAGENTA;
DRAWTEXT((XX1 AND XX2 AND XX3),1.8,'-牛气'),COLORYELLOW;

VAR2N:=LLV(LOW,3)<=LLV(LOW,60);
VAR3N:=  C>O AND (C/O>1.03 OR C>1.03*REF(C,1));
绝地反击:=IF(VAR2N AND VAR3N,90,0);
STICKLINE(绝地反击,0.5,1,3,0),COLORCYAN;
STICKLINE(绝地反击,0,0.5,3,0),COLORMAGENTA;
DRAWTEXT(绝地反击,0.8,'-独醉'),COLORYELLOW;
来自 江苏省南京市浦口区

举报

使用道具 扔鸡蛋 回复

2463387
Lv.3

专栏

发表于 2017-4-14 19:06 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省无锡市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

0楼
楼主
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表