劳烦大神!写个顶部选股

[通达信] 2652 0
设置
3066102 Lv.2

专栏

发表于 2017-6-6 10:35 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
根据以下的指标。选出金叉后第1次或2.3次出现顶部型号的(最好第几次可以选股时设定或者直接在指标里面改)万分感谢!

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;

{底部信号}
BB值:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
DRAWTEXT(CROSS(BB值,9),0, '   底'),COLORYELLOW;
DRAWICON(CROSS(BB值,9),0,34);
DRAWTEXT(CROSS(90,BB值),0, '   顶'),COLORGREEN;
DRAWICON(CROSS(90,BB值),0,35);



VA1:=HHVBARS(MACD,BARSLAST(MACD<0)+1);
VA2:=CROSS(BACKSET(CROSS(0,MACD) OR (ISLASTBAR AND MACD>0),REF(VA1,1)+2),0.5);
前高:DRAWLINE(VA2,MACD,REF(VA2,1),REF(MACD,1),1),COLORYELLOW,POINTDOT ;
VA3:=LLVBARS(MACD,BARSLAST(MACD>0)+1);
VA4:=CROSS(BACKSET(CROSS(MACD,0) OR (ISLASTBAR AND MACD<0),REF(VA3,1)+2),0.5);
前低:DRAWLINE(VA4,MACD,REF(VA4,1),REF(MACD,1),1),COLORYELLOW,POINTDOT ;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
B1:=REF(C,A1+2)<REF(C,A1+1)<C AND REF(MACD,2)>=REF(MACD,1) AND REF(MACD,1)<=MACD AND MACD<-0.1;
STICKLINE(B1>0,-0.1,0,2,0),COLORMAGENTA;


0,COLORGRAY,DOTLINE;
{RSI买入}
WRSI:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
相对强弱RSI买入:=CROSS(WRSI,20),STICK,LINETHICK2,COLORYELLOW;
{RSI买入:STICKLINE(CROSS(WRSI,20),0,70,0,0),LINETHICK2,COLORYELLOW;}
STICKLINE(相对强弱RSI买入,0-0.1,MACD-0.1,0.3,0),COLORRED;

附件

QQ截图20170606103444.jpg
来自 重庆市

举报

使用道具 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表