请老师看看这两个指标如何优化

[东财通] 5449 3
设置
2937358 Lv.2

专栏

发表于 2017-6-6 16:16 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
我自己编了两个指标,是将日线,60分钟,30分钟,15分钟的KD指标和MACD指标放在了一起,担出现了一个问题,就是使用的时候切换周期时不顺畅,很卡,而使用其他指标时切换周期就很顺畅,一点都不卡。想请老师们帮忙优化一下,或是不同的指标形式有相同效果的指标。谢谢!

日线,60分钟,30分钟,15分钟的KD指标
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1),NODRAW;
D:SMA(K,M2,1),NODRAW;
MIN15K:=KD.K#MIN15;
MIN15D:=KD.D#MIN15;
AMIN15KD:=MIN15K>MIN15D;
BMIN15KD:=MIN15K<MIN15D;
STICKLINE(AMIN15KD,60,80,10,0),COLORLIRED;
STICKLINE(BMIN15KD,60,80,10,1),COLORLIRED;
MIN30K:=KD.K#MIN30;
MIN30D:=KD.D#MIN30;
AMIN30KD:=MIN30K>MIN30D;
BMIN30KD:=MIN30K<MIN30D;
STICKLINE(AMIN30KD,40,60,10,0),COLORLIBLUE;
STICKLINE(BMIN30KD,40,60,10,1),COLORLIBLUE;
MIN60K:=KD.K#MIN60;
MIN60D:=KD.D#MIN60;
AMIN60KD:=MIN60K>MIN60D;
BMIN60KD:=MIN60K<MIN60D;
STICKLINE(AMIN60KD,20,40,10,0),COLORLICYAN;
STICKLINE(BMIN60KD,20,40,10,1),COLORLICYAN;
DAYK:=KD.K#DAY;
DAYD:=KD.D#DAY;
ADAYKD:=DAYK>DAYD;
BDAYKD:=DAYK<DAYD;
STICKLINE(ADAYKD,0,20,10,0),COLORLIMAGENTA;
STICKLINE(BDAYKD,0,20,10,1),COLORLIMAGENTA;


日线,60分钟,30分钟,15分钟的MACD指标
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG),NODRAW;
DEA:EMA(DIF,MID),NODRAW;
MACD:(DIF-DEA)*2,COLORSTICK,NODRAW;
MIN15:=MACD.MACD#MIN15;
MACD15大:=MIN15>0;
MACD15小:=MIN15<0;
MIN15DIF:=MACD.DIF#MIN15;
MIN15DEA:=MACD.DEA#MIN15;
A15:=MIN15DIF>0;
B15:=MIN15DIF<0;
STICKLINE(MACD15大,60,80,10,0),COLORBLUE;
STICKLINE(MACD15小,60,80,10,1),COLORBLUE;
MIN30:=MACD.MACD#MIN30;
MACD30大:=MIN30>0;
MACD30小:=MIN30<0;
MIN30DIF:=MACD.DIF#MIN30;
MIN30DEA:=MACD.DEA#MIN30;
A30:=MIN30DIF>0;
B30:=MIN30DIF<0;
STICKLINE(MACD30大,40,60,10,0),COLORCYAN;
STICKLINE(MACD30小,40,60,10,1),COLORCYAN;
MIN60:=MACD.MACD#MIN60;
MACD60大:=MIN60>0;
MACD60小:=MIN60<0;
MIN60DIF:=MACD.DIF#MIN60;
MIN60DEA:=MACD.DEA#MIN60;
A60:=MIN60DIF>0;
B60:=MIN60DIF<0;
STICKLINE(MACD60大,20,40,10,0),COLORGREEN;
STICKLINE(MACD60小,20,40,10,1),COLORGREEN;
日:=MACD.MACD#DAY;
MACDDAY大:=日>0;
MACDDAY小:=日<0;
DAYDIF:=MACD.DIF#DAY;
DAYDEA:=MACD.DEA#DAY;
ADAY:=DAYDIF>0;
BDAY:=DAYDIF<0;
STICKLINE(MACDDAY大,0,20,10,0),COLORRED;
STICKLINE(MACDDAY小,0,20,10,1),COLORRED;
来自 江苏省常州市

举报

使用道具 扔鸡蛋 回复

3647842
Lv.3

专栏

发表于 2017-6-6 22:14 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省无锡市

举报

使用道具 点亮 支持 扔鸡蛋 回复

2937358
Lv.2

专栏

发表于 2017-6-6 21:07 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省常州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

3647842
Lv.3

专栏

发表于 2017-6-6 17:06 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 江苏省无锡市

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
4楼
3楼
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表