手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

稳赚趋势(指标 主图 通达信 贴图)

[通达信]
设置
32031 18 常怡_28 Lv.5 发表于 · 2017-6-19 16:57 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层

今天在网上闲逛,把一个大智慧的“稳赚趋势”改成通达信的,给想学习源码的同学们分享,不赚小散们的共享币
指标主要是依据股价的10日和20日(参数可以根据自己喜好改)均线为基础,控制K线变色,而其均线也随趋势改变颜色。
结合指标源码看图:
ZJ:EMA(C,10),COLOR0000FF;
HY:EMA(C,20),COLORFF00FF;
IF(ZJ > REF(ZJ,1),ZJ,DRAWNULL),COLORRED,LINETHICK2;
IF(ZJ < REF(ZJ,1),ZJ,DRAWNULL),COLORGREEN,LINETHICK2;
IF(HY > REF(HY,1),HY,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(HY < REF(HY,1),HY,DRAWNULL),COLORBLUE,LINETHICK2;
STICKLINE(CLOSE > ZJ,HIGH,L,0,0),COLORRED;
STICKLINE(CLOSE > ZJ,C,OPEN,2.5,0),COLORRED;
STICKLINE(CLOSE = ZJ,H,L,3,0),COLORWHITE;
STICKLINE(CLOSE < ZJ,H,L,0,0),COLORYELLOW;
STICKLINE(CLOSE < ZJ,O,C,2.5,0),COLORYELLOW;
STICKLINE(CLOSE < HY,OPEN,CLOSE,2.5,0),COLORCYAN;
STICKLINE(CLOSE < HY,HIGH,L,0,0),COLORCYAN;

tu1.png
tu2.png


[ 本帖最后由 常怡_28 于 2017-6-22 14:30 编辑 ]
查看全部打赏
  • 平淡328+3理想币 : 谢谢精彩分享,祝投资愉快!!!

相关股票

举报

扔鸡蛋(0) 回复

玉玉玉玉玉
Lv.2
发表于 2020-6-30 02:01 复制 查看全部楼层
谢谢源码分享

举报

扔鸡蛋(0) 回复

偏爱一个
Lv.4
发表于 2017-9-3 20:55 复制 查看全部楼层
老师,我也有个通达信的指标麻烦你帮我改成做个选股公式:
G0:=(XMA(XMA(H,30),30)-XMA(XMA(L,30),30))+XMA(XMA(H,30),30);
D0:=XMA(XMA(L,30),30)-(XMA(XMA(H,30),30)-XMA(XMA(L,30),30));
G01:=(XMA(XMA(H,30),30)-XMA(XMA(L,30),30))*0.5+XMA(XMA(H,30),30);
D01:=XMA(XMA(L,30),30)-(XMA(XMA(H,30),30)-XMA(XMA(L,30),30))*0.5;
GO0:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3+XMA(XMA(H,60),60);
DO0:=XMA(XMA(L,60),60)-(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3;

STICKLINE(CURRBARSCOUNT=1,G0,G0,100,5),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1,D0,D0,100,5),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=1,GO0,GO0,100,5),COLORLIBLUE;
STICKLINE(CURRBARSCOUNT=1,DO0,DO0,100,5),COLORRED;
DRAWTEXT(ISLASTBAR,G0,'     卖'),COLORGREEN;
DRAWTEXT(ISLASTBAR,D0,'     买'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,GO0,'     顶'),COLORLIBLUE;
DRAWTEXT(ISLASTBAR,DO0,'     底'),COLORRED;
谢谢 !!

举报

点亮(0) 扔鸡蛋(0) 回复

炒股不放糖
Lv.3
发表于 2017-7-19 13:21 复制 查看全部楼层
谢谢!!!

举报

扔鸡蛋(0) 回复

宏基327
Lv.4
发表于 2017-7-19 09:15 复制 查看全部楼层
@常怡_28
谢谢好人!!!!

举报

点亮(0) 扔鸡蛋(0) 回复

常怡_28
Lv.5
发表于 2017-7-14 16:11 复制 查看全部楼层
谢谢朋友们顶帖

举报

扔鸡蛋(0) 回复

一望吴际
Lv.4
发表于 2017-6-26 22:53 复制 查看全部楼层
天天赚钱!

举报

扔鸡蛋(0) 回复

常怡_28
Lv.5
发表于 2017-6-22 14:36 复制 查看全部楼层
原帖由 @股012 于 2017-6-20 23:32 发表
IF(ZJ>REF(ZJ,1),ZJ,DRAWNULL),COLORRED,LINETHICK2;
IF(ZJ<=REF(ZJ,1),ZJ,DRAWNULL),COLORGREEN,LINETHICK2;
IF(HY>REF(HY,1),HY,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(HY<REF(HY,1),HY,DRAWNULL),COLORBLUE,L ...


26楼  @源于开始  33楼  @杰好杰
一楼已重新编辑

举报

点亮(0) 扔鸡蛋(0) 回复

常怡_28
Lv.5
发表于 2017-6-21 15:54 复制 查看全部楼层
原帖由 源于开始 于 2017-6-20 23:45 发表
当前公式 : 稳赚趋势 (指标画线公式)  
错误句 :
IF(ZJ>
详细信息 :  
错误起始位置 : 30 ; 长度: 3
怎么不行呢?


今天不知怎么乱码了,别的网站昨天转过去还是正确的。
外网转贴.png
正在申请重新编辑源码


[ 本帖最后由 常怡_28 于 2017-6-21 16:23 编辑 ]

举报

点亮(0) 扔鸡蛋(0) 回复

晖少zs
Lv.3
发表于 2017-6-21 11:46 复制 查看全部楼层
谢谢老大

举报

扔鸡蛋(0) 回复

源于开始
Lv.1
发表于 2017-6-20 23:45 复制 查看全部楼层
当前公式 : 稳赚趋势 (指标画线公式)  
错误句 :
IF(ZJ&GT
详细信息 :  
错误起始位置 : 30 ; 长度: 3
怎么不行呢?

举报

点亮(0) 扔鸡蛋(0) 回复

股012
Lv.2
发表于 2017-6-20 23:32 复制 查看全部楼层
IF(ZJ&gt;REF(ZJ,1),ZJ,DRAWNULL),COLORRED,LINETHICK2;
IF(ZJ&lt;=REF(ZJ,1),ZJ,DRAWNULL),COLORGREEN,LINETHICK2;
IF(HY&gt;REF(HY,1),HY,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(HY&lt;REF(HY,1),HY,DRAWNULL),COLORBLUE,LINETHICK2;
楼主,这些语句我的通达信怎么通不过啊?

举报

点亮(0) 扔鸡蛋(0) 回复

消遥快活
Lv.2
发表于 2017-6-20 13:41 复制 查看全部楼层
为不要共享币的高风亮节点赞!

举报

扔鸡蛋(0) 回复

超人旺仔
Lv.1
发表于 2017-6-20 10:09 复制 查看全部楼层
现在这个时候不太适用。。

举报

扔鸡蛋(0) 回复

还要走多远
Lv.3
发表于 2017-6-20 08:15 复制 查看全部楼层
两条变色线好用,谢谢!

举报

扔鸡蛋(0) 回复

刘琴2008
Lv.3
发表于 2017-6-19 17:22 复制 查看全部楼层
谢谢源码分享

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表