请老师做一个选股公式(已解答:竹隐风雷)

[通达信] 2515 1
设置
3592264 Lv.4

专栏

发表于 2017-7-2 20:03 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
TIM截图20170702194704.png
一牛马线主图
EXP1:EXPMA(CLOSE,M1),LINETHICK2,COLORRED;
DRAWTEXT(CROSS(CLOSE,EXP1),EXP1,'买入'),COLORYELLOW;{收盘价>生命线=买入};
DRAWTEXT(CROSS(EXP1,CLOSE),EXP1,'卖出');{收盘价<生命线=卖出};

HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
牛线:(20*HHJSJDA+19*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/211,COLORYELLOW;
马线:MA(牛线,5),COLORRED;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(涨停,H,L,0,0),COLORMAGENTA;
二选股
YFLZTA:=(46.18*EMA(CLOSE,3)-31.82*EMA(CLOSE,4))/14.36;
YFLZTB:=SUM(VOL*CLOSE,5)/SUM(VOL,5);
YFLZTC:=EMA(YFLZTB,15);
YFLZTD:=CLOSE*VOL;
YFLZTE:=EMA((EXPMA(YFLZTD,3)/EXPMA(VOL,3)+EXPMA(YFLZTD,6)/EXPMA(VOL,6)+EXPMA(YFLZTD,12)/EXPMA(VOL,12)+EXPMA(YFLZTD,24)/EXPMA(VOL,24))/4,13);
YFLZTF:=0.99*YFLZTE;
YFLZTG:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
YFLZTH:=COUNT(YFLZTG,15)>=1;
QQ:REF(CROSS(YFLZTC,YFLZTA),1) AND CROSS(C,YFLZTF) AND YFLZTH;
请老师在选股公式上在添加,1,牛线大于马线,2,MACD红柱变长或绿柱变短

[ 本帖最后由 任刚 于 2017-7-4 07:49 编辑 ]

举报

使用道具 扔鸡蛋 回复

2998320
Lv.3

专栏

发表于 2017-7-2 21:01 复制 查看全部楼层
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
  • 任刚+10理想币 +5共享币 : 赠人玫瑰之手,经久犹有余香!
查看全部打赏

举报

使用道具 点亮 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
2楼
站长推荐 /8
回顶部 到页底
快速回复 返回顶部 返回列表