发新话题
引用:
原帖由 @工具2018 于 2018-1-13 23:11 发表
求助老师:如何在K线上显示每天指标数字.
例,KDJ的J值..在上面显示这个J值 在K线上
其它不显示..
谢谢!    
在K线指标最后加这一行
J值:KDJ.J,NODRAW;
  • 2018-1-15 10:47 理想币 +10 任刚: 赠人玫瑰之手,经久犹有余香!
发消息 加好友
积分
21879 
理想币
14065 个 
彩币
493 个 
共享币
7551 个 
注册时间
2013-5-11 

复制

引用:
原帖由 @阿宝哦 于 2018-1-13 23:42 发表

在K线指标最后加这一行
J值:KDJ.J,NODRAW;
7969367    
老师,希望在K线图上显示每天的J值数字。谢谢老师!
发消息 加好友
积分
12148 
理想币
8092 个 
彩币
1232 个 
共享币
1365 个 
注册时间
2012-11-27 

复制

引用:
原帖由 @阿宝哦 于 2018-1-13 23:42 发表

在K线指标最后加这一行
J值:KDJ.J,NODRAW;
7969367    
希望跟您发的主图形式一样的表达方式。
发消息 加好友
积分
12148 
理想币
8092 个 
彩币
1232 个 
共享币
1365 个 
注册时间
2012-11-27 

复制

引用:
原帖由 @工具2018 于 2018-1-13 23:59 发表

希望跟您发的主图形式一样的表达方式。    

然后调用你所修改的公式即可。

[ 本帖最后由 阿宝哦 于 2018-1-14 00:21 编辑 ]
发消息 加好友
积分
21879 
理想币
14065 个 
彩币
493 个 
共享币
7551 个 
注册时间
2013-5-11 

复制

引用:
原帖由 @阿宝哦 于 2018-1-14 00:20 发表

7969379
然后调用你所修改的公式即可。    
谢谢阿宝老师!
发消息 加好友
积分
12148 
理想币
8092 个 
彩币
1232 个 
共享币
1365 个 
注册时间
2012-11-27 

复制

引用:
原帖由 @阿宝哦 于 2018-1-14 00:20 发表

7969379
然后调用你所修改的公式即可。    
谢谢老师。按你方法,还是J值不显示在主图K线上。

附件:

30.JPG (126.64 KB)

2018-1-14 09:20

30.JPG

发消息 加好友
积分
12148 
理想币
8092 个 
彩币
1232 个 
共享币
1365 个 
注册时间
2012-11-27 

复制

回复 5楼 @阿宝哦 的帖子

@阿宝哦 VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3*VAR6-2*VAR7;
VAR1A:=IF(CROSS(VAR6,VAR8) AND CROSS(VAR7,VAR8) AND CROSS(VAR7,VAR6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:IF(VAR1D>0.015,VAR1F,0)/45,COLORMAGENTA;
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
主力资金:POW(VAR11,3)*0.1+POW(VAR11,1),COLORRED;
0,COLORYELLOW;



做一个紫色线出现时的选股公式可以吗老师
发消息 加好友
积分
650 
理想币
42 个 
彩币
5 个 
共享币
192 个 
注册时间
2015-6-10 

复制

引用:
原帖由 @工具2018 于 2018-1-14 09:20 发表

谢谢老师。按你方法,还是J值不显示在主图K线上。    
发消息 加好友
积分
21879 
理想币
14065 个 
彩币
493 个 
共享币
7551 个 
注册时间
2013-5-11 

复制

引用:
原帖由 @士123我 于 2018-1-14 10:14 发表
阿宝哦 VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3* ...    
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
CROSS(VAR1D,0.015);

附件:

QQ截图20180115020324.png (27.62 KB)

2018-1-15 02:05

QQ截图20180115020324.png

发消息 加好友
积分
21879 
理想币
14065 个 
彩币
493 个 
共享币
7551 个 
注册时间
2013-5-11 

复制

回复 10楼 @阿宝哦 的帖子

@阿宝哦 预警:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK2,COLORGREEN;
操盘:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK2,COLORRED;
趋势:EMA(操盘,25),LINETHICK2;
STICKLINE(操盘>LOW AND 操盘<HIGH,操盘,MIN(MIN(OPEN,CLOSE),操盘),4,0),COLORYELLOW;
STICKLINE(操盘>MIN(C,O) AND 操盘<MAX(C,O),操盘,MIN(OPEN,CLOSE),4,0),COLORYELLOW;
STICKLINE(操盘>HIGH,OPEN,CLOSE,4,0),COLORYELLOW;
STICKLINE(操盘>HIGH,HIGH,LOW,0,0),COLORYELLOW;
VAR23:=100*XMA(XMA((C-REF(C,1)),6),6)/XMA(XMA(ABS((C-REF(C,1))),6),6);
回调买:=LLV(VAR23,2)==LLV(VAR23,7) AND COUNT(VAR23<0,2) AND CROSS(VAR23,MA(VAR23,2));
XG:=操盘>HIGH AND 回调买 AND L<=操盘;
DRAWTEXT(XG,L,'▲买入'),COLORRED;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IFF(HIGH==LOW,4,HIGH-LOW);
QJ1:=IFF(CAPITAL==0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IFF(HIGH==LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IFF(CAPITAL==0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IFF(HIGH==LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IFF(CAPITAL==0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IFF(HIGH==LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IFF(CAPITAL==0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IFF(HIGH==LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IFF(CAPITAL==0,10000,10000),COLOR00AAAA,LINETHICK1;
V2:=SMA(IFF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*120/FROMOPEN*5,2,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
DY:=ISLASTBAR==1 AND C<REF(C,1);
DY2:=REF(V2,1)-DY;
XG2:=C>O AND DY2<0.02 AND MA(C,5)>MA(C,60) AND C/REF(C,1)>=1.02 AND H<预警;
DRAWTEXT(XG2 AND L<操盘,L,'↖暴涨'),COLORRED;
黄金坑:IFF(LOW<操盘,1,0),NODRAW,COLORYELLOW;
买入:IFF(XG,1,0),NODRAW,COLORRED;
暴涨:IFF(XG2 AND L<操盘,1,0),NODRAW,COLORRED;买入做个选股公式
发消息 加好友
积分
650 
理想币
42 个 
彩币
5 个 
共享币
192 个 
注册时间
2015-6-10 

复制

引用:
原帖由 @士123我 于 2018-1-15 12:06 发表
阿宝哦 预警:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),LINETHICK2,COLORGREEN;
操盘:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK2,COLORRED;
趋势:EMA(操盘,25),LI ...    
操盘:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1;
VAR23:=100*XMA(XMA((C-REF(C,1)),6),6)/XMA(XMA(ABS((C-REF(C,1))),6),6);
回调买:=LLV(VAR23,2)==LLV(VAR23,7) AND COUNT(VAR23<0,2) AND CROSS(VAR23,MA(VAR23,2));
XG:操盘>HIGH AND 回调买 AND L<=操盘;
发消息 加好友
积分
21879 
理想币
14065 个 
彩币
493 个 
共享币
7551 个 
注册时间
2013-5-11 

复制

回复 12楼 @阿宝哦 的帖子

@阿宝哦 有未来函数吗
发消息 加好友
积分
650 
理想币
42 个 
彩币
5 个 
共享币
192 个 
注册时间
2015-6-10 

复制

引用:
原帖由 @士123我 于 2018-1-15 12:25 发表
阿宝哦 有未来函数吗    
有!
发消息 加好友
积分
21879 
理想币
14065 个 
彩币
493 个 
共享币
7551 个 
注册时间
2013-5-11 

复制

发新话题
理想论坛 » 指标编写互助答疑区 » 求助老师:如何在K线上显示每天指标数字
指标编写互助答疑区:积分规则

快速回复主题

选项

发帖请务遵守本站的相关规则,所有发表(包括转发)政治、色情非法信息者本站将实时提供发贴者个人信息给公安局,追究责任,特此申明!
具体规则请参见 理想论坛会员守则》 《净化论坛环境,打击恶意灌水》。

您需要登录后才可以发帖

[完成后可按 Ctrl+Enter 发布]

理想论坛上的网友发表的帖子纯属个人意见,理想论坛不负任何责任!广告赞助商内容与本站无关!免责声明
理想论坛值班电话[9:30~18:30]: ☎ 400 016 5518-1 ☎ 186 4906 9487(广告)187 1028 6081(广告)
找回密码 软件区:1006648222 百宝箱: 1006267111 广告: 1006269111 广告: 3145821447
诚信档案编号:CX20150604010215010383 信誉编号:TL852015042710940
工业和信息化部信息备案: 京ICP备15035364号 京ICP证151057号
关闭底部 打开底部 回顶部 到页底 理想论坛微信号:lixiang55188 扫描下载理想选股App
关闭
关闭