23 12
发新话题

回复 楼主 @海角麦穗 的帖子

@海角麦穗 幅制上了就可以用啊
发消息 加好友
积分
3992 
理想币
1646 个 
彩币
0 个 
共享币
742 个 
注册时间
2016-12-10 

复制

回复 2楼 @清心a 的帖子

@清心a 当前公式 : 控盘 (指标画线公式)  
错误句 :
无庄控盘:IF(主力控盘.控盘程度<0,主力控盘.控盘程度,0),COLORWHITE
详细信息 : 某个操作数没有相应的操作符匹配!
错误起始位置 : 119 ; 长度: 5
发消息 加好友
积分
6261 
理想币
47 个 
彩币
5 个 
共享币
5431 个 
注册时间
2012-12-20 

复制

VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,控盘,0,1,0),COLORWHITE;
A10:=CROSS(控盘,0);
无庄控盘:IF(主力控盘.控盘程度<0,主力控盘.控盘程度,0),COLORWHITE;
开始控盘:IF(A10,5,0),LINETHICK1,COLORYELLOW;
STICKLINE(主力控盘.控盘程度>REF(主力控盘.控盘程度,1) AND 主力控盘.控盘程度>0,主力控盘.控盘程度,0,8,0),COLORRED;
有庄控盘:IF(主力控盘.控盘程度>REF(主力控盘.控盘程度,1) AND 主力控盘.控盘程度>0,主力控盘.控盘程度,0),COLORRED;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 主力控盘.控盘程度>0,主力控盘.控盘程度,0,8,0),COLORFF00FF;
高度控盘:IF(VAR2>50 AND COST(85)<CLOSE AND 主力控盘.控盘程度>0,主力控盘.控盘程度,0),COLORFF00FF;
STICKLINE(主力控盘.控盘程度<REF(主力控盘.控盘程度,1) AND 主力控盘.控盘程度>0,主力控盘.控盘程度,0,8,0),COLOR00FF00;
主力出货:IF(主力控盘.控盘程度<REF(主力控盘.控盘程度,1) AND 主力控盘.控盘程度>0,主力控盘.控盘程度,0),COLOR00FF00;
发消息 加好友
积分
3992 
理想币
1646 个 
彩币
0 个 
共享币
742 个 
注册时间
2016-12-10 

复制

回复 3楼 @海角麦穗 的帖子

@海角麦穗 看到了吗
发消息 加好友
积分
3992 
理想币
1646 个 
彩币
0 个 
共享币
742 个 
注册时间
2016-12-10 

复制

回复 3楼 @海角麦穗 的帖子

@海角麦穗看看这个,瞎能的。 V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:=EMA(V11,3),LINETHICK2,COLORLIMAGENTA;
V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*100;
准备现金:= STICKLINE(趋势线<=13,0,20,5,0),COLORCC9900;
AA:=(趋势线<=13) AND FILTER((趋势线<=13),15);
DRAWTEXT (AA,0,'准备现金'),COLORCC9900;
买入股票:= STICKLINE(趋势线<=13 AND V12>13,0,50,5,0),COLOR0099FF;
BB:= (趋势线<=13 AND V12>13) AND FILTER((趋势线<=13 AND V12>13),10) ;
DRAWTEXT (BB,0,'买入股票'),COLOR0099FF;
见顶清仓:=STICKLINE(趋势线>=90 AND V12,0,30,5,0),COLORRED;
CC:=(趋势线>=90 AND V12) AND FILTER((趋势线>=90 AND V12),10);
DRAWTEXT (CC,100-10,'见顶清仓'),COLOR0099FF;
VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,控盘,0,1,0),COLORWHITE;
A10:=CROSS(控盘,0);
无庄控盘:IF(主力控盘.控盘程度<0,主力控盘.控盘程度,0),COLORWHITE;
ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//散户套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}
ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}
ZSHJJ:=EMA(ZSHTL,89);{//散户警戒}
ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
{散户套牢筹码}
STICKLINE(C>0,ZSHTL,ZZLKP,0,0),COLOREEEEEE;
{散户筹码警戒}
STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,1,0),COLORAAAAAA;
{主力控盘筹码}
STICKLINE(C>0,ZZLKP,0,0,0),COLORBLUE;
{铸顶风险区}
STICKLINE(ZZLKP>75,ZZLKP,0,2,0),COLORFFFFFF;
{顶部:(ZZLKP>75),COLORFFFFFF;}
{主力筹码警戒}
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,4,0),COLORRED;
{筑底散兵坑}
STICKLINE(ZSHTL>=90,ZZLKP,0,5,0),COLOR66FFCC;
{底部:(ZSHTL>=90),COLOR66FFCC;}
IF(ZCMZL,ZCMZL>REF(ZCMZL,1),DRAWNULL),COLOR0066FF,LINETHICK1;
{增量资金};
散户套牢系数:INTPART(ZSHTL),COLORYELLOW;
主力控盘系数:INTPART(ZZLKP),COLORCYAN;
资金流入强度:ZJLRQD,LINETHICK2,COLORRED;
市场筹码总量:INTPART(ZCMZL),COLORWHITE,NODRAW;
轴:50,COLORGREEN,DOTLINE,LINETHICK1;
DRAWTEXT(CROSS(主力控盘系数,轴),轴+10,'高度控盘'),COLORYELLOW;
MID := (HIGH+LOW+CLOSE)/3;
CR:=SUM(MAX(0,HIGH-REF(MID,1)),20)/SUM(MAX(0,REF(MID,1)-LOW),20)*100;
A线:=REF(MA(CR,10),5);
MA2:=REF(MA(CR,20),9);
DRAWTEXT(CR>160 AND A线>160,轴+25,'顶'),COLORYELLOW;
DRAWTEXT(CR<60 AND A线<60,0-1,'底'),COLORYELLOW;
{STICKLINE(CR<60 AND A线<60,0,5,5,0),COLORRED;}
STICKLINE(CR>160 AND A线>160,散户套牢系数+5,散户套牢系数,5,0);
发消息 加好友
积分
3992 
理想币
1646 个 
彩币
0 个 
共享币
742 个 
注册时间
2016-12-10 

复制

回复 4楼 @清心a 的帖子

@清心a VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3*VAR6-2*VAR7;
VAR1A:=IF(CROSS(VAR6,VAR8) AND CROSS(VAR7,VAR8) AND CROSS(VAR7,VAR6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:IF(VAR1D>0.015,VAR1F,0)/45,COLORMAGENTA;
VAR9:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR10:=EMA(VAR9,13);
VAR11:=2*(VAR9-VAR10);
主力资金:POW(VAR11,3)*0.1+POW(VAR11,1),COLORRED;
0,COLORYELLOW;



做一个紫色线的选股公式可以吗老师
发消息 加好友
积分
650 
理想币
42 个 
彩币
5 个 
共享币
192 个 
注册时间
2015-6-10 

复制

回复 6楼 @清心a 的帖子

@清心a 老师好!通达信通不过,我就想要通达信可以用的
发消息 加好友
积分
6261 
理想币
47 个 
彩币
5 个 
共享币
5431 个 
注册时间
2012-12-20 

复制

VAR1:=(HIGH+LOW+CLOSE*2)/4;
VAR2:=EMA(VAR1,21);
VAR3:=STD(VAR1,21);
VAR4:=((VAR1-VAR2)/VAR3*100+200)/4;
VAR5:=(EMA(VAR4,89)-25)*1.56;
VAR6:=EMA(VAR5,5)*1.22;
VAR7:=EMA(VAR6,3);
VAR8:=3*VAR6-2*VAR7;
VAR1A:=IF(CROSS(VAR6,VAR8) AND CROSS(VAR7,VAR8) AND CROSS(VAR7,VAR6),1,0);
VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
拉升资金:VAR1D>0.015;
发消息 加好友
积分
450 
理想币
248 个 
彩币
0 个 
共享币
50 个 
注册时间
2017-12-2 

复制

回复 8楼 @海角麦穗 的帖子

@海角麦穗 我就是用的通达信的啊
发消息 加好友
积分
3992 
理想币
1646 个 
彩币
0 个 
共享币
742 个 
注册时间
2016-12-10 

复制

回复 7楼 @士123我 的帖子

@士123我 你这一个不如看操盘线直观,MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210;
马线:MA(牛线,25),COLORGREEN;
MA55:MA(C,55),COLORGREEN;
IF(牛线>=REF(牛线,1),牛线,DRAWNULL),COLORRED,LINETHICK2;
IF(牛线<=REF(牛线,1),牛线,DRAWNULL),COLORGREEN,LINETHICK2;
IF(马线>=REF(马线,1),马线,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(马线<=REF(马线,1),马线,DRAWNULL),COLORGREEN,LINETHICK2;
IF(MA55>=REF(MA55,1),MA55,DRAWNULL),COLORCYAN,LINETHICK2;
IF(MA55<=REF(MA55,1),MA55,DRAWNULL),COLORGREEN,LINETHICK2;
发消息 加好友
积分
3992 
理想币
1646 个 
彩币
0 个 
共享币
742 个 
注册时间
2016-12-10 

复制

回复 10楼 @清心a 的帖子

@清心a l老师早上好!我的通达信就是通不过
发消息 加好友
积分
6261 
理想币
47 个 
彩币
5 个 
共享币
5431 个 
注册时间
2012-12-20 

复制

回复 12楼 @海角麦穗 的帖子

@海角麦穗 怎么提示的
发消息 加好友
积分
3992 
理想币
1646 个 
彩币
0 个 
共享币
742 个 
注册时间
2016-12-10 

复制

回复 13楼 @清心a 的帖子

@清心a 当前公式 : 控盘 (指标画线公式)  
错误句 :
无庄控盘:IF(主力控盘.控盘程度<0,主力控盘.控盘程度,0),COLORWHITE
详细信息 : 某个操作数没有相应的操作符匹配!
错误起始位置 : 119 ; 长度: 5
发消息 加好友
积分
6261 
理想币
47 个 
彩币
5 个 
共享币
5431 个 
注册时间
2012-12-20 

复制

回复 14楼 @海角麦穗 的帖子

@海角麦穗 句后少个;
发消息 加好友
积分
3992 
理想币
1646 个 
彩币
0 个 
共享币
742 个 
注册时间
2016-12-10 

复制

回复 15楼 @清心a 的帖子

@清心a 公式里有,不知道最后显示没有,我不懂截图
发消息 加好友
积分
6261 
理想币
47 个 
彩币
5 个 
共享币
5431 个 
注册时间
2012-12-20 

复制

回复 16楼 @海角麦穗 的帖子

@海角麦穗 在幅制一次
发消息 加好友
积分
3992 
理想币
1646 个 
彩币
0 个 
共享币
742 个 
注册时间
2016-12-10 

复制

回复 17楼 @清心a 的帖子

@清心a VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,控盘,0,1,0),COLORWHITE;
A10:=CROSS(控盘,0);
无庄控盘:IF(主力控盘.控盘程度<0,主力控盘.控盘程度,0),COLORWHITE;
开始控盘:IF(A10,5,0),LINETHICK1,COLORYELLOW;
STICKLINE(主力控盘.控盘程度>REF(主力控盘.控盘程度,1) AND 主力控盘.控盘程度>0,主力控盘.控盘程度,0,8,0),COLORRED;
有庄控盘:IF(主力控盘.控盘程度>REF(主力控盘.控盘程度,1) AND 主力控盘.控盘程度>0,主力控盘.控盘程度,0),COLORRED;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 主力控盘.控盘程度>0,主力控盘.控盘程度,0,8,0),COLORFF00FF;
高度控盘:IF(VAR2>50 AND COST(85)<CLOSE AND 主力控盘.控盘程度>0,主力控盘.控盘程度,0),COLORFF00FF;
STICKLINE(主力控盘.控盘程度<REF(主力控盘.控盘程度,1) AND 主力控盘.控盘程度>0,主力控盘.控盘程度,0,8,0),COLOR00FF00;
主力出货:IF(主力控盘.控盘程度<REF(主力控盘.控盘程度,1) AND 主力控盘.控盘程度>0,主力控盘.控盘程度,0),COLOR00FF00;

当前公式 : 控盘 (指标画线公式)  
错误句 :
无庄控盘:IF(主力控盘.控盘程度<0,主力控盘.控盘程度,0),COLORWHITE
详细信息 : 某个操作数没有相应的操作符匹配!
错误起始位置 : 119 ; 长度: 5
发消息 加好友
积分
6261 
理想币
47 个 
彩币
5 个 
共享币
5431 个 
注册时间
2012-12-20 

复制

回复 18楼 @海角麦穗 的帖子

@海角麦穗 你幅制一下18楼你发的这个进去试试,我刚试了可以啊
发消息 加好友
积分
3992 
理想币
1646 个 
彩币
0 个 
共享币
742 个 
注册时间
2016-12-10 

复制

回复 19楼 @清心a 的帖子

@清心a 我的不行,不知道是什么原因
发消息 加好友
积分
6261 
理想币
47 个 
彩币
5 个 
共享币
5431 个 
注册时间
2012-12-20 

复制

后一页【ctrl+“→”】 【ctrl+“←”】前一页 还有1页内容,点此下一页
 23 12
发新话题
理想论坛 » 指标编写互助答疑区 » 求助老师给下面经传指标改成通达信可用,谢谢!
指标编写互助答疑区:积分规则

快速回复主题

选项

发帖请务遵守本站的相关规则,所有发表(包括转发)政治、色情非法信息者本站将实时提供发贴者个人信息给公安局,追究责任,特此申明!
具体规则请参见 理想论坛会员守则》 《净化论坛环境,打击恶意灌水》。

您需要登录后才可以发帖

[完成后可按 Ctrl+Enter 发布]

理想论坛上的网友发表的帖子纯属个人意见,理想论坛不负任何责任!广告赞助商内容与本站无关!免责声明
理想论坛值班电话[9:30~18:30]: ☎ 400 016 5518-1 ☎ 186 4906 9487(广告)187 1028 6081(广告)
找回密码 软件区:1006648222 百宝箱: 1006267111 广告: 1006269111 广告: 3145821447
诚信档案编号:CX20150604010215010383 信誉编号:TL852015042710940
工业和信息化部信息备案: 京ICP备15035364号 京ICP证151057号
关闭底部 打开底部 回顶部 到页底 理想论坛微信号:lixiang55188 扫描下载理想选股App
关闭
关闭