手机版 官方微博
官方微信
扫描关注:理想财富微信公众号
理想论坛App
扫描下载理想论坛App
RSS

缠论严格线段指标

[其他股软]
设置
34866 27 理想66ff30 Lv.2 发表于 · 2018-3-13 22:07 举报 显示全部楼层 复制 正序浏览 |
跳转到指定楼层
分享个缠论严格线段指标

举报

扔鸡蛋(0) 回复

廖伟良
Lv.0
发表于 2020-8-2 15:43 复制 查看全部楼层
学习一下,对指标很感兴趣

举报

扔鸡蛋(0) 回复

悦目神
Lv.0
发表于 2020-3-21 17:30 复制 查看全部楼层

STICKLINE(C>=O ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(C>=O ,OPEN,CLOSE,3.1,0 ),COLOR000033;
STICKLINE(C>=O,OPEN,CLOSE,2.7,0 ),COLOR000066;
STICKLINE(C>=O ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(C>=O ,OPEN,CLOSE,1.5,0 ),COLOR0000CC;
STICKLINE(C>=O ,OPEN,CLOSE,0.9,0 ),COLOR0000FF;
STICKLINE(C>=O ,OPEN,CLOSE,0.3,0 ),COLORCC66FF;

STICKLINE(C<O ,OPEN,CLOSE,3.1,0 ),COLOR990000;
STICKLINE(CLOSE<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE<O ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE<O ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE<O ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE<O ,OPEN,CLOSE,0.3,0 ),COLORCYAN;


HIGHN:=10;
AA:=REF(C,HIGHN)=HHV(C,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND C=HHV(C,HIGHN+1);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(C,DDD),C);
DINGBU1:=REF(DINGBU,DDD+1);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+10);
LOWN:=10;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
DD1:=BARSLAST(CC1);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);

{短T}
ZZ:=5;
AC:=REF(C,ZZ)=HHV(C,2*ZZ+1);
AD:=BACKSET(AC,ZZ+1);
AE:=FILTER(AD,ZZ) AND C=HHV(C,ZZ+1);
AF:=BARSLAST(AE);
AG:=IF(AE,CURRBARSCOUNT,0);
AH:=IF(AF,REF(C,AF),C);
AI:=IF(AF,REF(AG,AF),AG);
AL:=CONST(AI);
短T:DRAWLINE(CURRBARSCOUNT=AL,C,ISLASTBAR,REF(C,AL-1),1),DOTLINE,COLORMAGENTA,LINETHICK2;
T线:DRAWLINE(CURRBARSCOUNT=GDCS1,C,ISLASTBAR,REF(C,GDCS1-1),1)DOTLINE,COLORMAGENTA,LINETHICK2;
过T:IF(CROSS(C,T线),T线,DRAWNULL),CIRCLEDOT,COLORYELLOW;
线5:MA(CLOSE,5),COLORMAGENTA,LINETHICK1;
度5:=ATAN((线5/REF(线5,1)-1)*100)*180/3.1416,NODRAW,COLORMAGENTA;
{IF(度5>44,线54,DRAWNULL),LINETHICK2,COLORWHITE;}
线10:MA(CLOSE,10),COLORGREEN,LINETHICK1;
度8:=ATAN((线10/REF(线10,1)-1)*100)*180/3.1416,NODRAW,COLORGREEN;
{IF(度10>30,线10,DRAWNULL),LINETHICK2,COLORMAGENTA;}

XG:=CROSS(线5,线10);
DRAWICON(XG,H*1.01,29);



线21:MA(CLOSE,21),COLORWHITE,LINETHICK1;
度20:ATAN((线21/REF(线21,1)-1)*100)*180/3.1416,NODRAW,COLORWHITE;
IF(度20>30,线21,DRAWNULL),LINETHICK0,COLORWHITE;
MA30:=MA(CLOSE,30),LINETHICK0,COLORYELLOW;
MA55:MA(CLOSE,55),COLORRED,LINETHICK1;
跌55:IF(MA55<=REF(MA55,1),MA55,DRAWNULL),COLORGREEN,LINETHICK1;
度55:ATAN((MA55/REF(MA55,1)-1)*100)*180/3.1416,NODRAW,COLORRED;
IF(度55>20,MA55,DRAWNULL),LINETHICK3,COLORRED;
MA120:=MA(CLOSE,120),COLORYELLOW,LINETHICK0;
MA250:MA(CLOSE,250),COLORBLUE,LINETHICK0;

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLOR00C0C0;

STICKLINE(CLOSE>REF(CLOSE,1)*1.097 AND C>O ,OPEN,CLOSE,1,0 ),COLORYELLOW;
STICKLINE(CLOSE*1.1<REF(CLOSE,1) AND C<O ,OPEN,CLOSE,1,0 ),COLORGREEN;
CY20X:=(REF(CLOSE,1)<REF(线21,1) OR OPEN<REF(线21,1)) AND CLOSE>线21 AND 线21>MA55 AND CLOSE>REF(HIGH,1);
CY60X:=(REF(CLOSE,1)<REF(MA55,1) OR OPEN<REF(MA55,1)) AND CLOSE>MA55 ;
STICKLINE(CY20X,CLOSE,OPEN,1.7,0),COLORMAGENTA;
STICKLINE(CY60X,CLOSE,OPEN,0.5,0),COLORWHITE;
上轨:EMA(REF(HHV(HIGH,30),1),2),COLORBROWN,DOTLINE,LINETHICK1;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
DRAWTEXT(买1>0 OR 买2>0,LOW*0.96,'买'),COLORGREEN;
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,1);
DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.94,''),LINETHICK1,COLORFF00FF;

举报

扔鸡蛋(0) 回复

前游客
Lv.4
发表于 2020-1-15 22:04 复制 查看全部楼层
第一图不像缠论线段,第二张图还行。不按笔划线段不完美

举报

点亮(0) 扔鸡蛋(0) 回复

游戏零零
Lv.2
发表于 2020-1-15 18:24 复制 查看全部楼层
看看来的计回归

举报

扔鸡蛋(0) 回复

和先生
Lv.2
发表于 2019-10-15 20:15 复制 查看全部楼层
年累计回归

举报

扔鸡蛋(0) 回复

股三多A
Lv.4
发表于 2019-10-11 14:11 复制 查看全部楼层
没有呀~~~~~~·你可以吧指标放在网盘里呀~~~~~~~~

举报

点亮(0) 扔鸡蛋(0) 回复

阿多与阿空
Lv.2
发表于 2019-10-11 13:49 复制 查看全部楼层
没找到下载附件

举报

扔鸡蛋(0) 回复

张杨91
Lv.2
发表于 2019-10-11 10:37 复制 查看全部楼层
好好好好好好好好好好好

举报

扔鸡蛋(0) 回复

思念的纯度
Lv.6
发表于 2018-8-30 08:58 复制 查看全部楼层
谢谢

举报

扔鸡蛋(0) 回复

金重
Lv.4
发表于 2018-5-20 22:54 复制 查看全部楼层
什么意思?

举报

扔鸡蛋(0) 回复

理想b758ba
Lv.3
发表于 2018-5-20 19:47 复制 查看全部楼层
楼主的东西看不到

举报

扔鸡蛋(0) 回复

王智wt
Lv.4
发表于 2018-3-17 17:11 复制 查看全部楼层
什么意思?

举报

扔鸡蛋(0) 回复

理想70ab7f
Lv.2
发表于 2018-3-17 15:35 复制 查看全部楼层
楼主挂两张不明情况的图片?

举报

扔鸡蛋(0) 回复

股之鲨
Lv.4
发表于 2018-3-17 14:01 复制 查看全部楼层
什么都看不到 @理想66ff30

举报

点亮(0) 扔鸡蛋(0) 回复

理想c26202
Lv.1
发表于 2018-3-16 22:37 复制 查看全部楼层
看不到图片,谢谢!

举报

扔鸡蛋(0) 回复

天凤神龙
Lv.4
发表于 2018-3-15 22:24 复制 查看全部楼层
图片挂了啊

举报

扔鸡蛋(0) 回复

赢富021
Lv.4
发表于 2018-3-14 19:48 复制 查看全部楼层
看不到图片,网盘链接应该可以分享

举报

扔鸡蛋(0) 回复

我是天天的
Lv.1
发表于 2018-3-14 10:20 复制 查看全部楼层
看不到东西

举报

扔鸡蛋(0) 回复

贤齐
Lv.7
发表于 2018-3-14 09:28 复制 查看全部楼层
看不到图片,网盘链接应该可以分享

举报

扔鸡蛋(0) 回复

理想66ff30
Lv.2
发表于 2018-3-14 08:52 复制 查看全部楼层
@好人一等  我传不了文件,图片上画的就是指标自动生成的,有联系方式

举报

点亮(0) 扔鸡蛋(0) 回复

理想66ff30
Lv.2
发表于 2018-3-14 08:52 复制 查看全部楼层
@阿良88  我传不了文件,图片上画的就是指标自动生成的,有联系方式

举报

点亮(0) 扔鸡蛋(0) 回复

理想66ff30
Lv.2
发表于 2018-3-14 08:51 复制 查看全部楼层
@鑫国 我传不了文件,图片上画的就是指标自动生成的,有联系方式

举报

点亮(0) 扔鸡蛋(0) 回复

风季
Lv.4
发表于 2018-3-14 08:41 复制 查看全部楼层
没见指标啊

举报

扔鸡蛋(0) 回复

好人一等
Lv.4
发表于 2018-3-14 08:35 复制 查看全部楼层
什么意思?

举报

扔鸡蛋(0) 回复

阿良88
Lv.3
发表于 2018-3-14 08:25 复制 查看全部楼层
什么意思?

举报

扔鸡蛋(0) 回复

鑫国
Lv.5
发表于 2018-3-14 05:56 复制 查看全部楼层
楼主挂两张不明情况的图片?

举报

扔鸡蛋(0) 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

论坛问题
微信扫一扫,添加好友咨询
驿站问题
微信扫一扫,添加好友咨询
广告投放
微信扫一扫,添加好友咨询
回顶部 到页底
快速回复 返回顶部 返回列表