发新话题

回复 楼主 @每天一涨 的帖子

@每天一涨   这个可以直接用作选股啊。  在条件选股公式中建就行啦。

[ 本帖最后由 我注册啦 于 2018-6-14 16:08 编辑 ]

附件:

yw.PNG (50.38 KB)

2018-6-14 16:08

yw.PNG

发消息 加好友
积分
4982 
理想币
62 个 
彩币
0 个 
共享币
15 个 
注册时间
2008-9-30 

复制

哪种情况下选股呢
发消息 加好友
积分
1948 
理想币
1202 个 
彩币
0 个 
共享币
607 个 
注册时间
2017-11-29 

复制

回复 楼主 @每天一涨 的帖子

@每天一涨   看错了,这个行:




好线:=38;
平线:=5;
OK:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;
RSI2:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;
鱼:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;
RSI4:=SMA(鱼,7,1);
趋势A:=MA(((CLOSE-LLV(LOW,48))/(HHV(HIGH,48)-LLV(LOW,48))*50),17)+9;
趋势B:=MA(((CLOSE-LLV(LOW,53))/(HHV(HIGH,53)-LLV(LOW,53))*50),17)+9;
趋势C:=EMA(((CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*50),17)+18;
A1:=MA(趋势A,7)*1.372;
A2:=A1*1.0887;
A3:=(1.5*(趋势B+RSI4)-(A2+A1))+12;
鱼网:IF((CROSS(RSI2,RSI4) OR CROSS(RSI2,A3) AND A3<好线 AND RSI1<平线),48,38);
  • 2018-6-16 16:46 理想币 +8 任刚: 赠人玫瑰之手,经久犹有余香!
  • 2018-6-16 16:46 共享币 +4 任刚: 赠人玫瑰之手,经久犹有余香!
发消息 加好友
积分
4982 
理想币
62 个 
彩币
0 个 
共享币
15 个 
注册时间
2008-9-30 

复制

好线:=38 ;
平线:=51 ;
OK:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100 ;
RSI2:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100 ;
鱼:SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;
RSI4:=SMA(鱼,7,1) ;
趋势A:=MA(((CLOSE-LLV(LOW,48))/(HHV(HIGH,48)-LLV(LOW,48))*50),17)+9 ;
趋势B:=MA(((CLOSE-LLV(LOW,53))/(HHV(HIGH,53)-LLV(LOW,53))*50),17)+9 ;
趋势C:=EMA(((CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*50),17)+18 ;
A1:=MA(趋势A,7)*1.372 ;
A2:=A1*1.0887;
A3:=(1.5*(趋势B+RSI4)-(A2+A1))+12 ;
鱼网: IF((CROSS(RSI2,RSI4) OR CROSS(RSI2,A3) AND A3<好线 AND RSI1<平线),48,38) ;
  • 2018-6-16 16:47 理想币 +8 任刚: 赠人玫瑰之手,经久犹有余香!
  • 2018-6-16 16:47 共享币 +4 任刚: 赠人玫瑰之手,经久犹有余香!
发消息 加好友
积分
1125 
理想币
44 个 
彩币
0 个 
共享币
42 个 
注册时间
2017-1-23 

复制

这个应该是你想的了:

好线:=38,COLORFF3311;
平线:=51,COLORFF1155;
OK:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORWHITE;
RSI2:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORWHITE;
鱼:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORRED,DOTLINE;
RSI4:=SMA(鱼,7,1),LINETHICK1,COLORWHITE;
趋势A:=MA(((CLOSE-LLV(LOW,48))/(HHV(HIGH,48)-LLV(LOW,48))*50),17)+9,COLORFFFFFF;
趋势B:=MA(((CLOSE-LLV(LOW,53))/(HHV(HIGH,53)-LLV(LOW,53))*50),17)+9,COLOR3377DD;
趋势C:=EMA(((CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*50),17)+18,COLORYELLOW,LINETHICK1;
A1:=MA(趋势A,7)*1.372,COLORGREEN,LINETHICK1;
A2:=A1*1.0887;
A3:=(1.5*(趋势B+RSI4)-(A2+A1))+12,COLORGREEN,LINETHICK1,DOTLINE;
鱼网:=IF((CROSS(RSI2,RSI4) OR CROSS(RSI2,A3) AND A3<好线 AND RSI1<平线),48,38),COLORBLUE,LINETHICK1;

XG:鱼网=48;
发消息 加好友
积分
4982 
理想币
62 个 
彩币
0 个 
共享币
15 个 
注册时间
2008-9-30 

复制

附个图给你。

附个图给你。

附件:

yw33.PNG (31.5 KB)

2018-6-14 16:30

yw33.PNG

发消息 加好友
积分
4982 
理想币
62 个 
彩币
0 个 
共享币
15 个 
注册时间
2008-9-30 

复制

红线上穿蓝色三角
发消息 加好友
积分
1027 
理想币
81 个 
彩币
0 个 
共享币
126 个 
注册时间
2015-11-30 

复制

发新话题
理想论坛 » 指标编写互助答疑区 » 请哪位老师能把这公式改为选股公式,谢谢。
指标编写互助答疑区:积分规则

快速回复主题

选项

发帖请务遵守本站的相关规则,所有发表(包括转发)政治、色情非法信息者本站将实时提供发贴者个人信息给公安局,追究责任,特此申明!
具体规则请参见 理想论坛会员守则》 《净化论坛环境,打击恶意灌水》。

您需要登录后才可以发帖

[完成后可按 Ctrl+Enter 发布]

理想论坛上的网友发表的帖子纯属个人意见,理想论坛不负任何责任!广告赞助商内容与本站无关!免责声明
理想论坛值班电话[9:30~18:30]: ☎ 400 016 5518-1 ☎ 186 4906 9487(广告)187 1028 6081(广告)
找回密码 软件区:1006648222 百宝箱: 1006267111 广告: 1006269111 广告: 3145821447
诚信档案编号:CX20150604010215010383 信誉编号:TL852015042710940
工业和信息化部信息备案: 京ICP备15035364号 京ICP证151057号
关闭底部 打开底部 回顶部 到页底 理想论坛微信号:lixiang55188 扫描下载理想选股App
关闭
关闭