请老师帮忙改写此公式的选股公式

[通达信] 4082 2
设置
1537128 Lv.3

专栏

发表于 2018-9-17 14:39 复制 显示全部楼层 正序浏览 |
跳转到指定楼层
请教老师,看看能否将此选股公式的出信号提前至涨幅8%时,而不是涨停后才有信号!谢谢!!!



VAB0:=531;VAB1:=1510000;VAB2:=VAB0 + VAB1; VAB3:=IF(DATE > VAB2,0,1);
LC:=REF(CLOSE,1);
SG:=EMA(HHV(HIGH,1),8);
X1:=EMA(CLOSE,8);
X30:=((X1 < REF(X1,1)) AND (CLOSE < X1));
X31:=IF(((SG < REF(SG,1)) OR X30),1,0);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
震仓线:=40;
抄底线:=25;
PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线*VAB3;
牛牛:=(((((COUNT((X31 = 1),4) = 3) AND (X31 = 0))AND O<C AND (((C-REF(C,1))/REF(C,1))>0.085))*85) >=85)OR((C-REF(C,1))/REF(C,1)>0.085 AND (REF(PP3,1) OR REF(PP,1))) AND VAB3=1;


JBS:=C/REF(C,1)>1.05 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));
升:=FILTER(JBS,28)*100;
VAR1:=IF((C/REF(C,1)>1.05 AND H/C<1.01 AND C>REF(C,1)),91,0);
VAR2:=FILTER((VAR1>90),45) AND FILTER((VAR1>90),35) AND 升>0;
预警:=VAR2 AND COUNT(VAR2,60)=1  ;



XG:牛牛 AND 预警 ;

[ 本帖最后由 小麦郎 于 2018-9-17 19:48 编辑 ]
来自 湖南省郴州市

举报

使用道具 扔鸡蛋 回复

1537128
Lv.3

专栏

发表于 2018-9-18 08:08 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 湖南省郴州市

举报

使用道具 点亮 支持 扔鸡蛋 回复

1512098
Lv.6

专栏

发表于 2018-9-17 23:31 复制 查看全部楼层 屏蔽
游客,您是(游客)级别,无法查看回复内容,请登录论坛并到新手区学习升级之后才能查看。升级指南请看...
来自 四川省成都市

举报

使用道具 支持 扔鸡蛋 回复

您需要登录后才可以回帖 登录

本版积分规则 《理想财富服务协议》《免责声明》

楼主
3楼
2楼
站长推荐 /5
回顶部 到页底
快速回复 返回顶部 返回列表